PDA

View Full Version : How to make Win XP boot first like before??



medellin58
21st March 2005, 12:49 AM
Hi, right when I installed Fedora, Win XP would boot first if I didnt interupt the booting process, but when I updated all the abailable updates, now to boot Win XP I have to press a key and scrool down to Win XP,
How can I change that order back???
Hope someone can help.
canotech@netzero.net.

Thanks

mnguyen
21st March 2005, 02:50 AM
You check the grub.conf file, there is a line that sets the "default" option. This is the default boot OS when GRUB starts.

The value 0 stands for the first entry in the boot list, 1 for the second entry and so on.
You check order of WinXP entry in the list and put the corresponding value for the "default" option. It should work.

medellin58
21st March 2005, 03:08 AM
Thanks for your help, I'll try it now.

medellin58
21st March 2005, 03:52 AM
sorry to say but it didn't work, I edited the file grub.conf located at "/boot/grub/grub.conf",
I changed the line "Default=0 for Default=3" and didn't work,
There is anything else I can try????
Help.

Zigzagcom
21st March 2005, 03:55 AM
Did you save your changes?

Bob D.
21st March 2005, 03:56 AM
Would you please post a copy of the text from your grub.conf so we can take a look at it? Changing the default as was suggested should have worked. Perhaps something else is odd with the file.

Thanks!

Bob

medellin58
21st March 2005, 04:55 AM
OK, the file grub.conf is the one, OK, but changing the number in front of default= didn't make the trick, instead, I
cutted the lines for Win XP that were at the end of the file (In position 3) and pasted rigth after the hiddenmenu line so win XP was placed first than the other options, leaving "Default=0" as it was originally, and that was it, like this:
default=0
timeout=5
splashimage=(hd0,3)/boot/grub/splash.xpm.gz
hiddenmenu

title WinXP
rootnoverify (hd0,0)
chainloader +1
title Fedora Core (2.6.10-1.770_FC3)
root (hd0,3)
kernel /boot/vmlinuz-2.6.10-1.770_FC3 ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.10-1.770_FC3.img
title Fedora Core (2.6.9-1.667)
root (hd0,3)
kernel /boot/vmlinuz-2.6.9-1.667 ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.9-1.667.img
[root@localhost grub]#

----------------------------------------------------------
I'm sure that what you guys suggested was right but I don't know why didnt work to me.
Any way thanks for pointing me to the rigth file.

Bob D.
21st March 2005, 06:32 AM
Ah, I see what the problem is and why it works now.

Grub, in its own oddness, starts counting from 0, not 1. So when you speak of position 3, it is actually position 2 in "grub speak".

To set XP as the default in your original grub config. with XP in the 3rd podition you would have needed to set the default line to "default=2". Since you moved the XP lines to the first position, the existing "default=0" now works correctly.

Bob

mnguyen
21st March 2005, 09:22 AM
Yes, i stated the zero-based count of grub in my post already. medellin58 did not notice that line :P.

Anyway, it works well now.