PDA

View Full Version : mounting windows to view files



armen
21st March 2005, 12:30 AM
hi,
anyone know exactly what packages i need to be able to access windows thru fc3?

mnguyen
21st March 2005, 02:55 AM
You need no package to access FAT32 partition since FC3 kernel supports it by default.
You just mount the partition to a directory and access it.

$ mount /dev/hda2 mywindowsdrive/ (/dev/hda2 is you windows partition, you can list all the available partition using fdisk -l)

For NTFS, you need to download rpm from this website : http://linux-ntfs.sourceforge.net/rpm/
then use the mount command as shown to do as for FAT32.

artur
21st March 2005, 03:02 AM
Hi Armen
If it's NTFS fs, WinXP, then download the appropriate packages from here(for your version of kernel)
http://linux-ntfs.sourceforge.net/
and you'll be able to read NTFS files from your WinXP partition. You can't write to it though...
To make it mount at the boot edit /etc/fstab adding the following
/dev/hda1 /mnt/winxp ntfs auto,users,exec,ro,umask=0222 0 0
You'll first need to create /mnt/winxp obviously. And also yours might be not hda1 but some other name, check with "df" in terminal.
HTH

artur
21st March 2005, 03:24 AM
Oops sorry, while I was typing mnguyen already posted a solution...

armen
21st March 2005, 11:29 AM
hi,
i tried doing exactly what is written above and windows still doesn't mount.
i even created a winxp folder in /mnt/. any ideas?

if fc3 automatically mounts winxp, why is my /mnt/ directory empty?

electric_head
21st March 2005, 11:43 AM
Which RPM
It is important to install exactly the same version of NTFS kernel module as the kernel you have installed. Below are some simple instructions to help you find the file you need.

A quick way to find the version is to use the
http://linux-ntfs.sourceforge.net/rpm/whichrpm (right-click .. save link as)
Save the file and run it
------------
chmod 700 whichrpm
./whichrpm
------------
this will show you which rpm you need to be able to access winxp partition.
I followed the installation guide in this page and everything goes fine .. and am totally newbie in Linux
http://linux-ntfs.sourceforge.net/rpm/instructions.html

FC3 don't detect NTFS automatically .. you need to do it manually following the easy instructions on this page :)

dickinsd
21st March 2005, 11:59 AM
I just posted elsewhere:

Do you get any errors?

Are you trying to mount hdb with a command like this:


mount /dev/hdb1 /mnt/windows -t ntfs -r -o umask=0222
Or are you trying to auto mount the device using /etc/fstab?

If your using the /etc/fstab then you need to include details for your users and group ID if you want to access the mount when not logged in as root.

A line like this should appear in your /etc/fstab file:

/dev/hdb1 /mnt/windows ntfs ro,umask=0222,uid=me,gid=500 0 0
I wanted my XP partition to mount automatically, and I wanted the mount to appear on my desktop, my /etc/fstab has this line:

/dev/hda1 /home/me/Desktop/WindowsXP ntfs ro,umask=0222,uid=me,gid=500 0 0
Dave