PDA

View Full Version : How to recompile kernel.



vishnumrao
19th March 2005, 08:53 PM
I have been trying to install emu10k1 drivers for my creative sound card. I contacted creative suport who after viewing the error that i was getting, suggested that the sound modules are not present and that the kernel should be recompiled. He also advised me to go through the readme file.

The error that I am getting is shown in another thread posted by the name "sound card installation".

In the read me file this is what they have written:

Requirements
------------
- The kernel must be compiled:
- With loadable modules support (CONFIG_MODULES = y)
- With soundcard support (CONFIG_SOUND = y/m)
- Without any integrated emu10k1 soundcard drivers (CONFIG_SOUND_EMU10K1 = m/n)
- "PnP-compatible OS installed" option in BIOS must be disabled
- Recommended system configuration: Min. 100 MHz Pentium-class w/ 32 MB RAM
- Kernel headers matching the kernel for which you are compiling the
driver.

- For sequencer support, sound.o is required (CONFIG_SOUND_OSS= y/m)

How do I compile the kernel with these above mentioned conditions. Please give me specific stepwise instructions.

Thanks,
Vishnu.

dorian
20th March 2005, 03:01 AM
Hi,

first of all look at this thread: http://www.fedoraforum.org/forum/showthread.php?t=29434. It should make the kernelrecompilation a peace of cake...

Now if you reach stage 4 in the above mentioned HOWTO you will have to look up all the support team mentioned. After typing "make menuconfig" you should see an overhelming lot of Options. Here are the once you need to take into account. Hopefully i missed nothing, but just ask if something is missing. To be on the save side i suggest you give your new beast a name firs, which leave your original Kernel as it was.

Nameing your kernel:
Select (using cursor keys an return) general-setup and the first option and type in a name.

With loadable modules support (CONFIG_MODULES = y):
Go back to main menu and select "Lodable Module Support' the first Option ensures that your kernel can load modules. Should be aktivated by default (Asterix in the brackets maks activation).

Without any integrated emu10k1 soundcard drivers (CONFIG_SOUND_EMU10K1 = m/n)
Go back to main Menu and change to menu Device-Drivers. Then change to submenu Sound. And to subsubmenu Advanced Linux Sound Architecture. Change to subsubsubmenu "PCI devices" and change the setting for option named "Emu10k1 (SB Live!, Audigy, E-mu APS)" and deaktivate this option (just click until brackets are empty).

Only one of the following the sentences "For sequencer support, sound.o is required (CONFIG_SOUND_OSS= y/m)" is relevant for Kernel options and if i were you i would ignore this, cause OSS-Sound is depreciated and thus deactivated by default. It could be that the software supplied by creative is OSS-based, which makes this Option critical. So here are the steps to activation:
Go back to main menu, select the menu "device drivers", then the submenu "Sound", then subsubmenu "Open Sound System", then activate the lonely (or first) option to activate OSS and get a hell of further Options. Just look for Option "Creative SBLive! (EMU10K1) (NEW)" and make sure it is deaktivated.

Now exit all menus until you are asked to save the config. If you want to do everything all over again click no, otherwise click yes!

Folllow the white rabbit (allways a good thing) and continue as described in the above mentioned thread.

Be sure to configure your bios to be conform with these instruction:
- "PnP-compatible OS installed" option in BIOS must be disabled

You might want to check if everything worked out: Have a look in directory /boot. There should be your new kernel vmlinz<whatever> (you can identify it by the name you gave him), an initrd<whatever>.img and some other files for your kernel. There should be a subdirectory "grub" with a file called "menu.lst" in it. See if your kernel is mentioned in this file. If this is not the case you can copy the entry of fedora and change vmlinz and initrd entry to your kernel, edit the name too. (To deaktivate you kernel just remove these lines.)

Then do it the windows way: Reboot the System and select your new kernel from the bootmenu. If it panics (It will say so in the commandline) just hard reset and boot the original kernel (normally if the kernel panics, it was not able to read from disk. Therefor the reset should not matter at all). Thats about it.

Hope that helps.

Dorian.
P.S.: I will not take any responsibility for these instructions, but i will anser further questions if you have them.