PDA

View Full Version : FC Installation Problem on MSI 915G Combo



darkb0e
18th March 2005, 12:10 PM
Hello ppl!
At first:
M/B: MSI Combo 915G
CPU: 2.8Ghz (LGA775)
RAM: 2 x 512@533Mhz Kingston Running at dual Channel
VGA: Onboard
SCSI: Adaptec 29160
HDD: MAXTOR ATLAS 15K 36Gb(SCSI)
LAN:Onboard (i think its a Marvell Chip)

The Problem:
When I am trying to install the box give me

CPU: 0
EIP: 0030:[<c00f0488>] Not tainted VLI
EFLAGS: 00010246 (2.6.9-1.667)
EIP is at 0xc00f0488
eax: 0000b100 ebx: 00000000 ecx: 00002504 edx: 25808086
esi: 00000000 edi: c03798cc ebp: 00000000 esp: dfc87f70
ds: 007b es: 007b ss: 0068
Process Swapper (pid: 1, treadinfo=dfc87000 task=dfcb1730)
Stack: b1000400 c00f026b c00f028d 00000400 000098cc 00002570 0100b102 8086c00f
00540000 0246c00f c02a4cd0 00000060 dfc87fbe dfcab400 00000000 00000000
c02a51b9 dfc87fbe dfc87fbf c03c6d86 dfc87fc0 dfc87fc0 c03d1674 00000000
Call Trace:
[<c02a4cd0>] pci_bios_find_device+0x19/0x38
[<c02a51b9>] pcibios_sort+0xc9/0x14b
[<c03c6d86>] pcibios_allocate_resources+0xeb/0xfc
[<c03c77e7>] pcibios_init+0x65/0x68
[<c03b1702>] do_initcalls+0x49/0x8e
[<c010051b>] init+0xc1/0x1f3
[<c010045a>] init+0x0/0x1f3
[<c01041d5>] kernel_thread_helper+0x5/0xb
Code: 81 fe 00 ff 75 05 8a c1 ee eb 11 66 81 fe 01 ff 75 07 66 8b c1 66 ef eb 03
8b c1 ef 66 9d 66 5a 58 f8 c3 c3 c3 66 50 66 53 b7 00 <2e> 8a 83 96 04 00 00 66
5b 8a d8 66 58 c3 00 01 02 03 04 05 06
<0>Kernel panic - not syncing: Attempted to kill init!

I have tried FC2, FC3, FC4 Test1 none worked, the message was the same except the kernel version!!!

Please Help me!

mndar
18th March 2005, 12:41 PM
When exactly during the installation process are you getting these error messages?

darkb0e
18th March 2005, 12:50 PM
In the first boot screen i hit enter (boot: (enter))
then it shows
Loading vmlinuz...........................
Loading initrd.img.......................................
and then the message :(

darkb0e
18th March 2005, 01:06 PM
If i give linux mem=1024
it does not shows the error but it displays
Uncompressing Linux... Ok, booting the kernel.
and STUCKS there!

mndar
18th March 2005, 03:43 PM
I tested this for FC3
1>Burn the boot.iso file from the first FC3 CD, images folder to a RW and try booting from that.
If that doesn't work try this.
2>Download the testing.zip file that i have attached.
a> Copy the vmlinuz and initrd.img files from the first FC3 CD, isolinux folder to a directory 'fc3' on your harddrive.
b> write the grub.img file to a floppy using
In Linux: dd if=grub.img of=/dev/fd0
In Windows: rawwritewin.exe
c> boot from the floppy
Press 'c' at the main menu to get into the command line. Type in
root (hd0,0)
'hd0' and '0' are the HDD and the partition number respectively.Remember there is a space after 'root' You might have to replace hd0 with sd0 since you have a SCSI disk. Press TAB after typing 'root (' to get the possible options. The digit after hd0 or sd0 is the partition number. You can press TAB after 'root(hd0,' , to list the possible partitions. Assuming the vmlinuz and initrd.gz files are in a directory 'fc3' in the partition you specified earlier, type
kernel /fc3/vmlinuz
initrd /fc3/initrd.img
It will work only if this is a FAT32 or Linux partition. It won't work if it is a NTFS one. You could choose to install from the HDD itself IF u have the ISOs stored.

darkb0e
21st March 2005, 11:03 AM
i have tried both, none worked, i have setup the fc3 on different m/b and all worked, moved the disk to this machine caused the same problem, i have disabled ide controller, acpi, sound card, lan card, again nothing worked!!!
plz help!!!
i need to buy i new m/b? have u ever tested a 775 socket motherboard with DDR2, and onboard Graphics?plz help me..

darkb0e
21st March 2005, 12:20 PM
i have found a solution at http://www.linuxquestions.org/questions/history/280217
it was boot: linux pci=nosort text but i dont know whether it runs X windows...does anyone have X on 915G Chipset?

darkb0e
21st March 2005, 01:32 PM
All worked OK at last, i have my new machine up and running FC3!the solution was the option pci=nosort
Thx all the ppl for the help!