View Full Version : Anyone try xorg-x11 from rawhide?

17th March 2004, 08:21 PM
I just saw today that there is xorg-x11 rpms available for the xorg fork of xfree86 and im curious if anyone has tried it out yet. I am interested in giving it a shot and seeing if the official nvidia drivers will work with it or not.

18th March 2004, 02:30 PM
i thought about it, but when i started to install it required me to remove a lot of apps, including openoffice and, of course, XFree86. i may try it out anyway in order to submit bug reports. i think the change is a good thing, since XFree86 was becoming very "closed" to open development.

/. has an article with some interesting responses:

20th March 2004, 10:10 PM
just did

after manually taking care of xfs and ld.so.conf, everything seems to be ok

$ chinput
Chinput Version 3.0.2 -- XIM Server
Distributed under the terms of the GNU General Public License (GPL)
Error : XCreateFontSet() !

22nd March 2004, 06:06 AM
redhat71, could you explain the steps you took to fix xorg - postinstall...

i'm kind of in the middle of it and having trouble getting X to start. i have "/usr/X11R6/lib" in /etc/ld.so.conf

what else am i missing?

i'll post more after trying some more things..

22nd March 2004, 02:02 PM
the installation(rpm -Uvh xorg*) was quite smooth except there were a few packages that have dependency problem, i manually solved them by downloading the latest version of those packages

the extra work i read from the maillist are the ld.so.conf and xfs service
since you've taken care of the ld.so.conf, just take a look at xfs
if it's not running, "/etc/init.d/xfs start" and try "startx" again

ps: i rarely know anything about X or lib, there's not much i can help
if you need more info, i suggest you check the maillist, this topic is kind of HOT recently