PDA

View Full Version : MPlayer - Very distorted audio with XViD files - recorded on Archos AV420



linuxnewbiestu
16th March 2005, 01:28 AM
Hi everyone,

First of all, I'm pretty new to Linux, and it's been a challenging week or so to get sound, graphics, and various other bits up and running, all I can say is thank smeg (red dwarf ref there) for yum!

My current problem is this - I have used yum to get mplayer, including all the skins etc.

I can play mpegs fine it would seem, but when it comes to trying to play the XViDs (AVI Files) that my Archos produces I get audio distorition if I try to search through the video, listening to it it appears to be the audio from the start of the file overlayed on top of the current section's audio.

This is driving me potty as I'm trying to escape Win XP for my video viewing - editing comes next :-) I've installed the all codecs pack from mplayerhq.hu into both /usr/llocal/lib/codecs and /usr/liblocal/win32 (as suggested in another post) But with no joy - maybe I'm doing something wrong in the video and audio codecs preferences in MPlayer. My sound system is ALSA 1.0.8

I would be appreciative of any help people can give

thanks - Stu

PS. More info on my system :
P4 3.6, 1gb RAM, ATi Radeon X600 256mb graphics, 2 x 250gb SATA HDDs (Linux gets 82gb of that to itself and 32 as a FAT32 partition to share files with my Win XP install)

linuxnewbiestu
16th March 2005, 01:29 AM
Oops, forgot to say I'm running Fedora Core 3, 2.6.10.770 kernal with Gnome

Sorry about that!

Woad_Warrior
17th March 2005, 03:26 AM
try running mplayer from a terminal. it should tell you what is happening. (if the problem isn't clear, post any error messages it outputs.)

linuxnewbiestu
17th March 2005, 02:55 PM
I ran mplayer in a console - mplayer enterprise-storm-front.avi (which is one of the files I recorded from my archos) no notable error messages when I did the video search (fast-forward / re-wind) but there was some stuff about vidix? I've included it here for you to see - chopped to the relevant section because I have a radeon x600


No vidix driver name provided, probing available ones (-v option for details)!
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
[radeon] Error occurred during pci scan: Operation not permitted
vosub_vidix: Couldn't find working VIDIX driver

Acording to the data on the console mplayer is using the following codecs

Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)


Opening audio decoder: [imaadpcm] IMA ADPCM audio decoder
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 24188->192000 (193.5 kbit)
Selected audio codec: [imaadpcm] afm:imaadpcm (IMA ADPCM)

This problem doesn't ocure on any of my MPEGs - some are DVD rips some are videos I produced myself.

For your info my soundcard is an onboard Intel High Definition Audio chip (only supported in ALSA 1.0.8 - at least I think that's the case)

thanks

Stu

---
9 Days to Go - The Doctor is coming home, and this time let's hope it's for good - 7pm - Saturday 26th March - BBC ONE

Woad_Warrior
18th March 2005, 01:03 AM
try this:
mplayer -vo xv name-of-file.avi
(also try in su (superuser) mode.)
if these ideas fail, then i'm at a loss. (it took half an hour with google just to dredge these ideas up)

linuxnewbiestu
18th March 2005, 01:42 AM
Woad Warrior - thanks for the effort - much appreicated - it didn't make a difference to the audio problem but I didn't get the vidix messages.

Because of that I noticed something else

Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scrpts.i
that doesn't happen if I use the SU command and then run the command you gave me - on first thoughts I associated RTC with real-time-clock - making some weird connection with the time-coding on the video - however when I tried to do the video search it didn't make a difference with SU - but just out of interest what file would I add that line too?

Thanks once again, if there's anything I can do for you let me know - ashamedly I'm pretty hot on Winblows (what a mispent few years!)

Stu

Woad_Warrior
18th March 2005, 04:20 AM
you might find an answer or 2 on that last error with this google search:
http://www.google.com/search?hl=en&q=Linux+RTC+init+error+in+ioctl+%28rtc_irqp_set+10 24%29%3A+Permission+denied&btnG=Google+Search

afraid the only windows help i need is getting my family to stop using it. :D

linuxnewbiestu
18th March 2005, 05:34 AM
Thanks Woad Warrior, for all you help - I'll hope someone has had the same problem, and fixed it, finds my thread.

I know what you mean about getting family off Winblows - I swear I've had to do 2 reformats / reinstalls of xp a month for the last 2 years on my families pc cos of spyware / and microsoft junk in general!

linuxnewbiestu
18th March 2005, 05:38 AM
Thanks again Woad Warrior, very much appreciated - I'm not 100% bothered about these xvids - though it would be nice to play them in Linux - but my Archos has a nice TV out facility - so bang them up on the old 23" LCD widescreen!

Windows is a pain in the neck - I swear I've had to do at least 1 reformat / reinstall of Windows every month or so since my folks got their new PC up and running - there's so much spyware it's unbelievable, my sisters boyfriend doesn't understand the term so clicks on every bit of advertising going!