PDA

View Full Version : Setting Thunderbird as default e-mail client in Firefox



4ebees
10th March 2005, 12:30 PM
Hi all,

First of all I'd like to say thanks to everyone that has helped me previously. I'm new to FC3 and have found the support here to be very impressive.

My current problem is that I cannot work out how to make Thunderbird the default e-mail client when clicking on an e-mail link in Firefox. :confused:

I'm using Ffox 1.0.1 and Thunderbird 0.9

I've managed to do this in my 'other' OS, but cannot work it out for my Linux box. I've had a look on the Mozilla forum and Firefox and Thunderbird support - most of it is about Winders.

I'm using a fastmail account - this is all fine and works okay. I uninstalled Evolution and changed the KDE setting to Thunderbird as default. So when I click on an e-mail link in Konquie, it opens T'bird... but Firefox doesn't do anything.

Any help, advice, redirection/referral most appreciated.

dickinsd
10th March 2005, 12:53 PM
With FC, I think this is more down to the Fedora preferences than Firefox's preferences.

If you go to you Applications menu, down to Preferences and More Preferences, and then choose Preferred Applications, the window that opens has a tab for Web Browser, Mail Reader, Text Editor and Terminal.

Goto Mail reader, click the option to select a mail reader, and choose Thunderbird.

click OK, and then try using a mail link in firefox, this should now open thunderbird for you.

Hope that helps

Dave

greatscot
10th March 2005, 01:16 PM
I believe dickinsd is correct. That is how I solved this problem on my box.

Paul_Vandenberg
10th March 2005, 01:30 PM
In order for the above to work, you need to have Gnome installed or at least gnome-control-center, even if you use KDE.

dickinsd
10th March 2005, 01:36 PM
Oh good point, I don't actually use KDE, I only use Gnome, so wouldn't know how to set default applications using KDE or whatever your choice of desktop manager is.

Good catch Paul_Vandenberg

Dave

4ebees
10th March 2005, 01:59 PM
With FC, I think this is more down to the Fedora preferences than Firefox's preferences.

If you go to you Applications menu, down to Preferences and More Preferences, and then choose Preferred Applications, the window that opens has a tab for Web Browser, Mail Reader, Text Editor and Terminal.

Goto Mail reader, click the option to select a mail reader, and choose Thunderbird.

click OK, and then try using a mail link in firefox, this should now open thunderbird for you.

Hope that helps

Dave


[SIZE=4]Hi there,
In KDE, Preferred Applications, doesn't exist. I did go to component chooser in the Control Centre menu and select T'bird there. It works fine in KDE, but Ffox is still not compliant.

Should I also choose Ffox as the default browser? - nothing is chosen at the moment. I always have Ffox open anyway.

dickinsd
10th March 2005, 02:17 PM
Hi there,
In KDE, Preferred Applications, doesn't exist. I did go to component chooser in the Control Centre menu and select T'bird there. It works fine in KDE, but Ffox is still not compliant.

Should I also choose Ffox as the default browser? - nothing is chosen at the moment. I always have Ffox open anyway.
Yeah sorry, I jumped into that a little too quick, I think Paul_Vandenberg has corrected me on that one:

In order for the above to work, you need to have Gnome installed or at least gnome-control-center, even if you use KDE.
The gnome-control-center maybe a way of doing what I suggested in KDE.

Unfortunately 4ebees, I don't like KDE, so don't have it installed on my own machine, so I cant make any useful suggestions.

I am sorry about that

Dave

4ebees
13th March 2005, 01:45 PM
Thanks to everyone for the suggestions.

I've decided - though I'm not really happy about it - to reinstall Evolution; it works well with Ffox and so....

4ebees
22nd March 2005, 04:34 AM
Hi all,

I found a solution:

It was suggested to do this:

close Firefox and Mozilla

locate the '.default' file in .mozilla, which for me is:

/home/4ebees/.mozilla/firefox/lzg3oqdj.default

If there is not a file named 'user.js', the create one with a text editor.

Insert the following, exactly as stated:

user_pref("network.protocol-handler.app.mailto","/usr/bin/thunderbird");

the save and close.

Then boot up Firefox and Thunderbird will now be your default e-mail client when using mail links in Firefox.

nordicart
22nd March 2005, 05:05 AM
Hi,
For changing the default user account defaults, you can run gconf-editor and change the value of the key from evolution to thunderbird. It is located under desktop-->gnome-->url-handlers-->mailto
Or you can edit the text file located at /home/$HOME/.gconf/desktop/gnome/url-handlers/mailto and change evolution to thunderbird

joejohnston77
25th June 2007, 01:31 PM
I know this thread is over 2 years old, but I wanted to drop a thanks to 4ebees for the solution i was looking for.

So thanks. :)

Joe