View Full Version : Installation Problems

8th March 2005, 05:20 PM
Hi All,

Is there some information that I can access showing me ( newbee to Linux ) step for step instructions on installing the latest versions of Apache Server, PHP, MyPHPadmin and MySQL. I've tried everything I can possibly think of ..... and yes being new I've probably done 100's of things wrong to start off with but I'm totally lost.

Here's what I've done so far..... which doesn't work.

Reinstalled Fedora Core 3 with all updates (via up2date) then installed apt's synaptic to make further installs easier.

Upgraded MySQL to 4.1.10... appears to have worked when I check synaptic.

Install Apache 2.0.53 source and successfully compiled with make and make install. Everything seems fine except that the older version 2.0.52 is still installed and I can't remove it. I disabled it in the services utility and added /usr/local/apache2/bin/apachectl start to the rc.local.... seems fine.

Installed PHP 5.0.3 from source and successfully compiled with make and make install.

Installed MyPhpAdmin 2.6.1 patch 3, Drupal and extracted it to the proper docuement root folder.

Edited the configuration files both Apache & PHP as per instructions.

After all that I'm unable to access MySQL via MyPhPAdmin because of some security issues I still today don't understand. I think a complete step for step guide of some sort is what I need or atleast someone tell me what the versions of each app is.


9th March 2005, 07:24 AM
Any error messages when you try phpMyAdmin? Does it complain about a password or account?

9th March 2005, 11:56 AM

Current error is happens when I attempt to open index.php from the browser:

Fatal error: Call to undefined function PMA_DBI_get_dblist() in /usr/local/apache2/htdocs/phpad/libraries/common.lib.php on line 1410. Something about the host name being empty.

9th March 2005, 01:42 PM
have you checked your config file for phpmyadmin? Are you able to post that on here

9th March 2005, 02:24 PM
Hi weaved,
I think by following the article
you are asking these questions........................................
Have you completely followed the article............or have you mixed it up with different articles on various books?
Why are you using apt-get and up2date.........the reason is that apt-get will not install the very latest versions by default unless you have added them in you repository files. Thats why we download the source files and install them manually...................The article has worked for me and many others.
I think you are mixing it up with various other articles in books............There is no hostname you have to specify in phpmyadmin.......as far as the versions of the softwares are required I have given the link also in the how-to article.............If you are following the article please dont use apt-get............You can use apt-get to install only the dependencies but not the packages because you will not be able to configure the package as per the requirements.
According to me now, just follow the article completely from the beginning (forget about what you have installed till now) and if you have any problems please let us know...........fedoraforum is always here to help you out

9th March 2005, 05:19 PM
When I get home I'll post the config file for review.


9th March 2005, 05:39 PM
Hi Weaved,
Do try mambo.........it is also like Drupal but has an automated setup..............So there is no need for PHPMyAdmin............

9th March 2005, 07:37 PM
Hi raghavendra,

Appreciate the suggestions. All I really want is to the latest versions of Apache, Php and MySQL installed on my server and that I can use some kind of GUI to build my database. I'm starting to feel really like an idiot not being able to install these applications. I'm going to gut my system ..... again and start over but this time I'm not going to update anything before installing the apps as per your howto. Then I'm going to install apt & synaptic to allow for any missing dependencies. How does that sound ?

When I reinstall the core again..... what packages should I install ? Previously I selected the development package (to get the compiler & PHP), MySQL and Web Server.


9th March 2005, 07:48 PM
Dont hessitate to ask..........Even I am an idiot ;)
As far as reinstalling is concerned I dont think it is necessity; but if you still want to reinstall I have the following suggestion,
Do you have the disk space to install everything ............
if yes just choose custom and during package selection choose everything
by this way you will not have dependency problems and there will be no need to use apt-get while following the how-to article.

10th March 2005, 04:22 AM
Hi raghavendra,

Great news..... it works...... thank god ! My next question is what the heck did I do wrong before this ?

A couple of further questions.... Your walk through said create a table Drupal and import it from /usr/local/apache2/htdocs/drupal/database/database.mysql. The opening screen was asking me to create a database.... which I assumed was Drupal..... and then add tables to the new database. I couldn't find an import function..... not sure what you mean.

Would you not recomment upgrading the mysql to the latest level from here..... just curious but now that it's working I won't mess with it if you don't think it's a good thing from here... let me know.

again... much thanks,

10th March 2005, 04:45 AM
I am happy that it worked fine..............But what did you do to make it work.............Did you reinstall fedora???
Please let me know.
As far as Drupal is concerned follow these steps
open your webbrowser and give http://localhost/phpad/index.php
then there are two columns on the right hand side........one is MySQL and the other phpMyAdmin
under the MySQL there is an option to create a table............type drupal (any name you can give, but the article follows name as drupal) and click create........then click SQL on top
Below you will see

Location of the textfile:

Just click on browse point to /usr/local/apache2/htdocs/drupal/database/database.mysql
and click OK and GO..............all the tables will be imported to MYSQL..................Thats the advantage of using PHPMyAdmin.

To which version of MySQL do you want to upgrade??Ofcourse there is nothing wrong in trying out new things :)

10th March 2005, 12:58 PM
Hi raghavendra,

I reinstalled fedora 3 from scratch, selected custom package install as you suggested and selected all packages. I had one problem with the install, something went wrong with the Php 5.0.3 make because it didn't create the libphp5.so and failed when I started apache..... so I went back to that step in the walk through and redid it making sure the configure command was correct and after that I was able to start apache and open the index.php page. All I can attribute is there's something wrong with the dependency check when you select server install instead of custom and select specific packages from the package list.

The version I want to move MySQL is 4.1.10 and rpmfind has some rpms. Just want to start off with an up to date version of Apache, MySQL & PHP but don't get me wrong.... I'm real happy to atleast be able to have a GUI environment for databases instead of command line.

Also would you recommend staying with the default updater being yum or get involved with apt / synaptic ?


10th March 2005, 02:06 PM
I dont think there is anything wrong with custom package selection........maybe you left out something while selecting.........................Installing everything is a crazy thing to do, but for starters it is good since you will not be having problems with dependencies..........thats why I suggested it to you..............And coming to the creation of libphp5.so yes there are problems reported in many forums but you can get it running by trying twice or thrice :)
If you want to try out with upgradation there is nothing wrong...........but if you are hesitant of messing up the old one, try taking an image of the system (If you have space for it) and then trying out...........if something goes wrong also you can just restore the image and have a working copy of the old one.
Deciding between apt-get and yum is your personal choice...........for me I use synaptic (a graphical interface for apt-get)...........but there are interfaces also for yum like gyum...........So you can try out any and stick on to one you like :)
Do let me know how my posts are........Are they useful :)

11th March 2005, 02:31 AM
Hi raghavendra

Well the good news is my linux isn't broke...... bad news is ( not really that bad ) it just appears to be 2 versions of apache installed.... you got me ..... how that happened. When I attempt to manually start the apache with /etc/init.d/mysqld start I get an error stating that mysqld doesn't exist. Ok... I check the mysql web page and determine the command is mysql not mysqld and that works and I can access the newer database being (4.1.10).... fine. If I go into the services dialog and enable httpd to start automatically (check mark in the box) and reboot apache 5.0.52 is loaded and it can't find the database.

So.... I quess I can leave the original apache disabled and put the proper start command in the rc.local file to boot the correct version of apache or can I remove the older version from the os and if so how ?


11th March 2005, 10:18 AM
No dont remove the old version, just keep it disabled (anyway it will be disabled by default after the setup of FC3)..........You will not have any problems with the old one :)

11th March 2005, 11:38 PM
Hi raghavendra,

I've hit on a snag.... I can't bring up the default website http://localhost/drupal it failes and tells me I can't select the database.

unable to select database

I noticed when I was accessing the index.php that it was complaining about the absoluteuri which I changed to localhost/phpad/ but that didn't resolve the above.... your thoughts ?


12th March 2005, 09:41 AM
I am unable to get what problem you are facing...............What's your ip................If you dont know it just visit www.whatismyip.com and pass on the number so that I can visit your computer and see the error.............. :)

12th March 2005, 01:44 PM

After you create the database drupal and run the script to add tables to it. You open your web browser ( on the server locally ) http://localhost/drupal it fails and gives the message unable to select the database. I'm assuming there's a sample web page and database that you can have a look at. I know what the IP is of my server because it's static.


12th March 2005, 02:22 PM
Just try this
$db_url = "mysql://user:password@localhost/prefix_drupal"
notice the prefix_ before drupal.

13th March 2005, 04:51 PM
Hi raghavendra,

Just to followup with you on everything todate. I've got the latest versions of PHP, MySQL and Apache installed and I'm able to access the database. The only thing not working is Drupal.... and that's ok with me. I'm able to use PHPAdmin to setup test databases and access those via PHP which will allow me to learn more about the environment. Not sure what's wrong with Drupal but I'm going to push ahead with what I've got working.

Really appreciate all your help and hope I didn't give you too many headaches.... newbie caused.

Thanks Again,

13th March 2005, 05:32 PM
I am happy that my posts helped you :)
As far as Drupal is concerned that should work.........I had no problem with it..........The only problem which I faced, I have put up in the article itself with the solution...
Maybe this might help you
And I also suggest you try out mambo :)

13th March 2005, 08:17 PM
:) weaver, make sure you have also created a password for the mysqluser. It is a commonly overlooked problem. There also may be a test database and default users that you might want to delete. Just checking.