PDA

View Full Version : Gdk problem



Elbryan
23rd February 2005, 08:14 PM
I've almost written in all part of the site :P.
Well .. i'm trying to install the GDK to install after lMule :D

First i've installed glib-2.3.1 (configure and make).
Afterthat i tried to install in the same way the gtk+ too. (vers. 1.2.9) but when
i launch the "./configure" .. here are the results:



checking for dgettext in libc... yes
checking for msgfmt... /usr/bin/msgfmt
checking for dcgettext... yes
checking for gmsgfmt... /usr/bin/msgfmt
checking for xgettext... /usr/bin/xgettext
checking for catalogs to be installed... az ca cs da de el es et eu fi fr ga gl hr hu it ja ko lt nl no nn pl pt pt_BR ro ru sk sl sp sr sv tr uk wa zh_CN.GB2312 zh_TW.Big5
checking for extra flags to get ANSI library prototypes... none needed
checking for extra flags for POSIX compliance... none needed
checking for glib-config... no
checking for GLIB - version >= 1.2.8... no
*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.
configure: error:
*** GLIB 1.2.8 or better is required. The latest version of GLIB


What i have to do to resolve this mistakes!?!?


Thanks all!

addarich
24th February 2005, 01:47 AM
check the ./configure --help, I think there is a option to disable the test for glib, after you disable it, you should be able to compile gtk without any problem

Jman
24th February 2005, 03:37 AM
But installing it should be as easy as
yum install glib-devel

Elbryan
24th February 2005, 07:08 PM
and for the gtk-devel? what i must do?

Jman
25th February 2005, 06:27 AM
There's two versions, looks like you need gtk+:
yum install gtk+-devel See the pattern? :)