PDA

View Full Version : External USB, Kernel Panic, HELP!



guy
18th February 2005, 10:36 AM
I went to boot up the computer last night, and was faced with the following-


Checking filesystems
/boot:clean 30/26104 files, 9249/104388 blocks
/home2 has been mounted 24 times without being checked, check forced
Error reading block 229389 (Attempt to read block from system resulted in short read) while doing inode scan.
/home2: UNEXPECTED INCONSISTENCY; RUN fcsk MANUALLY. (i.e. without -a or -p options)
***An error occurred during the file system check.
***Dropping you to a shell' the system will reboot
***when you leave the shell.

This morning, when I tried again, I got-


audit (1108714753.4294966829:0) initialized Red Hat nash version 3.5.22 starting
Out of memory: Killed process 158 (hotplug)
159
161
160
1(sh)
rhgb@ /usr/bin/rhgb: cannot execute binary file
kernel panic: Attempted to kill init

I'm using FC2, and the USB drive is added as Home2 according to the instructions on this page- http://fedoranews.org/tchung/storage/.

I have no idea at all what the above means, so help would be greatly appreciated.

Firewing1
18th February 2005, 02:28 PM
Hi,
Firstly, we need to know the following:
-Your system type & stats
-Does your BIOS support USB boot?
-Has it worked before?
-Did you run the manual fsck?
Once we have this info we can help you out. I had the same problem and it was b/c I couldn't boot from a USB drive....
Firewing1

guy
18th February 2005, 02:56 PM
Thanks for the reply- I'm off home in a couple of hours and won't be able to access the web on a computer that won't start after that!

- System type and stats- good question. What info does that entail? I can tell you that it's an IBM machine with a Pentium 3, a USB 2 card I installed myself, a DVD writer, CD drive, and a Creative sound card.

- Bios/USB boot- I have no idea. How do I find that out? I use the external drive to save music, not for anything else, so I don't think it should relate to booting.

- Worked before- yes indeed, for a few weeks now.

- Manual fsck- I don't know what that is or how to use it.


Ok, maybe not much extra info there, but that's because I don't really use the computer for much besides the web, burning cd's, etc.

Thanks!

mjman
18th February 2005, 04:34 PM
Actually, I just build a computer, and installed fc3 on it. I accidentally didn't connect the ide-cable for the hdd to the motherboard very securely. Anyways, while I was setting up fc3, actually i think i was doing an update with yum, the harddrive disconnected from the motherboard. I did a hard shutdown, and upon the next boot, I got the same exact error as you. i ran fsck manually, (just type fsck /dev/<partition>), and it found more than 10,000 filesystem inconsistencies. Anyways, after that, I rebooted, and got that second error, the cannot execute binary error. I plugged in the drive as an external drive for my laptop to look at the filesystem, and discovered that many many files were missing or corrupted. So, I think you might be screwed =(.

guy
18th February 2005, 05:20 PM
What does this mean? Do I need to replace the hard drive, or just reinstall FC2?

Firewing1
19th February 2005, 03:32 PM
Hi,
Thanks for the Info! If it's an IBM, when you start up, there should be a message somewhere on the screen, lasting but 1 or 2 seconds, that says something like "Hit F12 to enter setup". If you hit the key, you will enter your BIOS. This is unnessicary, though, because if you successfully booted from the USB drive before, your computer is therefore capable. For the system specs, I was thinking the FSB + processor speed, amount of RAM, ##GB harddrive, etc...
For the manual fsck, just use the FC install CD, and type "Linux rescue" into the boot prompt. When you get to the terminal, use "fsck /dev/hda".
Firewing1

guy
21st February 2005, 02:55 PM
Thanks for getting back to me, man.

As far as I know I've never booted from the USB drive, since as I mentioned, it just has/had music on it.

The processor runs at 700mhz, the RAM is 128mb, the external HD is 160gb, and the internal one is around 9gb. I think it might be time for a new machine!

I can enter BIOS without an issue, but since it's all in German, I can't work out how to get the machine to boot up from my FC2 CD! I put the disc in either of my 2 drives, but they won't read it before I get trapped with the second of the 2 lots of code that I put up above. I no longer have the option to run fsck, by they way.

Firewing1
22nd February 2005, 10:55 PM
Hmmm..
This will be tough then. Basically, you need a way to boot from a medium, whether it be a CD or Floppy that will let you run fsck. If you can't edit your BIOS, then I'm sorry, but I can't help... (Maybe it would be time for a new computer ! ;) )
Firewing1

guy
23rd February 2005, 11:29 AM
Well, I bought a new machine yesterday, so now it's just a matter of waiting for the new one to arrive, and getting the old one to the charity shop. It's got an AMD 64 processor, and I'm going to be using FC3, so I'll be back here again before long, no doubt...

Thanks!

Firewing1
24th February 2005, 10:34 PM
One thing to be careful of when installing FC3 is the boot loader. If you still want WinXP to boot on it, (It usually comes pre-installed, and is good to have as a backup...) you have to configure advanced boot options when installing...
Firewing1.