View Full Version : Samba SWAT: Connection refused!

13th June 2004, 02:55 AM
This Samba thing is really getting me down. Can't get it to work AT ALL!!! Read about the SWAT thing, and tried to start it with Localhost:901, but I get a Connection refused error message. Can anyone give me clear, complete, and step by step instructions on how to get Samba to work, both from the Linux server side and from a Win98 client box? Don't just refer me somewhere else, I've tried every link I can find and somehow they all have failed to work. And some of them have conflicting directions!!!

13th June 2004, 03:46 AM
Try the following steps
as su
1 modify /etc/xinetd.d/swat by using an editor eg vi or gedit etc..
2 change disable = yes to disable = no
3 save and quit
4 as su
5 #/etc/rc.d/init.d/xinetd restart
then in mozilla web browser type http://localhost:901.
That should work.

13th June 2004, 03:54 AM
Also this how to was posted and works for others.http://www.fedoraforum.org/forum/showthread.php?s=&threadid=2556

There are also great examples and how to on your fedora installation. FC1 is a bit different. FC2 in /usr/share/doc/samba-3.0.3/docs there are pdf files that explain how to samba network with other operating systems. Samba-Guide.pdf has different examples and how to implement.

13th June 2004, 04:13 AM
A couple of things to check:
If trying to conect from the Windows box ,make sure and insert the "IP Address of the Windows box" into /etc/xinetd.d/swat/ as shown below.
Make sure the linux box has a user account that matches the user name and password that you are trying to connect with.
Also a password must be added to the samba account. On the linux box type: " smbpasswd -a " then enter the same password as the linux user account above.
Another thing in the "smb.conf" file make sure the "encrypt passwords = yes" line is in the global section.

# default: off
# description: SWAT is the Samba Web Admin Tool. Use swat \
# to configure your Samba server. To use SWAT, \
# connect to port 901 with your favorite web browser.
service swat
disable = no
port = 901
socket_type = stream
wait = no
only_from =
user = root
server = /usr/sbin/swat
log_on_failure += USERID

16th June 2004, 05:47 PM
if you still have problems, you might need to open that port in your firewall temporaily, and make sure the samaba port is open if you want to sahre anything