PDA

View Full Version : sk98lin does not compile in FC3



ewsforos
1st February 2005, 06:17 PM
Hello ppl,

Just set up a new box. Specs:

P4-550@3.4GHz
Asus P5AD2-E PREMIUM
1Gb DDR2@667 RAM
Geforce 6800GT
1x Maxtor Diamondmax plus 10 250Gb 16Mb cache
2x DVDRs
Enermax 600W PSU

Not that all that is revelant but it may help some other people understand exactly my problem. Maybe some with similar setup?

Anyway... I've managed to configure the sound with the latest version of alsa.

My major problem is the sk98lin module for the onboard Marvel Yukon 8053 PCI-E Gbit Ethernet.

I've tried 2.9.xFC kernels, 2.6.10xFC kernels, and 2.6.10 vanilla kernel. The module will not compile. It gives an error in the beginning of the compilation (MODPOST).

I've tried the _4, _6, _7 (from marvel + asus cd) and _9 (syskonnect) versions. In all cases it fails to compile. I'm deeply troubled by that because by not having network in linux I have to go back to windows xp (Which I installed for that reason), download upgrades/kernels/drivers/whatever, put them in my usb-stick, boot back to linux and try to solve the problem (loop).

I've even downloaded manually all basic system upgrades from an ftp mirror and -ihv-ed them manually. Still no luck. I'm out of ideas...

Is there anyone here who was able to make the damn thing work? :confused:

Thanks in advance...

schildre
1st February 2005, 07:44 PM
Is there a specific reason that you need to compile this module? If ease of use is your main objective, it looks as if the precompiled file sk98lin.ko is contained in the kernel package (I'm looking at kernel-2.6.10-1.741_FC3.i586.rpm). Is there a line for this module in the file /etc/modprobe.conf? What happens when you type:

$ lsmod | grep sk98lin
or, if that gives nothing, type (as root)

# modprobe sk98lin

Also, does dumping the startup messages by typing
$ dmesg | grep sk98lin show anything that might give a clue why this module isn't loading? Sorry I don't have any special knowledge about network cards, just trying to make some general suggestions that might help narrow down your search for the problem.

ewsforos
1st February 2005, 07:48 PM
Yes, the kernel does have sk98lin and it seems to load just fine. The problem is that it doesn't work. Whenever I try to enable/do something with the network card I get a "device not found/working" (don't remember the working exactly). It simply cannot "see" the eth0 interface. The module seems to be loaded though and I have put "eth0 sk98lin" in /etc/modules.conf

So it is not good to me at all :-/

schildre
1st February 2005, 07:49 PM
sorry, I should have written

$ /sbin/lsmod | grep sk98lin if you are logged on as a regular user.

ewsforos
1st February 2005, 07:55 PM
Yes no worries, I know my way around linux systems. I know how it works.. My problem is that I cannot find a single version of the driver that will compile on FC3...

I suspect something to do with the way devices are set in FC3. It won't compile on either 2.6.9.xFC, 2.6.10xFC or plain vanilla 2.6.10

As for the default 2.6.10xFC3, yes, it does load, but it doesn't work. It won't detect eth0 no matter what I do...

schildre
1st February 2005, 08:10 PM
Are there any error messages in /var/log/messages before the driver craps out?
Manifestly the module does compile, since it is included with the kernel package so someone must have compiled it. Have you tried recompiling and installing the entire kernel as well as the module in question?

ewsforos
1st February 2005, 08:20 PM
Yes, it does compile in the FC-patched form, but still it won't work...

Obviously somebody did compile it but for some reason which I cannot understand, it will not work for me.. very strange... Just found out an experimental alternative driver (a rewrite of sk98lin) so I will give this one a try... Wish me luck :P

schildre
1st February 2005, 08:32 PM
Good luck. Maybe someone who has actual experience with your type of card will be able to pick up the thread. I just wanted to make sure you had looked in the obvious places, as you apparently have done.

ewsforos
1st February 2005, 09:23 PM
Nope, no luck again. This time the "hacked" module compiled, it brings itself up but again:

error fetching interface details (I think): device not found

I'm about to start torturing the damn thing!



PS: Thanks, I appreciate your interest, insight and time anyway. Take care pal.

ewsforos
2nd February 2005, 03:53 PM
Hello,

I've contacted Sysconnect support and I received a reply in record time giving me their latest beta driver. The version is 8.13 and you can find it here:

http://www.syskonnect.de/syskonnect/support/driver/htm/sk9elin.htm

Keep in mind that this driver WON'T compile as it is. You have to generate a patch for your kernel and then recompile the kernel/devices. In any case it works just fine and I'm very glad I am back at linux.

Many thanks to sysconnect's support department. They obviously have very good support, and they replied in an unbelievable 8 minutes (!!!). And that at 2am in the morning. Congratulations and I hope we see other vendors following their example.

drews project
3rd February 2005, 12:45 AM
i tried that
/sbin/lsmod | grep sk98lin and got the following from the terminal
/sbin/lsmod | grep sk98lin
sk98lin 142889 0

ewsforos
3rd February 2005, 09:13 AM
Is it not working for you? Did you amend /etc/modprobe.conf and put in there: "alias eth0 sk98lin" ?
Any more info would be appreciated in order to help you out.

/sbin/ifconfig eth0

/sbin/lspci |grep Ethernet

drews project
3rd February 2005, 09:07 PM
i just took a look at my /etc/modprobe.conf and this is what it had in it
alias scsi_hostadapter ata_piix
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
alias ieee1394-controller ohci1394
alias eth0 tulip
alias eth1 sk98lin
options sk98lin

the eth0 device is an old linksys network card i had laying around.

when i did /sbin/ifconfig eth0 this is what i got back
/sbin/ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:20:78:03:17:AB
inet addr:192.168.1.103 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::220:78ff:fe03:17ab/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:14747 errors:0 dropped:0 overruns:0 frame:0
TX packets:17146 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3020201 (2.8 MiB) TX bytes:14809727 (14.1 MiB)
Interrupt:185 Base address:0x2c00

and when i did /sbin/ifconfig eth1 i got this back
/sbin/ifconfig eth1
eth1: error fetching interface information: Device not found

/sbin/lspci |grep Ethernet
01:0a.0 Ethernet controller: Linksys NC100 Network Everywhere Fast Ethernet 10/100 (rev 11)
02:00.0 Ethernet controller: Marvell Technology Group Ltd. Marvell Yukon 88E8053 Gigabit Ethernet 10/100/1000Base-T Adapter (rev 15)

ewsforos
3rd February 2005, 09:32 PM
Try patching a clean version of the kernel (fresh download) with the patch generated by the driver. Then recompile the kernel and make sure you choose support for this card in the kernel configuration. I would say to repeat the process before trying anything else. If this fails we can get it from there...

Hope this helps

voronwe
5th February 2005, 07:57 PM
Hey all, i had that same problem and wrote to Syskonnect and they advised me to use their new driver, i downloaded it and it compiled the 1st time and found both Marvell Youkon cards on my P5AD2-E Premium mobo.

Driver page :
http://www.syskonnect.de/syskonnect/support/driver/htm/sk9elin.htm

drews project
7th February 2005, 11:59 PM
i just completely reformatted and started from scratch on my fedora 3 system. fresh install of everything. i used my linksys network card to get online from it to write this and to go to the link above and download the latest drivers but when i tried to install them this is what i get back: Patch not generated, the sources already installed on the system in /lib/modules/2.6.9-1.667/source.

i've included some pictures to help you figure out what is going on. :mad:

voronwe
8th February 2005, 04:05 AM
Make the module with the user mode installation, and btw i use the latest kernel for FC3 witch should be 2.6.10-1.760, that works like a charm for me on my Asus P5AD2-E Premium with 2 Glan adapters onboard.

Cheers
Tom

drews project
8th February 2005, 09:32 PM
This is what i get back when i try to install it using user mode:
Using username "root".
root@192.168.1.103's password:
Last login: Tue Feb 8 15:23:43 2005 from 192.168.1.102
[root@localhost ~]# cd /root/Desktop/DriverInstall
[root@localhost DriverInstall]# ./install.sh

Installation script for sk98lin driver.
Version 8.13.1.3 (Jan-17-2005)
(C)Copyright 2003-2004 Marvell(R).
================================================== ==
Add to your trouble-report the logfile install.log
which is located in the DriverInstall directory.
================================================== ==


1) user installation 3) generate patch
2) expert installation 4) exit
Choose your favorite installation method: 1
Please read this carfully!

This script will automatically compile and load the sk98lin
driver on your host system. Before performing both compilation
and loading, it is necessary to shutdown any device using the
sk98lin kernel module and to unload the old sk98lin kernel
module. This script will do this automatically per default.
If you want to shutdown and unload the old sk98lin kernel module
manually, run the script in the EXPERT mode.

Please plug a card into your machine. Without a card we aren't
able to check the full driver functionality.

Do you want proceed? (y/N) y
Create tmp dir (/tmp/Sk98ICbCHmCklEoOnTfWpoWNm) [ OK ]
Check user id (0) [ OK ]
Check kernel version (2.6.10-1.760_FC3smp) [ OK ]
Check kernel symbol file (/proc/kallsyms) [ OK ]
Check kernel type (SMP) [ OK ]
Check number of CPUs (2) [ OK ]
Check architecture (found) [ OK ]
Set architecture (i386) [ OK ]
Check compiler (/usr/bin/gcc) [ OK ]
Check mcmodel flags (none) [ OK ]
Check module support (/sbin/insmod) [ OK ]
Check make (/usr/bin/make) [ OK ]
Check archive file (sk98lin) [ OK ]
Check kernel gcc version (3.4.2) (Kernel:3.4.2 == gcc:3.4.2) [ OK ]
Check sk98lin driver availability (not loaded) [ OK ]
Check kernel header files (not found) [ failed ]
Kernel header not found. Please install the linux header files
development package or crate a symbolic link from the
/usr/src/KERNEL_VERSION directory to linux
Example: ln -s /usr/src/KERNEL_VERSION /usr/src/linux

Installation of sk98lin driver module failed.
Delete temp directories (done) [ OK ]

voronwe
9th February 2005, 12:07 AM
Ahhhh hehe ok that is an easy error to correct hehe :)

The error tells u that it cannot find the kernek source info / dir and to solve that u need to run the command : ln -s /usr/src/KERNEL_VERSION /usr/src/linux

To make it work do the following in ur shell. :

ln -s /lib/modules/2.6.10-1.760_FC3smp/source /usr/src/linux

The install scripts assumes that the Kernel Source code is located in /usr/src/linux witch it is not so now we make a link the source from /lib/modules/2.6.10-1.760_FC3smp/source to /usr/src/linux and then run the script again, then it should work fine, but then again for this to work u need to install the kernel source rpm file, if u dont have that allready.

Cheers

Tom Stage
Copenhagen Denmark

drews project
9th February 2005, 01:10 AM
where would i find the kernel source rpm file? im only asking because i tried downloading it from rpmfind and it installed ok but i thought i already took care of that last night when i did the yum updates?

drews project
9th February 2005, 03:22 AM
this is what i got back from my shell when i ran that command:
[root@localhost DriverInstall]# ln -s /usr/src/2.6.10-1.760_FC3 /usr/src/linux
ln: `/usr/src/linux': File exists
[root@localhost DriverInstall]#

i tried the user install after i got this back from the shell and it gave me the same error as before

Im still stumped? what could be the problem now?

jadychen
3rd September 2005, 03:57 PM
I had the same problem : the kernel do'nt got the drive , and then , when I recompile the kernel : Fedora Core 3 2.6.9-1.667 smp use : linux-2.6.9.tar.gz , when at "make modules " I got an error , Who can help me!!!
Thanks!!Thanks!!Thanks!!Thanks!!Thanks!!Thanks!!Th anks!!