View Full Version : no network connection and slowdown

11th June 2004, 05:16 AM
Having my network cable plugged during booting causes massive slowdowns as soon as it try's to start up eth0. It still boots, but takes about half an hour and it's really slow on the desktop too. (network connection does'nt work)
I tried booting without the cable and the computer is really responsive untill I try activating eth0. (still does'nt work) After this the computer is sluggish again untill restart.

I'm connected to the internet with adsl that works with dhcp. It does'nt require any special settings and works under windows xp. (dual boot)

I was searching for a solution, and found that some people had problems with kudzu. I moved kudzu from rc5.d to a temp folder where I allready had pcmcia, but it does'nt help.

Network card is a via Rhine II VT6102 and status is ok.

11th June 2004, 03:03 PM
You can disable services instead of moving them around every which way. I like the graphical way: Main Menu > System Settings > Server Settings > Services.

Try checking your boot logs: System Tools > System Logs.

11th June 2004, 08:41 PM
localhost mdmpd: mdmpd failed

It has something to do with raid setups? I disabled it. There was also errors that the lan cable was unplugged during bootup, which it was.

I tested booting without the cable, then putting the cable in -> activating eth0. It failed again, and the systems speed went down to a crawl like before (sluggish was an understatement). After trying to activate the connection I closed the panels and tried to open system logs again. It took 2 minutes to open up! (on an Athlon 64)

I had a look in the system log file and here are all the lines that have either a red or yellow mark next to them (after last boot):

(from previous shutdown)

localhost kernel: X[2314]: segfault at 000000000001ffe rip 000000000da06e3 rsp 0000007fbffff6d8 error 6

(from boot)

ifup: failed: no link present. Check cable?

network: Bringing up interface eth0: failed

kernel: There is already a security framework initialized, register_security failed.

kernel: failure registering capabilities with kernel

ACPI-0179: *** Warning: The ACPI AML in your computer contains errors, please nag the manufacturer to correct it.

ACPI-0182: *** Warning: Allowing relaxed access to fields; turn on CONFIG_ACPI_DEBUG for details.

Warning: Processor Platform Limit event detected, but not handled.

Once booted I tried to activate the eth0 again. There was alot of dhcpdiscover attempts that where timed out. could it be that iptables is blocking them?

11th June 2004, 09:58 PM
Turning off iptables did'nt help. I put acpi debug on, and received a few errors concerning the soundcard on the next boot. (assuming the debug info comes in the system log?)

18th June 2004, 07:49 AM
I did a re-install, disabled extra services and now it works!