PDA

View Full Version : how to turn off drives and fan on a server?



pbillante
23rd January 2005, 04:17 PM
Hi,

I have an older Dell XPST500 that I'm using as a samba server w/o monitor. Works fine, but I only access the files occaisionally and the system's fans and hard drives are VERY LOUD.

Is there a way to configure the system to either go into a save to RAM (S3 power state) or at least spin down the drives and fan when the system is idle for long periods?

(On boot, I get the warning that the BIOS is older than ACPI, but checking Dell's release notes for the BIOS that I'm running says it does support ACPI. I don't know if that matters, but I added acpi=force to the boot command. I also tried using hdparm to set drive timeouts, but it didn't seem to work once I closed the root session.)

Any thoughts?

Thanks!

terr9898
23rd January 2005, 05:17 PM
Not 100% about the fans but for hdparm, add the parameters to /etc/rc.local

Void Main
23rd January 2005, 06:25 PM
There is also a sysconfig file for hdparm options called /etc/sysconfig/harddisks if you prefer.

pbillante
28th January 2005, 03:56 AM
Thanks - I added parameters to the /etc/sysconfig/harddisks :

EXTRA_PARMS="-B128 -S240"

(I saw somewhere else that for multiple parameters they need to be in quotes.)

I noticed that the USE_DMA parameter in this file was commented out. Should I uncomment that? Wouldn't DMA give me better performance? Is there any risk in uncommenting that?

Thanks!

Void Main
28th January 2005, 04:07 AM
Before you ever add anything to /etc/sysconfig/harddisks you want to try them on the command line (just in case some param might cause some sort of a lockup for instance). Before adding DMA check to see if it isn't already enabled automatically:

# hdparm /dev/hda

Linux today is pretty good at configuring drives, although I'm sure there's the odd one that can be helped with some extra hdparm fiddling.

pbillante
29th January 2005, 03:46 PM
Thanks, I checked hdparm -i and all drives show an asterisk next to "udma2", so I guess DMA is on.

But, hdparm also says that the power management state is unknown -- i.e. it hasn't been set -- is it possible that the configs in the /etc/sysconfig/harddisks are not working?

pbillante
31st January 2005, 05:00 AM
Also, neither option (using /etc/sysconfig/harddisks or rc.local) works. I tried both and my drives are still running constantly -- no spindown or timeouts at all.

Any ideas why hdparm doesn't work?

Thanks!