PDA

View Full Version : rhgb default



et109
6th March 2004, 04:49 PM
I'd like to change the default start up screen to show the details, can anyone help me with it?

Jman
6th March 2004, 10:24 PM
Unfortunately, I don't think that will be very easy. Querying rpm for what files rhgb has:
rpm -q rhgb -l gives the executables, a few images, and some locale files. There is no config as far as I can tell.

Tweaking the source it is beyond me and probably more work than you wanted.

mhelios
7th March 2004, 03:28 AM
I've tried to do this by mucking with the initscripts with no success. It will show details, but not in the rhgb context; i.e. it just switches to non-gui text mode.

djf_jeff
7th March 2004, 05:00 AM
If you really want to hack some thing, go to /etc/init.d/functions

I have make a change that when I have a failure it do not show the detail but log in a file. So, you may change it to show the detail all the time.

Just an idea

mhelios
7th March 2004, 07:19 AM
Originally posted by djf_jeff
If you really want to hack some thing, go to /etc/init.d/functions

I have make a change that when I have a failure it do not show the detail but log in a file. So, you may change it to show the detail all the time.

Just an idea
This is actually the file I was referring to..It among other things controls the state of rhgb on boot.

et109
7th March 2004, 02:23 PM
Thanks to all for your replies.

I've just moved to Fedora from RH9 and built a custom .2115 kernel which defaults to 'details on' after the build. That led me to believe there was a config file somewhere for the rh gui start up.
Guess I'll go 'muck around' in the /etc/init.d/functions file and see if I can learn anything.
Tks again :-)

crackers
7th March 2004, 08:35 PM
I seem to remember seeing somewhare, possibly on Fedora Tips 'n Tricks that there's a grub boot-time flag for this. Of course, I'm too lazy to look myself...

lafflamj
20th October 2004, 11:44 PM
This is a problem I have been researching for myself today. I wanted to keep the graphical boot loader, but I wanted it to default to "Show Details". Why? No particular reason except that I liked the way it looked.

I never found a difinitive solution until I pieced this one together. It seems to work for me, but as always, your mileage may vary.

Edit /etc/rc.d/init.d/functions as indicated in bold below:

# Log that something succeeded
success() {
if [ -z "${IN_INITLOG:-}" ]; then
initlog $INITLOG_ARGS -n $0 -s "$1" -e 1
else
# silly hack to avoid EPIPE killing rc.sysinit
trap "" SIGPIPE
echo "$INITLOG_ARGS -n $0 -s \"$1\" -e 1" >&21
trap - SIGPIPE
fi
[ "$BOOTUP" != "verbose" -a -z "$LSB" ] && echo_success

[ -x /usr/bin/rhgb-client ] && /usr/bin/rhgb-client --details=yes

return 0
}

sailor
21st October 2004, 02:08 AM
Crackers. Don't you just remove the "rhgb" line from the kernel line in the grub.conf
It will boot and show the services loading with out the graphical border, no need to F2 to see the info.

Petrohead
21st October 2004, 02:34 AM
Crackers. Don't you just remove the "rhgb" line from the kernel line in the grub.conf
It will boot and show the services loading with out the graphical border, no need to F2 to see the info.

Kewl Beans !! Always wondered what the heck that line meant. Tried to google it last night and looked around here as well and couldn't find a definitive answer. Thx for that sailorsgh !! This is just what you're looking for et109. Works a treat ...............

crackers
21st October 2004, 03:28 AM
Do y'all enjoy digging up 7 month old posts and ragging me about it? Geez! :D

Thetargos
29th May 2006, 03:51 AM
Anyone know how to change the background image of RHGB? Not the computer image (which is installed under /usr/share/rhgb), but the bubbling backdrop... I like FC5 a LOT, I really do, but the whole bubbling theme gets on my nerves, and I'd like something less bubbling...

bubazoo
18th September 2006, 08:16 PM
I'd like to change the default start up screen to show the details, can anyone help me with it?


DId anyone ever figure this out? removing the "rhgb" from grub.conf doesn't show the startup screen at all, I think the guy wanted to know how to show the details within the startup screen. I too have been trying to figure this out for awhile and haven't come up with anything.

Thetargos
18th September 2006, 08:19 PM
Well, actually I have figured this out. Howver I'm not entirely sure how to change the whole of the apperance, except for the pixmap (I'd like to change the GTK theme too, but have been unable to thus far).

The pixmaps are installed onto /usr/share/rhgb, substitute with the same name, and these should change. As for the other pices I've been not able to figure out how.

Edit
For more information, read /usr/share/doc/rhgb-0.16.3/HOW_IT_WORKS

bubazoo
18th September 2006, 08:28 PM
thats not what I mean... I mean...

when fedora boots up, and that rhgb GUI screen starts up, there is a link you click on called "show details" and the startup process details show up inside a window there.

what he was asking, and I'm asking too, is how to turn that on by default? main reason is for looks, the details are too difficult to read when rhgb is disabled...

Thetargos
18th September 2006, 08:31 PM
Again, maybe the answer is that file, some flag that shoulod be passed to rhgb from rc.sysinit?

hokousha
8th November 2006, 05:31 AM
In FC5 the way to always get the detailed output during the bootstrap process was just to change the "rhgb" option on the appropriate "kernel" line in /etc/grub.conf to "norhgb". This would give you the details without the graphical border, which, for me, was perfect.

In FC6, however, changing "rhgb" to "norhgb" causes the screen to go black from the moment that rhgb would normally start up until the login screen appears. I'm not sure why the behavior was changed, but is there an easy way to modify the FC6 configuration so that details are always shown by default (with or without the graphical border)?

Personally I don't understand why the emphasis over time has been to hide the bootstrap details. It's useful information.

Thanks!

Thetargos
8th November 2006, 06:01 AM
The easiest way is to remove altogether the "rhgb" argument to the kernel if you don't want it in the first place :rolleyes:

Edit
And maybe use a framebuffer driver to get your X resolution in the console framebuffer... I use the vesa driver @1024x16bpp, as 1280 is too small for the console, with the vga=791, I used to run at 32bpp, but in the console there's no need to, so I left it @ 16.

mobsta
8th November 2006, 06:02 AM
hokousha just remove rhgb from grub.conf and you'll see the bootstrap details.

hokousha
13th November 2006, 03:01 AM
I think in the end the problem may have been that I had installed FC6 with virtualization. After reinstalling FC6 without it, the old "norhgb" trick works fine, and I suppose that simply removing the rhgb option would as well. Thanks!

Stian1979
14th March 2007, 06:52 AM
/etc/inittab line saying id:5:initdefault: change too 3.

That will prevent x-server from starting until after you login and type startx

fun1asma
16th March 2007, 05:35 AM
This is a problem I have been researching for myself today. I wanted to keep the graphical boot loader, but I wanted it to default to "Show Details". Why? No particular reason except that I liked the way it looked.

I never found a difinitive solution until I pieced this one together. It seems to work for me, but as always, your mileage may vary.

Edit /etc/rc.d/init.d/functions as indicated in bold below:

# Log that something succeeded
success() {
if [ -z "${IN_INITLOG:-}" ]; then
initlog $INITLOG_ARGS -n $0 -s "$1" -e 1
else
# silly hack to avoid EPIPE killing rc.sysinit
trap "" SIGPIPE
echo "$INITLOG_ARGS -n $0 -s \"$1\" -e 1" >&21
trap - SIGPIPE
fi
[ "$BOOTUP" != "verbose" -a -z "$LSB" ] && echo_success

[ -x /usr/bin/rhgb-client ] && /usr/bin/rhgb-client --details=yes

return 0
}

The workaround provided above works fine for me. However, if someone comes up with a "cleaner" solution, please let me know. Thanks.

icantux
16th March 2008, 08:58 PM
Sorry to bump up an old post like this,

Just wanted to say that the workaround worked for me too under Fedora 8.
Too bad there's no option to show/hide details that would be less ... "intrusive".

jammer2001
7th July 2010, 03:22 AM
I was looking for this exact same thing too - it worked for me also on Linux 2.6.18-128.el5xen #1 SMP i686 i686 i386 GNU/Linux Red Hat Enterprise Linux Server release 5.3 (Tikanga)

Personal rant: CONUNDRUM: if everyone would either answer the question or JUST NOT POST (a rant or putdown) then perhaps things would be EASIER to find on the web in all the NOISE!!! Someone should start worldwide movement on this to CLEAN UP THE WEB.