PDA

View Full Version : ATi drivers problems...



phoebe
21st January 2005, 10:10 AM
Hello everyone. I am very new to Linux, and yesterday I tried to install the newest ATi drivers on my system. I tried several methods, well some worked, some not, but I couldn't get my 3D acceleration to work. I tried to patch the kernel, that didn't worked, i installed the drivers anyway, rebuilded them with the scripts ( make.sh & make_install.sh ).. Well now everything is a complete mess, and this is what fglrxinfo gives me:

[root@PHOEBE phoebe]# fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.4 Mesa 5.0.2)
If anyone can help me to clean all this, and uninstall everything from the drivers I have so far, and make the new ones work, I'd be very gratefull.
Runnin FC2, Kernel 2.6.10

P.S. Sorry for my very bad english :)

ghaefb
21st January 2005, 10:47 AM
Read here -> http://www.fedoraforum.org/forum/showthread.php?t=32300&highlight=ati

phoebe
21st January 2005, 11:14 AM
Uhm, thanks, I forgot to mention that i tried several HowTos in the HowTo forum, well tried a mix of them all... And got to my current situation :)
Well i'll try the guide you linked again in the evening.
Thanks.

ghaefb
21st January 2005, 11:24 AM
As far as I know you need to install ati driver rpm: rpm -ivh fglrx....rpm --force
And remove radeon module: modprobe -r radeon
Change /etc/X11/xorg.conf -> Section "Device".. Driver "radeon" to -> Driver "fglrx".

I don't know this is the good/right way to do this... but it works.

kevcart3
21st January 2005, 11:37 AM
I had a problem with installing the drivers, the letter K in "keyboard" was capitalized several times in the xorg.conf file causing my x server to crash on startup, all i did was replace the original xorg.conf using fglrxconfig and edited the part about the keyboard and it worked


EDIT: This is under the ATI BugZilla as bug #32

http://ati.cchtml.com/show_bug.cgi?id=32

I just wanted to warn you in case u ran into that problem like i did.