PDA

View Full Version : Login Manager in Fedora KDE Spin black/blank screen after installing Nvidia drivers



TheDcoder
22nd April 2018, 02:51 PM
Hello guys, been a while since I have last posted here.

I have recently installed Fedora 27 KDE Spin on my new laptop with a powerful Nvidia GTX 1050Ti graphics card, initially the open source nouveau drivers were not properly working with my computer (I had to disable power management with nouvea.runpm=0 kernel parameter) so I installed the proprietary Nvidia drivers from RPM Fusion by following their guide (https://rpmfusion.org/Howto/NVIDIA#Current_GeForce.2FQuadro.2FTesla).

Since installing the drivers I have not been able to access the login manager (SDDM I think), I get a blank/black screen when I log out or try to switch user account. I am not sure what is happening, I will be happy to provide more details if needed :)

Thanks for the help in Advance!

P.S I have had setup auto-login for my account before installing the drivers so I get logged in automatically on boot.

chepioq
22nd April 2018, 04:33 PM
Look the log in /var/cache/akmods/nvidia/

TheDcoder
22nd April 2018, 04:48 PM
Thanks for the reply chepioq, there are 2 log files in that folder along with 2 rpm files, I have checked the log file which has the higher version number (390.48-1-for-4.15.17-300.fc27.x86_64.log) and here are the contents: https://paste.fedoraproject.org/paste/H9E05tWzMeFdUmXEsnYmSQ

I have not been able to find anything interesting in the log, maybe you will find something related?

chepioq
22nd April 2018, 05:01 PM
The log is good, you have nvidia's drivers installed and enabled.
Do you use X or wayland ?

TheDcoder
22nd April 2018, 05:24 PM
I am using X

In the meanwhile I tried this solution but it did not work: https://unix.stackexchange.com/a/437882

chepioq
22nd April 2018, 05:38 PM
have you optimus technologie ?
In this case drivers nvidia don't work, you must use "Prime"
https://wiki.archlinux.org/index.php/PRIME

TheDcoder
22nd April 2018, 05:45 PM
Yes, I believe my card uses Optimus technology, in the relevant section (https://rpmfusion.org/Howto/NVIDIA#Optimus) for it in RPM Fusion wiki says that Optimus is handled automatically in Fedora 25 and later, so I was not sure if it is a problem with Optimus, I will dig deeper and find out about this PRIME thing :)

chepioq
22nd April 2018, 06:23 PM
Ok test and see... :p

TheDcoder
22nd April 2018, 07:01 PM
I can't find good instructions or any packages related to prime in my repositories (which includes the non-free rpmfusion ones) :confused:

chepioq
22nd April 2018, 07:07 PM
Have you see this page : https://rpmfusion.org/Howto/Optimus

TheDcoder
22nd April 2018, 07:13 PM
Digging further reveals that prime is a set of shell scripts which make switching between the cards easier, but unfortunately it is made by canonical and only shipped with Ubuntu :(

I got this info from here: https://github.com/bosim/FedoraPrime#fedora-prime

I am not sure how FedoraPrime will help me, at this point I am considering changing login managers...

Edit: Yes, I have seen the Optimus wiki on RPM Fusion and I don't think I have anything that I can try on that page

TheDcoder
7th May 2018, 05:24 PM
Bumpty bump.

I upgraded to F28 today and after making sure everything was okay I decided to give the login manager another shot... Sadly everything is the way it was :(

Any ideas? I can provide more information if needed.

revolucion09
19th February 2019, 07:34 AM
Getting exactly the same issue. Going to test with Fedora Workstation instead of KDE spin

TheDcoder
19th February 2019, 08:34 AM
I am on F29 now, they might have fixed whatever issue they had SDDM, because I do recall seeing the login screen one time. Maybe I should try it again and see how it goes.

revolucion09
19th February 2019, 10:44 PM
I am on F29 now, they might have fixed whatever issue they had SDDM, because I do recall seeing the login screen one time. Maybe I should try it again and see how it goes.

No, they havent :( i tried this Yesterday with same resulta than you, i can only use auto login. I switched to gnome workstation, I think fedora pays attention mostly to this spin anyways,and memory leaks in gnome are getting resolved.

TheDcoder
25th February 2019, 09:54 AM
You are right, I tried this today and same result. I am looking into switching desktop environments myself to avoid using SDDM. Gnome is not a spin by the way, it is the official DE for Fedora, though I do not use it because I do not like how Gnome handles UI

revolucion09
26th March 2019, 05:47 PM
Any news on this? Still not solved