PDA

View Full Version : Unable to scan anymore after upgrade to F28



Boricua
4th April 2018, 06:19 PM
Hi there. After upgrading to F28 Beta I'm no longer able to use my Brother MFC-8890 for scanning in my network. gscan2pdf, nor simple-scan nor skanlite are able to locate it. No issues printing nor accessing its settings with firefox. It's the first time I see this happening after a version upgrade. I tried re installing the rpm drivers and ran the command

brsaneconfig3 -a name=SCANNER model=MFC-8890DW ip=192.168.1.106
Running

brsaneconfig3 -q | grep SCANNER shows

0 SCANNER "MFC-8890DW" I:192.168.1.106
Am I missing something here? Any hint appreciated,

antikythera
4th April 2018, 09:23 PM
is sane-backends-drivers-scanners still installed?

donatom
5th April 2018, 12:24 AM
In addition to checking whether sane-backends-drivers-scanners is installed as antikythera suggests, try installing xsane.

Boricua
5th April 2018, 10:49 AM
is sane-backends-drivers-scanners still installed?

Yes, as well as sane-backends, sane-backends-drivers-cameras, sane-backends-libs, sane-frontends, xsane-common and libsane-hpaio

Boricua
5th April 2018, 10:51 AM
In addition to checking whether sane-backends-drivers-scanners is installed as antikythera suggests, try installing xsane.

OK. Internet access is a little limited around here lately, but I will install xsane and report back.

Boricua
5th April 2018, 10:59 AM
No progress. Xsane tries to find the scanner without success. I can only guess some kind of connection problem, software-sided.

Boricua
6th April 2018, 02:59 PM
Here is some more info. I installed F28 Beta from scratch in my Lenovo T460s. All scanning apps show the standard "Noname Integrated Camera" message when ending scanning for devices. This is the crucial step missing in my desktop computer. I installed in the T460s the brother rpm driver for my other scanner, model MFC-8460n but still need to complete a final connection step since I'm out of my office at the moment. I expect it to work without issue.

Boricua
11th April 2018, 01:25 PM
No, it didn't work either. I filed bug report 1564763 against sane-backends and found out that library libnsl isn't shipped by glibc in F28, but by separate package libnsl. I then filed a request to Brother to update the drivers. Hope this can be solved, because for me it would be a major setback. Would need to stick with F27 instead of upgrading.

Boricua
11th April 2018, 09:45 PM
I think I found a solution. Checking with dnfdragora, I noticed the library installed on my desktop is libnsl2. I also found as not installed libnsl, described as providing

"...the legacy version of libnsl library, for accessing NIS services. This library is provided for backwards compatibility only; applications should use libnsl2 instead to gain IPv6 support."
I installed libnsl and the scanner now works as expected. Don't know if this could be considered a permanent solution or just a temporary fix, since I am not sure I need IPv6 at all.