PDA

View Full Version : updating f28 beta 1.3



horizonbrave
29th March 2018, 03:54 PM
Hi,
I started using f28.
It was downloaded from this page: https://fedoraproject.org/wiki/Test_Results:Fedora_28_Beta_1.3_Desktop?rd=Test_Re sults:Current_Desktop_Test
And I'm using this iso: https://kojipkgs.fedoraproject.org/compose/28/Fedora-28-20180328.1/compose/Workstation/x86_64/iso/Fedora-Workstation-Live-x86_64-28_Beta-1.3.iso

I tried to update it as usual by 'sudo dnf update' but some problems shows up:


Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
mesa-filesystem x86_64 18.0.0-0.5.rc5.fc28 updates-testing 29 k
Skipping packages with broken dependencies:
mesa-dri-drivers x86_64 18.0.0-0.5.rc5.fc28 updates-testing 14 M
mesa-libxatracker x86_64 18.0.0-0.5.rc5.fc28 updates-testing 1.4 M
mesa-vulkan-drivers x86_64 18.0.0-0.5.rc5.fc28 updates-testing 1.8 M


Any suggestion please?
Cheers

lsatenstein
29th March 2018, 04:48 PM
I was testing with Beta1.2 (Yesterday's date)

My download errors

Problem 1: cannot install the best update candidate for package mesa-dri-drivers-18.0.0-0.3.rc4.fc28.x86_64
- nothing provides libLLVM-6.0.so(LLVM_6.0)(64bit) needed by mesa-dri-drivers-18.0.0-0.5.rc5.fc28.x86_64
Problem 2: cannot install the best update candidate for package mesa-libxatracker-18.0.0-0.3.rc4.fc28.x86_64
- nothing provides libLLVM-6.0.so(LLVM_6.0)(64bit) needed by mesa-libxatracker-18.0.0-0.5.rc5.fc28.x86_64
Problem 3: problem with installed package mesa-dri-drivers-18.0.0-0.3.rc4.fc28.x86_64
- package mesa-dri-drivers-18.0.0-0.3.rc4.fc28.x86_64 requires mesa-filesystem(x86-64) = 18.0.0-0.3.rc4.fc28, but none of the providers can be installed
- cannot install both mesa-filesystem-18.0.0-0.5.rc5.fc28.x86_64 and mesa-filesystem-18.0.0-0.3.rc4.fc28.x86_64
- cannot install both mesa-filesystem-18.0.0-0.3.rc4.fc28.x86_64 and mesa-filesystem-18.0.0-0.5.rc5.fc28.x86_64
- cannot install the best update candidate for package mesa-filesystem-18.0.0-0.3.rc4.fc28.x86_64
- nothing provides libLLVM-6.0.so(LLVM_6.0)(64bit) needed by mesa-dri-drivers-18.0.0-0.5.rc5.fc28.x86_64
warning: /var/cache/dnf/updates-testing-3ab9f75e4a13f117/packages/authselect-compat-0.3.2-1.fc28.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 9db62fb1: NOKEY
Importing GPG key 0x9DB62FB1:
Userid : "Fedora 28 (28) <fedora-28@fedoraproject.org>"
Fingerprint: 128C F232 A937 1991 C8A6 5695 E08E 7E62 9DB6 2FB1
From : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-28-x86_64


I run an overnight script for my testing.
What I do is a minimal workstation installation (GNOME),
Then I run my script that:
a) adds the "installation groups" that I want to have, with the benefit of their being installed after the reboot and admin login
b) Lets me setup rpmfusion and to load other items (some gnome extensions), and some third party stuff.
c) Lets me use the system ollowing the basic installation.
d) Lets me setup the desktop settings for my needs
e) Lets me establish my root crontab


Here is what negative stuff I found.
Device management crashes. (Had it happen for keyboard and for printer).
User management went OK. Here is a gripe.


With anaconda, when I create the admin user, I have the option of adding the admin to group users
Not so for the independent (standard) user. I have to do that manually.

Admin should be able to join a standard user to a group (eg, users).

On the positive side
gcc 8.1
LIbreOffice 6.0
Printer setup and printing is working. (It was not working with the daily F28 composes). It is still broken with Fedora 27.


Interested in my script that I use for post installation. It's attached.

lsatenstein
30th March 2018, 12:09 AM
For the mesa stuff do sudo dnf update --best --allow This option should clear up the skipped items.

Tonight, on a separate drive, I will be installing the KDE version of F28.
The Gnome version seems to be OK for what I do with my desktop.

What I have noticed with F28 and recent F27 updates is the introduction of automated reporting.

When a Gnome software crashes, an automatic bugzilla report is generated. I am asked if I wish to upload a dump.
I do that, but after the first time after that initial crash for the same reason, I just let the auto report go to bugzilla.

This auto-report facility is the reason why the software is of improved quality.

lsatenstein
5th April 2018, 08:54 PM
I just completed 2 days of testing Fedora 28 Beta1-3. I tested the Gnome and KDE versions.
My feedback
KDE version --FAIL
Gnome version -- Stay on Fedora 27. At least you can make use of the desktop.

With a blank desktop design by Fedora 28, one asks the question, "Why do you have a desktop". Is it to look at background pictures?

If I was to suggest a feature to GNOME it would be:

Get rid of the favourites bar, and make the entire desktop the favourites bar.
At the base of this favourites display, maintain the frequent/all buttons


KDE Plasma has done something similar to what I suggest.

My perception: With F28, since we can't make use of the desktop, the Gnome beta1.3 in my view is an alpha 1.0

KDE network installation did not include Firefox. Even competing distributions provide firefox as an alternative browser. Other features for KDE plasma were not included (I chose every KDE option from the F28 network install ISO). Was this a "hurried build"?

Kobuck
6th April 2018, 12:49 AM
Gnome version -- Stay on Fedora 27. At least you can make use of the desktop.

What were you doing with Gnome in F27 that's gone in F28??

Other than the change in background art, my F28 desktop looks and feels the same as F27.
I do modify the default by doing a "dnf install gnome-tweaks" and activate the application menu and places extensions.
I haven't seen a difference, what is missing??

OOps!! never mind the question I saw your earlier post. I use the "places" extension to accomplish a similar purpose with a drop down menu from the header ( I recognize its not the same as an icon on the desktop)

lsatenstein
11th April 2018, 01:20 AM
I do a lot of plugging and plugging of usb's, backup drives, etc, to the USB'S. F27 presented a popup to the desktop where I could see what it was I plugged in. Now I have to guess when the plugin got recognized, and then open up the files (Nautilus) program in order to check it's bookmarks for mounted drives.

And then there is the trash icon which easily allows me to click on it and voila, my recovery or discard.
The desktop allowed me to save multiple clicks, However I did create a mounted.desktop file with a suitable icon. I put that into the favourites list.
One click directs me to /run/media/mylogon

where I can see what is mounted.

Kobuck
11th April 2018, 04:10 AM
Hmmm.....

My default Gnome setup provides a popup notification when a USB storage device is inserted. I don't know where its configuration control is located though.