PDA

View Full Version : Japanese problem: ibus-kkc adding words to the dictionary defect



maverick6664
18th February 2018, 01:19 AM
Hi all,

On Fedora 27, ibus-kkc is the default input method. However somehow it's impossible to add words to the dictionary with the keyboard in kana mode. It's possible on Roma-ji mode. I like kana-mode, so it's a bit clumsy.....where should I post this? Is here the right place?

best regards,

smr54
18th February 2018, 03:21 AM
Yeah, that's probably a Gnome decision which many feel is a bad one. Use fcitx-kkc. See http://srobb.net/jpninpt.html which has a Fedora section.

Ibus seems to have gotten worse and worse over the years.

Yes, using Fedora is probably the right place.

maverick6664
18th February 2018, 11:16 AM
Thank you smr54,

When I used bsd/os, freebsd, and linux 27 years ago, Wnn/Canna + kinput2 was the only choices. Since then, I used to use kinput2 + Canna as far as I remember. I went to Windows 5 years ago. I am new to ibus, so I cannot tell fcix is better than ibus. As you say, ibus may be getting worse. I'll try fcix from now on. But before then, I have something to do :) Reading your link, fcitx sounds good.

smr54
18th February 2018, 01:22 PM
Hopefully, it will work better for you. I shouldn't be so harsh on ibus, it may work better with Gnome. I don't use Gnome and began having issues with it a couple of years ago.

Note that if you are using Gnome there's a few steps to take, also mentioned on my page.

maverick6664
18th February 2018, 03:13 PM
Hopefully, it will work better for you. I shouldn't be so harsh on ibus, it may work better with Gnome. I don't use Gnome and began having issues with it a couple of years ago.

Note that if you are using Gnome there's a few steps to take, also mentioned on my page.

I cannot detach ibus and activate fcitx.


gsettings set org.gnome.settings-daemon.plugins.keyboard active false

doesn't work for me. This schema doesn't exist and I cannot detach...so I will use ibus-anthy. To add words to the dictionary, I will use "kasumi -a". It's not bad.

smr54
18th February 2018, 04:21 PM
As mentioned on the page, the command has changed for F27 (though if ibus is working for you, it's probably easier to stay with it.)

For F27 one uses


gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "{'Gtk/IMModule':<'fcitx'>}"


That should be on one line.

maverick6664
18th February 2018, 09:43 PM
As mentioned on the page, the command has changed for F27 (though if ibus is working for you, it's probably easier to stay with it.)

For F27 one uses


gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "{'Gtk/IMModule':<'fcitx'>}"


That should be on one line.

Oh, sorry, I missed it....but I will stick to ibus-anthy because it's comfortable to me.

smr54
18th February 2018, 10:53 PM
If it ain't broke, don't fix it. :)