PDA

View Full Version : Fedora 27 software update issue



Mrbungle
19th January 2018, 11:02 PM
There seems to be an issue with the software update application in Fedora 27. Every day for probably 2 weeks it kept telling me there were new updates, so I would choose restart and install. Then I started looking and it was the same packages over and over. So I did a dnf update from a terminal and it told me I had 540 updates to apply. So I ran that manually and rebooted. There was one more software updater wanting to install updates that I watched and it seems to have worked. And I'm not getting daily apply update messages from the software updater.
Not sure if it's just me or if some package is causing an issue with the software updater. Like I said there were 540 updates so I didn't watch them all. :)
I can comb through logs if this is a common thing

lsatenstein
20th January 2018, 11:50 PM
Try the following in command line

sudo dnf update --skip

if that does not work, then
sudo dnf update --skip --best --allowerasing

and again if that does not work, post your message.

I usually found that if the second dnf fails, if there was something remaining that was blocking installation you could download the files that are not blocking ...

for example sudo dnf update a* b* and so forth.m until there was one file left that is the one to fix up. (remove it or live with it causing grief)

marko
21st January 2018, 12:12 AM
I think it's --skip-broken not --skip


dnf --help | grep skip
--skip-broken resolve depsolve problems by skipping packages

Maybe it works anyway by being a short name for --skip-broken but the dnf man page didn't seem to state it