PDA

View Full Version : File sharing, I give up... Need some help from someone



Jackson
14th January 2018, 04:28 PM
100% emotionally devastated.

I have spent the last 4 days trying to set up file sharing between my F27 Chromebook (Client) and my F27 Desktop (Server) No luck at all.

I have tried Samba and NFS. (would prefer Samba, it allows the option to share with a Windows computers if I ever need to, as that is the majority of people in the world)

I have done file sharing many times in the past with Mint, GalliumOS, Ubuntu, F10 - F14, Debian, Linux Lite...

I don't get why I cannot complete this simple task now in F27. I have wasted a tremendous amount of time, trying to get ONE simple task done. Clearly, this is not the way it should be.

I have searched all over the net. From websites showing "easy" walk through tutorials, to step by step youtube walkthroughs. Nothing has worked.

I just pulled up my search history, I was about to post links to everything I have tried. But this list is exhaustive. I have 22 websites and youtube videos providing walkthroughs and guidance. I would surely piss off an Administrator or Fedora Dev by posting all of these links.

Like I said, I am defeated here, with something intended to be so simple.
Is anyone willing to give me a push in the right direction to get this accomplished?

I just need Computer A and Computer B to play nicely and share. :(

(off topic, but is there a deadline when FedoraForum will be fixed? It's become hell to navigate and even use lately...)

PatMcLJr
14th January 2018, 05:09 PM
dunno
I have used sshfs before, did you try that one?
I couldn't get NFS to work, but it's supposed to be faster but less secure.

flyingdutchman
14th January 2018, 06:27 PM
You can use FTP, SSH, NFS, SMB or even netcat to share files, provided that the network is configured right.

Nothing will work if your network doesn't work and the way to tell is with ping, ntop, and tcpdump.


Ferinstance:

http://www.aeronetworks.ca/2013/04/network-connectivity-bane-of-all.html

http://www.aeronetworks.ca/2014/03/network-debugging.html

http://www.aeronetworks.ca/2013/04/hmm-lemme-see-how-many-boring-ways-can.html

http://www.aeronetworks.ca/2017/02/simple-file-server.html

PabloTwo
14th January 2018, 08:42 PM
Often times this is a firewall problem. Out of the box, Fedora is fairly restrictive on what it allows to pass over the net through the firewall. Depending on what you you are trying to "pass", you may need to enable some protocol(s) (i.e. "tcp" and/or "udp") or possibly enable an additional service type on the default zone, which is the "public" zone.

$ sudo firewall-cmd --get-active-zone
public
interfaces: enp3s0

$ sudo firewall-cmd --info-zone=public
public (active)
target: default
icmp-block-inversion: no
interfaces: enp3s0
sources:
services: ipp-client mdns dhcpv6-client ssh ipp
ports:
protocols:
masquerade: no
forward-ports:
source-ports:
icmp-blocks:
rich rules:

bbfuller
15th January 2018, 01:01 AM
You'll also probably find that SELinux blocks Samba shares with its default settings. I wouldn't recommend disabling it permanently, just temporarily until you get this resolved.

You probably know, but:


smbclient -L localhost

should show you what shares your server thinks it should be sharing. That's issued from the command prompt of a valid user.

Jackson
16th January 2018, 04:06 PM
You'll also probably find that SELinux blocks Samba shares with its default settings. I wouldn't recommend disabling it permanently, just temporarily until you get this resolved.

You probably know, but:


smbclient -L localhost

should show you what shares your server thinks it should be sharing. That's issued from the command prompt of a valid user.


Often times this is a firewall problem. Out of the box, Fedora is fairly restrictive on what it allows to pass over the net through the firewall. Depending on what you you are trying to "pass", you may need to enable some protocol(s) (i.e. "tcp" and/or "udp") or possibly enable an additional service type on the default zone, which is the "public" zone.

$ sudo firewall-cmd --get-active-zone
public
interfaces: enp3s0

$ sudo firewall-cmd --info-zone=public
public (active)
target: default
icmp-block-inversion: no
interfaces: enp3s0
sources:
services: ipp-client mdns dhcpv6-client ssh ipp
ports:
protocols:
masquerade: no
forward-ports:
source-ports:
icmp-blocks:
rich rules:

Yup! that seems to be the/a issue for my problem

I still have not succeeded in setting it up. so I cannot be 100% certain, but looking at the results of smbclient -L localhost and sudo firewall-cmd --get-active-zone it appears to be a firewall and SELinux thing. I really do not have the energy to dig in a solve this now. But I added it to one of my projects to do inside a VM first not to mess up my install. REALLY enjoying Fedora these days BTW. I find it much more stable than it use to be, and more so than the more popular distros like Ubuntu/Mint and the likes. - off topic

apt-get install *
vs
dnf install *

I know it is only 4 more characters... but it seems almost like typing the whole alphabet. (still miss typing yum, yum is just more fun to type/say then dnf)