View Full Version : Simple Scan; Fedora sees/controls scanner but no scan displayed

30th December 2017, 09:41 AM
(This might be in the wrong area. Please move it if it is.)
I recently upgraded a Dell Optiplex to Fedora 27. The only 'configuration' change I made was to add XFCE desktop and change to it.

The system recognizes three flat-bed scanners (two HP and a Canon). With all three scanners, Fedora can 'command' the scanner to scan, and the scanner does so.

But in all three cases no scan appears on the screen. According to the brief Simple Scan 'manual', the scan should appear as the scan is occurring.
I tried using a different USB cable, but the same result occurred.

Any ideas of what might be going wrong? I am not an experienced user, so please do not assume I know how to execute complex actions.

31st December 2017, 05:42 AM
I haven't used simple-scan but I have had great luck with xsane. What are the exact models of your HP and Canon scanners? To get xsane up and running you will install xsane, sane, sane-backends, hplip (for your HP in case you have an all-in-one printer-scanner. This is how you install them (type the following in terminal which you first must open):
# dnf install hplip sane xsane sane-backends
Then hit the "enter" key. Note: you must be in super-user mode to install. After running the command, disconnect/power-down your scanner. Reconnect and then run the following command (in terminal window which you must open):
$ xsane
In the xsane window (the narrow one with "xsane 0.999" on top), click on drop-down window next to "Type" and choose type of file (PDF, JPEG, etc.). Place something to scan on your scanner and then click on "Scan" on the bottom of this same narrow window. With any luck, you should hear/see the scanner work and a pdf/jpeg, etc file should appear shortly on the desktop.)

31st December 2017, 12:59 PM
Thanks for your input donatom.

According to what I read, Simple Scan is a front-end to XSANE. With my meagre knowledge, it seems Simple Scan would not work at all if XSANE was not already installed and functioning.

Regardless, I discovered two solutions on my own:

Solution A: change the desktop environment.
I discovered that Simple Scan works entirely fine on Gnome Classic desktop environment.
The 'clue' was that, after scanning using Simple Scan on XFCE, the system asked me whether I wanted to save a file when I attempted exiting Simple Scan.
When I chose to save, a PDF of the scan appeared on the desktop. Cropping also worked.
So, when using XFCE, Simple Scan is receiving the scan, and the scan (or cropped scan) is correctly saved to PDF, but the scan (or cropped scan) is not displayed in Simple Scan as it should be.
The scan (or cropped scan), displaying the scan and saving to PDF all work when using Gnome Classic desktop environment.
(I do not know how to report this XFCE/SimpleScan compatibility bug, so if someone else knows how to do so, please do so.)

Solution B: install and use gscan2pdf
I installed gscan2pdf a few moments ago.
It displays a scanned image in the XFCE desktop environment, and successfully saves it to PDF.
gscan2pdf is more complicated than Simple Scan. It looks like it will take longer to figure out how to use it.
I have not attempted to use gscan2pdf on other desktop environments.

31st December 2017, 05:24 PM
andrewf, glad you found a work-around to your scanning problem -- and thanks for explaining what exactly you did to get your scanners to work. I'm sure there are hundreds of others who will have or are having the same problem and your explanation will help them. Several years ago I tried simple-scan (and I use xfce4 DE) and I didn't like how it worked or I couldn't get it to work. Now I know why.