PDA

View Full Version : Google Earth doesn't work



cheluna
4th December 2017, 05:52 PM
Hi fedorians!

I'm trying to install Google Earth Pro (using the rpm package from its site) and I just cannot make it work. I don't understand what's going on. It used to work when I have installed Fedora 25. Now I have Fedora 27 and it doesn't load, it freezes at the start. I have tried with several Fedora versions (both live and installed versions) and flavours (kde, gnome, lxde) but it didn't make any difference. The thing is that I tried reinstalling my old Fedora 25 to see if I could use it there, and it didn't work either. :(
Since there will be no updates for Fedora 25 soon, I installed version 27 again (lxde, -old notebook-).

Here is what the console says:
google-earth-pro
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

Any ideas? I really need it for my work and I have lost so much time already.

Thanks!!

kldixon
4th December 2017, 08:05 PM
It works here, on a standard F27 Workstation install. How are you installing it? Did you download for the correct architecture? This is what and how I installed:


# rpm --import https://dl-ssl.google.com/linux/linux_signing_key.pub
# rpm -qp google-earth-pro-stable-current.x86_64.rpm
google-earth-pro-stable-7.3.0.3832-0.x86_64
# dnf install google-earth-pro-stable-current.x86_64.rpm

It pulled in 90 dependencies

kldixon
5th December 2017, 11:37 AM
The missing drivers are in mesa-dri-drivers


# rpm -q mesa-dri-drivers
mesa-dri-drivers-17.2.4-2.fc27.x86_64
# rpm -ql mesa-dri-drivers
/etc/drirc
/usr/lib/.build-id
/usr/lib/.build-id/04
/usr/lib/.build-id/04/1faf52f490e263e8413740bd3dac7a6d3a99a4
/usr/lib/.build-id/25
/usr/lib/.build-id/25/208be3af041e06876423f08b442559fda344de
/usr/lib/.build-id/3e
/usr/lib/.build-id/3e/acabd118cb47aeae8dc3250ed1f7c614efc571
/usr/lib/.build-id/3e/acabd118cb47aeae8dc3250ed1f7c614efc571.1
/usr/lib/.build-id/3e/acabd118cb47aeae8dc3250ed1f7c614efc571.2
/usr/lib/.build-id/3e/acabd118cb47aeae8dc3250ed1f7c614efc571.3
/usr/lib/.build-id/3e/acabd118cb47aeae8dc3250ed1f7c614efc571.4
/usr/lib/.build-id/6d
/usr/lib/.build-id/6d/928341653f0c12bf032d3f3453438cdc1abbc5
/usr/lib/.build-id/88
/usr/lib/.build-id/88/65e0b8aa9d5ed43fe504a0369ee22f6da199d0
/usr/lib/.build-id/90
/usr/lib/.build-id/90/c77f58812be297f47937c95c29d38e4a0cf6b0
/usr/lib/.build-id/a6
/usr/lib/.build-id/a6/5637831c77e4e20d38e3584a9795d31a287fd9
/usr/lib/.build-id/a6/5637831c77e4e20d38e3584a9795d31a287fd9.1
/usr/lib/.build-id/a6/5637831c77e4e20d38e3584a9795d31a287fd9.2
/usr/lib/.build-id/a6/5637831c77e4e20d38e3584a9795d31a287fd9.3
/usr/lib/.build-id/a6/5637831c77e4e20d38e3584a9795d31a287fd9.4
/usr/lib/.build-id/a6/5637831c77e4e20d38e3584a9795d31a287fd9.5
/usr/lib/.build-id/a6/5637831c77e4e20d38e3584a9795d31a287fd9.6
/usr/lib/.build-id/a6/5637831c77e4e20d38e3584a9795d31a287fd9.7
/usr/lib/.build-id/d8/3ebb3808985a198f696a3be1a0de9807e4e5bc
/usr/lib/.build-id/e4
/usr/lib/.build-id/e4/2c5c43782fe0417ed07340853b0b09226a0349
/usr/lib/.build-id/e4/2c5c43782fe0417ed07340853b0b09226a0349.1
/usr/lib/.build-id/e4/2c5c43782fe0417ed07340853b0b09226a0349.2
/usr/lib64/dri/i915_dri.so
/usr/lib64/dri/i965_dri.so
/usr/lib64/dri/kms_swrast_dri.so
/usr/lib64/dri/nouveau_dri.so
/usr/lib64/dri/nouveau_drv_video.so
/usr/lib64/dri/nouveau_vieux_dri.so
/usr/lib64/dri/r200_dri.so
/usr/lib64/dri/r300_dri.so
/usr/lib64/dri/r600_dri.so
/usr/lib64/dri/r600_drv_video.so
/usr/lib64/dri/radeon_dri.so
/usr/lib64/dri/radeonsi_dri.so
/usr/lib64/dri/radeonsi_drv_video.so
/usr/lib64/dri/swrast_dri.so
/usr/lib64/dri/virtio_gpu_dri.so
/usr/lib64/dri/vmwgfx_dri.so
/usr/lib64/gallium-pipe
/usr/lib64/gallium-pipe/pipe_nouveau.so
/usr/lib64/gallium-pipe/pipe_r300.so
/usr/lib64/gallium-pipe/pipe_r600.so
/usr/lib64/gallium-pipe/pipe_radeonsi.so
/usr/lib64/gallium-pipe/pipe_swrast.so
/usr/lib64/gallium-pipe/pipe_vmwgfx.so

satanselbow
5th December 2017, 08:20 PM
Not as apocalyptic as when Google Earth crashes on Android and you receive the fateful message that "Earth has stopped!" ... gulp!

cheluna
5th December 2017, 08:32 PM
Well... answering your question, I downloaded the package directly from the site, manually, and yes, the correct architecture for my 32bit Fedora. The package was google-earth-pro-stable-current.i386.rpm
I installed it just like you did: dnf install google-earth-pro-stable-current.i386.rpm. It installed 14 dependencies in my case.
But I have to tell you, at the end, the 27 versions drove me mad. My computer didn't like it . :/ It was working slower than with previous versions and it also had problems with the windows manager. They just wouldn't move, or change size, and I couldn't type... It was awful. So I came back to F24, and now I have successfully installed. It is very weird. I have come to the conclusion that every laptop is a different universe regarding the distros. Sometimes they work better, sometimes they just don't.
So, I kind of solve it. Not the best solution maybe, but at least, I'm able to work.
Thanks guys!

cheluna
5th December 2017, 08:33 PM
Not as apocalyptic as when Google Earth crashes on Android and you receive the fateful message that "Earth has stopped!" ... gulp!

What?? really? I haven't seen it -yet!

cheluna
5th December 2017, 08:34 PM
The missing drivers are in mesa-dri-drivers


# rpm -q mesa-dri-drivers
mesa-dri-drivers-17.2.4-2.fc27.x86_64
# rpm -ql mesa-dri-drivers
/etc/drirc
/usr/lib/.build-id
/usr/lib/.build-id/04
/usr/lib/.build-id/04/1faf52f490e263e8413740bd3dac7a6d3a99a4
/usr/lib/.build-id/25
/usr/lib/.build-id/25/208be3af041e06876423f08b442559fda344de
/usr/lib/.build-id/3e
/usr/lib/.build-id/3e/acabd118cb47aeae8dc3250ed1f7c614efc571
/usr/lib/.build-id/3e/acabd118cb47aeae8dc3250ed1f7c614efc571.1
/usr/lib/.build-id/3e/acabd118cb47aeae8dc3250ed1f7c614efc571.2
/usr/lib/.build-id/3e/acabd118cb47aeae8dc3250ed1f7c614efc571.3
/usr/lib/.build-id/3e/acabd118cb47aeae8dc3250ed1f7c614efc571.4
/usr/lib/.build-id/6d
/usr/lib/.build-id/6d/928341653f0c12bf032d3f3453438cdc1abbc5
/usr/lib/.build-id/88
/usr/lib/.build-id/88/65e0b8aa9d5ed43fe504a0369ee22f6da199d0
/usr/lib/.build-id/90
/usr/lib/.build-id/90/c77f58812be297f47937c95c29d38e4a0cf6b0
/usr/lib/.build-id/a6
/usr/lib/.build-id/a6/5637831c77e4e20d38e3584a9795d31a287fd9
/usr/lib/.build-id/a6/5637831c77e4e20d38e3584a9795d31a287fd9.1
/usr/lib/.build-id/a6/5637831c77e4e20d38e3584a9795d31a287fd9.2
/usr/lib/.build-id/a6/5637831c77e4e20d38e3584a9795d31a287fd9.3
/usr/lib/.build-id/a6/5637831c77e4e20d38e3584a9795d31a287fd9.4
/usr/lib/.build-id/a6/5637831c77e4e20d38e3584a9795d31a287fd9.5
/usr/lib/.build-id/a6/5637831c77e4e20d38e3584a9795d31a287fd9.6
/usr/lib/.build-id/a6/5637831c77e4e20d38e3584a9795d31a287fd9.7
/usr/lib/.build-id/d8/3ebb3808985a198f696a3be1a0de9807e4e5bc
/usr/lib/.build-id/e4
/usr/lib/.build-id/e4/2c5c43782fe0417ed07340853b0b09226a0349
/usr/lib/.build-id/e4/2c5c43782fe0417ed07340853b0b09226a0349.1
/usr/lib/.build-id/e4/2c5c43782fe0417ed07340853b0b09226a0349.2
/usr/lib64/dri/i915_dri.so
/usr/lib64/dri/i965_dri.so
/usr/lib64/dri/kms_swrast_dri.so
/usr/lib64/dri/nouveau_dri.so
/usr/lib64/dri/nouveau_drv_video.so
/usr/lib64/dri/nouveau_vieux_dri.so
/usr/lib64/dri/r200_dri.so
/usr/lib64/dri/r300_dri.so
/usr/lib64/dri/r600_dri.so
/usr/lib64/dri/r600_drv_video.so
/usr/lib64/dri/radeon_dri.so
/usr/lib64/dri/radeonsi_dri.so
/usr/lib64/dri/radeonsi_drv_video.so
/usr/lib64/dri/swrast_dri.so
/usr/lib64/dri/virtio_gpu_dri.so
/usr/lib64/dri/vmwgfx_dri.so
/usr/lib64/gallium-pipe
/usr/lib64/gallium-pipe/pipe_nouveau.so
/usr/lib64/gallium-pipe/pipe_r300.so
/usr/lib64/gallium-pipe/pipe_r600.so
/usr/lib64/gallium-pipe/pipe_radeonsi.so
/usr/lib64/gallium-pipe/pipe_swrast.so
/usr/lib64/gallium-pipe/pipe_vmwgfx.so


I don't know if I had those drivers, but it should have been installed if they weren't available, shouldn't it?
I guess I'll try some other time.

cheluna
5th December 2017, 08:36 PM
I don't know how to mark the thread as solved. :C