PDA

View Full Version : Display issues on Fedora 27 Xorg



Jeff Sadowski
4th December 2017, 05:52 AM
I need to be able to see the same screen in VNC as on the screen and as far as I know Wayland does not support this.

So I went to Xorg. Now I am having an issue with the display only being 640x480

When I run xrandr I get as follows.

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected 640x480+0+0 0mm x 0mm
640x480 73.00*

[root@methanemaker ~]# inxi -G
Graphics: Card: Intel Core Processor Integrated Graphics Controller
Display Server: X.org 1.19.5 drivers: fbdev (unloaded: modesetting,vesa) Resolution: 640x480@73.00hz
OpenGL: renderer: llvmpipe (LLVM 4.0, 128 bits) version: 2.1 Mesa 17.2.4



lspci -v shows

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 12) (prog-if 00 [VGA controller])
Subsystem: Intel Corporation Core Processor Integrated Graphics Controller
Flags: bus master, fast devsel, latency 0, IRQ 11
Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
I/O ports at 30c8 [size=8]
[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit-
Capabilities: [d0] Power Management version 2
Capabilities: [a4] PCI Advanced Features
Kernel modules: i915


Is there an easy fix for this?

Jeff Sadowski
4th December 2017, 06:25 PM
I saw elsewhere that the i915 does not like the nomodeset flag so I copied the line in /etc/default/grub commented out the original and removed nomodeset from the active line. Then ran
"grub2-mkconfig -o /boot/grub2/grub.cfg"
then rebooted but no luck

Jeff Sadowski
4th December 2017, 09:31 PM
To sum up.
It was the nomodeset flag I just was not updating grub correctly.
my /etc/default/grub looks as follows

GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
#GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora00/root rd.md.uuid=c449cef5:b0e299dd:028e55af:fa683980 rd.md.uuid=9e9d3e25:0a50591a:e2541589:55d13aab rd.lvm.lv=fedora00/swap nomodeset rhgb quiet"
GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora00/root rd.md.uuid=c449cef5:b0e299dd:028e55af:fa683980 rd.md.uuid=9e9d3e25:0a50591a:e2541589:55d13aab rd.lvm.lv=fedora00/swap rhgb quiet"
GRUB_DISABLE_RECOVERY="true"

If you use EFI you need to use

grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

to update grub