View Full Version : F27 turns monitor off on Intel E3800 (N2930) (works only with nomodeset)

3rd December 2017, 01:55 AM
Hello The Best Linux Community on the web!

For my handy-mandy home NAS/media server project I seem to have too unusual hardware.. :confused:

Brief description:
Right after booting installation media and choosing installer I had problem with screen going completely off (stand-by to be precise) after option to install was activated under Grub2
I worked that around by using "safe-mode" installer which adds nomodeset to grub.
This setting gets propagated to the installed system, making it actually boot to GUI. Unfortunately with max of 640x480 resolution and some poor color depth.
Clearing nomodeset option in Grub2 causes system to boot, but with monitor in standby (I can reach it over SSH)
Monitor goes into stand-by after about 3 seconds into Linux loading (at least it seems for me like that). It is the moment where Fedora logo would come out after the few initial lines on the console.

Aside from attached inxi otput, of course.
F27 (tested in same way with same results on F25 and F26 as well)
Mainboard: Jetway NF9W with
Intel® Celeron N2930 SoC, 1.83GHz – 2.16GHz Burst, Quad-Core, 7.5W TDP/4.5W SDP
Integrated Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display


System: Host: fedora.emenems Kernel: 4.13.16-300.fc27.x86_64 x86_64 bits: 64 gcc: 7.2.1 Console: tty 0
Distro: Fedora release 27 (Twenty Seven)
Machine: Device: desktop Mobo: NF9W model: NF9W v: 1.0 serial: <filter> UEFI: American Megatrends v: BARWAA01 date: 03/17/2015
CPU: Quad core Intel Celeron N2930 (-MCP-) arch: Silvermont rev.8 cache: 1024 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 14660
clock speeds: max: 2165 MHz 1: 1832 MHz 2: 1832 MHz 3: 1832 MHz 4: 1832 MHz
Memory: Array-1 capacity: 8 GB devices: 1 EC: None
Device-1: A1_DIMM0 size: 4 GB speed: 1333 MT/s type: DDR3 part: KHX1600C9S3L/4G
Graphics: Card: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display bus-ID: 00:02.0
Display Server: X.org 1.19.5 drivers: fbdev (unloaded: modesetting,vesa)
tty size: 118x44 Advanced Data: N/A for root out of X
Audio: Card Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.13.16-300.fc27.x86_64
Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 02:00.0
IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 8041.4GB (0.1% used)
ID-1: /dev/sda model: WDC_WD40EFRX size: 4000.8GB temp: 33C
ID-2: /dev/sdb model: ST4000VN000 size: 4000.8GB temp: 40C
ID-3: /dev/sdc model: SAMSUNG_SSD_PM83 size: 32.0GB temp: 0C
ID-4: USB /dev/sdd model: USB_Flash_Memory size: 7.8GB temp: 0C
Partition: ID-1: / size: 26G used: 6.3G (27%) fs: ext4 dev: /dev/dm-0
ID-2: /boot size: 976M used: 150M (17%) fs: ext4 dev: /dev/sdc2
ID-3: swap-1 size: 3.20GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 47.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 248 Uptime: 9:38 Memory: 1110.1/3845.6MB Init: systemd runlevel: 5 Gcc sys: N/A
Client: Shell (bash 4.4.121) inxi: 2.3.43

Check attached files for more details

5th December 2017, 08:32 PM
I was checking on the issue on my own in the mean time. Some more findings:

1. Similar issue happens on CentOS installer (display goes off at similar moment). I haven't checked logs for details
2. On my Fedora 27 I got more verbose logs from boot process and pinpointed the exact moment at which screen goes off. Details to follow:
Line 714 from attached log is the last one seen on the screen:
"kern :info : [ 3.830357] fb: switching to inteldrmfb from EFI VGA"
3. Next I added some options regarding i915. See below:
drm.debug=0 drm.vblankoffdelay=1 i915.semaphores=0 i915.modeset=1 i915.use_mmio_flip=1 i915.powersave=1 i915.enable_ips=1 i915.disable_power_well=1 i915.enable_hangcheck=1 i915.enable_cmd_parser=1 i915.fastboot=0 i915.enable_ppgtt=1 i915.reset=0 i915.lvds_use_ssc=0 i915.enable_psr=0

I tried with with both i915.enable_psr set as 1 and 0. Either did not work.

I'd be grateful for any suggestions from the community here.

For mods/admins: Since this is related to not only Fedora and not installation in particular, can you move it to hardware section? A change in title would greatly appreciated too.

5th December 2017, 09:51 PM

Problem seemed to be caused by setting in BIOS of my Jetway NF9W mainboard.
After disabling "support for DVI-VGA dongle" Linux boot completed fine and FullHD resolution is working in graphics mode.
Unfortunately I can't access neither BIOS nor Grub screen (since the screen is off during that time. Probably resetting BIOS or using RS-232 will be needed to get around that.

It was a pleasure to talk with myself..