View Full Version : The upgrade procedure failed twice now

Jeff Sadowski
2nd December 2017, 06:04 PM
I had tried to upgrade from 25 to 26 and had to rebuild.
Now I just tried from 26 to 27 and am having to rebuild.
What is going on? from 19-25 I had no issues. Now it seems it breaks and breaks bad.
Maybe it has to do with intel graphics? Or being plugged in through other devices?
I have my one computer plugged into my denon stereo (hdmi) then to my samsung tv
After the upgrade it just blinks and doesn't boot properly.
I followed the procedure listed here https://fedoramagazine.org/upgrading-fedora-26-fedora-27/

Jeff Sadowski
3rd December 2017, 08:58 AM
I followed the link on the page that tells me what to do when I encounter a problem and will contact who it recommends for reporting issues. I likely won't be able to even report an issue till Fedora 28. I can't leave that particular server down rebuilding on the whim from backup configs and backed up data is priority. I need my home server to do things at work now and then and I can't keep blowing it up like this when I upgrade. Hopefully they will give me some better options for the next time I upgrade. I was able to boot a boot disk and copy the latest of the configs and data elsewhere while I was reinstalling. Now I have to try and figure out all I need and install it. Important stuff for now then I can take my time as I figure out what I am still missing. I'm not going to just copy all the configs I have changed a few things and don't use others.

I raid1 my system. Maybe next time I'll unplug one disk of my raid and try an upgrade. Then if it fails blow up the failed disk plug back in my good system and boot it back up. Any recommendations?

3rd December 2017, 02:38 PM
While everyone's circumstances are different, I haven't had any serious issues upgrading lately. I do usually run into some errors where DNF tells me that a package can't be upgraded. In most cases removing the package solves the issue.

For example, for the last upgrade I had to remove rpmfusion-free-release, rpmfusion-nonfree-release, grub2-efi-modules and vlc-core. These were show stoppers. Once these packages were removed I was able to upgrade from LXDE 26 to LXDE 27.

Jeff Sadowski
5th December 2017, 06:01 AM
I'm thinking next time I should try and add the boot cd image to the boot partition and boot from it. Now I need a script to pull my configs and installed package list. and another script to restore them. I don't think I have that complicated a setup. I have two disks that I raid and another disk I use for my dvr dump.
The raided disks have 3 raided partitions one raid1 for efi, one raid1 for boot and a third raid1 for lvm. lvm has 3 partitions one for home, one for swap and the last for root.
I leave a big space in /boot so that I can put extra images there. An image I have had there in the past is freedos so that I could do bios updates. I have a second intel 1 Gig card and use the computer as a gateway and home server. I am planning to also implement samba-dc on this server but I'm going to play with it in a vm first to work out some details. The last 2 times I tried that update method it downloads everything and looks fine. I give it the final command to reboot and it just stalls and does nothing. Waiting more than an hour and still nothing just a continual reboot. I give up with that method it just does not work for my computer.

Jeff Sadowski
5th December 2017, 09:48 PM
i started the upgrade procedure on my laptop and it is working. Oh hell no, I will never upgrade that way again.
I need a usable system while it upgrades. On my laptop it is already an hour in and it is only 20% complete.