PDA

View Full Version : Enabling flash player in Firefox 57.0.1



Cylon1972
2nd December 2017, 03:03 PM
Hello,

My setup is as follows:
FC27.up2date as per 2-12-2017
Firefox 57.0.1
Addon shockwave Flash is enabled

When i open deezer, and i want to play a song, deezer complains that i need to install shockwave Flash.
I am clueless.

bobx001
2nd December 2017, 03:17 PM
did you go to adobe.com, and download their rpm installer, installed it via dnf, and then once that is installed, you need to then do another dnf, installing flash-plugin ?

Cylon1972
2nd December 2017, 03:22 PM
yes,

I even tried several other browsers, like opera,cyberfox and chromium.
No luck with them too.

Cylon1972
2nd December 2017, 03:24 PM
dnf install flash-plugin
Laatste metadata-expiratie-check: 1:06:10 geleden op za 02 dec 2017 14:17:11 CET.
Pakket flash-plugin-27.0.0.187-release.x86_64 is already installed.
....

Cylon1972
2nd December 2017, 05:03 PM
it is a browser issue.

Firefox is not able as well to work with QTS of a qnap nas.(web login)
Time to didge firefox.

Opera seems te be working without issues.

marko
2nd December 2017, 08:54 PM
@cylon1972
does the flash plugin show as enabled in about:plugins in Firefox?

Cylon1972
3rd December 2017, 08:51 AM
yes, it does.

nsnbm
3rd December 2017, 11:17 AM
The way I activated flash in firefox-57.0-2.fc27.x86_64 was through:

Tools -> Addons -> Plugins

where I could choose the option "Always activate" for Shockwave Flash. Before doing that, flash didn't run.

EastTexas
5th December 2017, 09:17 PM
I only use flash on Vivaldi
Vivaldi.com (https://vivaldi.com/)

When Opera cast off the original Presto layout engine and developers plus Jon Stephenson von Tetzchner, a new browser arose from the ashes.

Cylon1972
10th December 2017, 12:04 PM
This has been solved.

Solution:
1- rpm -ivh http://linuxdownload.adobe.com/adobe-release/adobe-release-x86_64-1.0-1.noarch.rpm
2- rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-adobe-linux
3- dnf install flash-plugin alsa-plugins-pulseaudio libcurl
4- activate ( enable) the shockwave plugin in firefox by: Menu > addons > allways activate the shockwave addon
5- restart browser.