PDA

View Full Version : Help needed upgrading fedora 22 to 27?



hakless
29th November 2017, 04:02 AM
Looking for guidance on how to properly upgrade to the latest version. I am obviously a novice and have been running 22 for a few years. I have tried to upgrade using "dnf system-upgrade" a few times. However, my system always returns to 22 as if no other version has been uploaded.

-first attempt was to go straight to 27 but received an error that the gpg key file could not be opened. I tried to figure out how to install the proper key to no avail...

-then I tried going to 24 first. It looked as though everything was working but after reboot only 22 was present. System appeared as if no change whatsoever.

-finally I tried going to 23 first. Same problem. No change to the system. Still boots to 22.

Can anyone help me figure out what I'm doing wrong?

I have made small changes to some config files while studying for Linux+ certification. Could that have caused issues?

Thanks!

hrsetrdr
29th November 2017, 07:42 AM
I don't know how many versions a Fedora upgrade can span. I know other Linux distributions are good for a couple version leap.

In all practicality I would back up data, and install Fedora 27 from media directly. it would certainly be a faster process.

antikythera
29th November 2017, 08:32 AM
the key (https://getfedora.org/keys/#) import command is

sudo rpm --import keyfilenamegoeshere
run it from the directory you saved the key file to, the F27 key won't exist on your system since it is over 3 versions old

you should then be able to upgrade from Fedora 22 straight to Fedora 27 using the dnf system upgrade (https://fedoraproject.org/wiki/DNF_system_upgrade) tool. you may however need to add the commands --allowerasing and --nogpgcheck (read the notes in the wiki regarding the obvious security risk of doing this, it's your choice entirely to use it or not) if errors still persist. check carefully what packages are preventing the upgrade though in the output from the commands run

hakless
30th November 2017, 09:48 PM
Thanks so much for your help!
Could you walk me through saving and importing the key? I did try this but I'm sure I did not do it correctly. This is what I tried:

sudo -rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-27-x86_64

I also tried using the URL (https://getfedora.org/static/F5282EE4.txt) instead of /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-27-x86_64

Also tried saving the key as a .txt file then copying it into the /etc directory.

cp was not successful. Not a command I use often so I may have not copied it correctly.

In any case I do not understand what the --import command does. Is copying it to the /etc/pki/rpm-gpg directory the same as importing the key?

Thanks again!