View Full Version : xfce sleep security flaw

27th November 2017, 08:57 AM
I just installed Fedora 27 xfce on my laptop, and was surprised to see after opening my lid that the screen did not lock! I checked "lock screen before sleep" in session settings, on power manager I have "when laptop lid is closed:" both set to suspend, and system sleep mode is also set to suspend. Unless there's another place I have to inconsistently tell my computer to lock my screen on sleep, this becomes a huge physical security issue if someone gets my hands on my laptop and I slept it without locking

27th November 2017, 03:26 PM
is the laptop actually sleeping when the lid is closed? also, does it lock if the screensaver kicks in? i'd check the screensaver lock settings too.

queries like this really belong under 'using fedora'. the spins and remixes section is primarily for people wanting to share their own custom fedora ISO or remix.

27th November 2017, 10:01 PM
My apologies, my assumption was the section had anything to do related to the spins, I will remember that for the future.

To answer your questions: yes the laptop is sleeping, I see my screen dim to black and there are no active screensavers, and the power light no my laptop goes off too. The lock screen also kicks in screen saves happens. Settings in lockscreen are set to "lock screen after 0 minutes" and display power management is enabled

28th November 2017, 06:59 PM
That's how xfce works. For basic functionality you need to flip a gazillion switches and then you find out it still doesn't work.

28th November 2017, 09:55 PM
Try removing xscreensaver and installing light-locker. Light-locker adds a security tab to the Power Manager settings where you can configure locking.

5th December 2017, 04:45 AM
I just dumped xfce for gnome. After getting tired of clicking lock screen before closing the lid, I then found out that the locking mechanism wasn't tipping off KeePassXC to lock the database. I wanted to use it, but those are too big of strikes against xfce for me. Which is sad because I like the simplicity. Soooo yeah hopefully that is something that can be fixed for others at least. I'll remember light-locker for the future though. I may consider xfce on my desktop since sleep functionality isn't a problem for me since my desktop is either on or off. Thank you for the suggestion!

Also Dutchy, +1 :)