PDA

View Full Version : [Fedora 27] Downgrade Openssl to 1.0.x



chronixsc
26th November 2017, 03:02 PM
I am trying to install Ruby 2.3.1 which doesnt work with OpenSSL 1.1.x. How can I downgrade to OpenSSL 1.0.x ?

jarongao
28th November 2017, 11:31 PM
Hello, I had the same issue and managed to install `2.3.1` and `2.3.5` on Fedora 27 by forcing install of `compat-openssl10-devel` (then updating it back to `openssl-devel` afterwards). I posted the solution in github here: https://github.com/rbenv/ruby-build/issues/1115