PDA

View Full Version : Help with NAS shares in F27



slwelch33
25th November 2017, 12:45 PM
I have been having a problem upgrading my existing Fedora 26 disks to F27 and was hoping somebody could point me in the right direction.
The disks I am using are inserted into KingWin HotSwap SATA disk carriers and I have not had any problems with them until F27 was released.
I have upgraded a couple of F26 disks to F27 and everything went fine except my NAS shares no longer work!
I tried testing on the remaining F26 disks and the NAS shares on them no longer work either!
I also tried fresh, clean installs of F27 with the same results.
For years, I have been using /etc/fstab to establish and use the shares but that method no longer works.
I have not (ever) used or tried using Samba for this.
Finally, I have CentOS 7 disks configured exactly the same as above and they work fine.
I am using Buffalo LS-441DE (and LS-421DE) NAS systems and have never had a single problem with them, (once I got them working).
The share type is "cifs" with directories created in /mnt/Linux, /mnt/kstart & /mnt/nasDload.
The shares are defined in /etc/fstab as:
//192.168.1.25/Linux /mnt/Linux cifs rw,uid=<UID>,gid=<GID>,credentials=/root/<CredFN> 0 0
(The credentials file contains both the 'username' and 'password' and is set so that only user root can see them)
The shares are not reachable after booting up and attempts to mount them manually result in:
"mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)"
Absolutely nothing has changed in my F26 disks to cause this failure that I can see.

Can anybody please point me in the right direction to get this working again!

TIA
Steve

glennzo
25th November 2017, 01:09 PM
Here's what I use in /etc/fstab for my Buffalo NAS.

//00.00.00.00/share/ /mnt/buffalo cifs vers=2.0,user=username,password=password 0 0

As you can tell I don't use a credentials file, but that has nothing to do with your issue. There were some recent changes to Samba/CIFS so vesrion 1, which was the default, no longer works. Specify "vers=2.0".

This happened to "everyone" when these Samba/CIFS changes were introduced. It was a common complaint across the Internet.

If you poke around on the web you'll see why we now need to add that specification.

slwelch33
25th November 2017, 02:37 PM
glennzo, Thank you so much for the help!
While inserting "vers=2.0," at the start of the Options section of the fstab line does not work (presently), "vers=1.0" Does in-fact work (just like before).
While I can get by with the vers=1.0 for now, I will use this to figure out what changes need to be made to my fstab entries.
I take it that vers 1.0 had/has some security issues.

I can't find any reference to marking a post as "Solved", so if you would, please do so for me!

Again, thanks.
Steve