PDA

View Full Version : [SOLVED] Fedora 27 (1.6) can not be installed on Virtualbox 5.1.22r115126



syracus
22nd November 2017, 09:39 AM
Hi,

I wanted to try Fedora 27 in an virtualized environment. I tried the latest Fedora 27 ISO (Live) from getfedora.org.
Booting the live-cd directly (with and without testing the media) when the boot process tries to start the graphical user interface it falls back to console. Latest entries are


[OK ] Started User Manager for UID 41.
[OK] Removed slice User Slice of liveuser.

This loop keeps going on forever. CPU usage of the host is raised to 100% btw.

When trying to use the Toubleshooting option 'Start Fedora.... in basic graphics mode' from the boot menu the graphical user interface can be started (showing gdm login screen for 'Live System User').
Selecting the user I get the 'Welcome to Fedora' screen. Using 'Install to Harddrive' does not show any dialog, although the application menu is presented. Quiting 'Install to HardDrive' mentions that the application is not responding. Playing around with several setting dialog it occasionally occures that the screen gets completely messed up, showing weird ASCII characters.

So overall I assume some very weird behaviour of the graphics card driver which is picked in Virtualbox environments.

Some questions I have:
- Can someone confirm this behaviour.
- Does someone know a workaround to get Fedora 27 installed into Virtualbox.
- Where can I get Fedora 26 ISO to download to test if the behaviour is new with Fedora 27?

Many thanks for your support
syracus

antikythera
22nd November 2017, 09:50 AM
I've not seen anything in the common bugs about issues launching Fedora 27 in VirtualBox but then haven't at the same time tried it myself yet either. Have you got the latest build of VirtualBox installed?

Fedora 26 downloads (https://dl.fedoraproject.org/pub/fedora/linux/releases/26/) (or use the torrents link in my signature).

EDIT - VirtualBox is at version 5.2.0 please try again with that

glennzo
22nd November 2017, 10:04 AM
Just as info, I have installed Fedora 27 LXDE, Cinnamon, XFCE, LXQT, Mate and Workstation under Virtualbox 5.2.0 r118431. The only one I have trouble with is Workstation. It installed fairly normally but it is a dog and runs so slowly that I don't bother with it. I suspect Wayland but have not bothered to confirm.

+1 for using the newest version of Virtualbox.

syracus
23rd November 2017, 08:50 AM
Updating to latest VirtualBox 5.2.0r118431 solved the installation issue.
Many thanks.

bobx001
23rd November 2017, 10:42 PM
just my $0.02

I use VirtualBox a lot, and I have found the race condition (100% cpu) on the VirtualBox instances a few times after say upgrading from FC23 to FC24 for example. What solved it for me on most cases was lowering the amount of virtual CPUs of the virtual machine to 1 (temporarily).