PDA

View Full Version : Fedora 26 broken package dependancies



HawkMage
21st November 2017, 01:36 AM
It seems that there is something going on with the package dependencies in the Fedora system repos. In the last month or so I get errors that package dependencies are not met for some updated package. The latest one says that python2-xapps-overrides can't be updated because nothing provides the dependency python2-gobject-base. Looking at the packages available for Fedora 26 python2-gobject-base doesn't exist for Fedora 26 but it is in the Fedora 27 repo. Is there a cross dependency between the two versions of the repo?

I am running Fedora 26 with Cinnamon and the following repos:

[root@oryx ~]# dnf repolist
Last metadata expiration check: 0:22:15 ago on Mon 20 Nov 2017 04:09:54 PM PST.
repo id repo name status
Dropbox Dropbox Repository 4
*fedora Fedora 26 - x86_64 53,912
fedora-multimedia negativo17 - Multimedia 413
fedora-steam negativo17 - Steam 15
google-chrome google-chrome 3
google-earth google-earth 2
skype-stable Skypeforlinux - stable 3
*updates Fedora 26 - x86_64 - Updates 10,902
virtualbox Fedora 26 - x86_64 - VirtualBox 3

Here is the info for the package and it's dependencies:

[root@oryx ~]# dnf info python2-xapps-overrides
Last metadata expiration check: 0:08:05 ago on Mon 20 Nov 2017 04:09:54 PM PST.
Installed Packages
Name : python2-xapps-overrides
Version : 1.0.4
Release : 2.fc26
Arch : x86_64
Size : 1.2 k
Source : xapps-1.0.4-2.fc26.src.rpm
Repo : @System
From repo : updates
Summary : Python2 files for xapps
URL : https://github.com/linuxmint
License : LGPLv2+
Description : Python2 files for XApp apps.

Available Packages
Name : python2-xapps-overrides
Version : 1.0.4
Release : 11.fc26
Arch : x86_64
Size : 9.8 k
Source : xapps-1.0.4-11.fc26.src.rpm
Repo : updates
Summary : Python2 files for xapps
URL : https://github.com/linuxmint/xapps
License : LGPLv2+
Description : Python2 files for XApp apps.

[root@oryx ~]# dnf deplist python2-xapps-overrides
Last metadata expiration check: 0:08:15 ago on Mon 20 Nov 2017 04:09:54 PM PST.
package: python2-xapps-overrides-1.0.4-11.fc26.x86_64
dependency: python(abi) = 2.7
provider: python2-2.7.14-2.fc26.i686
provider: python2-2.7.14-2.fc26.x86_64
provider: python2-libs-2.7.14-2.fc26.i686
provider: python2-libs-2.7.14-2.fc26.x86_64
dependency: python2-gobject-base(x86-64)
dependency: xapps(x86-64) = 1.0.4-11.fc26
provider: xapps-1.0.4-11.fc26.x86_64

leigh123linux
21st November 2017, 04:11 AM
Fix released to stable

https://bodhi.fedoraproject.org/updates/FEDORA-2017-932889b870

You can blame the python police for interfering :dis:

https://bugzilla.redhat.com/show_bug.cgi?id=1509706