PDA

View Full Version : Upgrade To 27 Fails With PGP Error On akmod-wl



evilbastard
18th November 2017, 01:28 PM
Trying to upgrade from 26 to 27 using:

Public key for akmod-wl-6.30.223.271-14.fc27.x86_64.rpm is not installedFailing package is: akmod-wl-6.30.223.271-14.fc27.x86_64
GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-27

Everything downloads but then it fails with a pgp error on akmod-wl:

Public key for akmod-wl-6.30.223.271-14.fc27.x86_64.rpm is not installedFailing package is: akmod-wl-6.30.223.271-14.fc27.x86_64
GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-27

antikythera
18th November 2017, 02:24 PM
try adding the --nogpgcheck switch to the upgrade command

evilbastard
18th November 2017, 02:46 PM
D'OH! forgot about that option, thanks!

mikee
18th November 2017, 10:24 PM
I make the following soft links for a release before upgrading


cd /etc/pki/rpm-gpg/
ln -s RPM-GPG-KEY-rpmfusion-nonfree-fedora-27-primary RPM-GPG-KEY-rpmfusion-nonfree-fedora-27-x86_64
ln -s RPM-GPG-KEY-rpmfusion-free-fedora-27-primary RPM-GPG-KEY-rpmfusion-free-fedora-27-x86_64


Then it properly imports the keys. Guessing there is a place this should be reported someday?