PDA

View Full Version : F26 stuck at linux 4.12.9-300



TablePC
17th November 2017, 03:42 PM
All of the PCs here are Lenovo and all but one has an Intel processor. The one I am having a problem with is a Lenovo H50-55 with AMDŽ A10-7800 radeon r7, 12 compute cores 4c+8g × 4 which is 64 bit and has AMDŽ Kaveri video. All PC get updates daily. Other than the problem below the PC is running great.

The problem is that it seems to be stuck at Linux 4.12.9-300. When I ran YUMExtender is said it was doing the new install and removing the oldest version, but when I open a terminal and run uname -mrs I still get 4.12.9-300. Also when I restart the PC 4.12.9-300 is displayed. The YUMExtender history for the last Linux update shows all four 3.13.12 packages as installed and 4.13.11 headers as removed.

I have tried running dnfdragora and the software application to see if they show that the update still needs to be done and they do not show any thing to update. I also tried running dnf upgrade --refresh and is says nothing to do.

When I run the Linux regression tests (./runtests.sh) the log file shows the linux 4.12.9 was tested.

Can someone please help me figure out what's going on?

Thanks in advance for your help on this.

PatMcLJr
17th November 2017, 06:18 PM
dunno
maybe try #dnf clean all
then try an update?
check the repos in /etc/yum.repos.d/
(I'm using f25 so I don't know if the repos have been moved)

TablePC
17th November 2017, 10:01 PM
I did the (dnf clean all) followed by (dnf upgrade --refresh). Unfortunately I'm still stuck at Linux 4.12.9 .

Thanks for the idea.

Thanks in advance for any further help I can get on this.

TablePC
21st November 2017, 02:08 AM
Today dnf tried to install Linux 4.13.13 the update seemed to run fine, but after I restarted the PC I found that the system was still stuck a Linux 4.12.9.

Thanks in advance for your continued help in this.

antikythera
21st November 2017, 11:05 AM
maybe grubby is broken and needs reinstalling

antikythera
21st November 2017, 11:09 AM
you could try forcing a grub2 update:

for MBR systems - sudo grub2-mkconfig -o /boot/grub2/grub.cfg

for EFI - sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

TablePC
21st November 2017, 02:16 PM
When I run <sudo grubby --default-kernel> I get "error opening /boot/grub/grub.cfg for read: No such file or directory".

I see that grub2 and grub2-efi are installed so I tried <sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg> and got

"/usr/bin/grub2-editenv: error: cannot open `/boot/grub2/grubenv.new': No such file or directory."
and
"/usr/bin/grub2-editenv: error: cannot open `/boot/grub2/grubenv.new': No such file or directory."

I was thinking about doing <dnf reinstall grub2 grub2-efi> but from some things I read online that could result in the config file being put in another location were it can't be found by grub2.

I just did a search and it seems like there is no grub.cfg file on this system.

I guess this might be the right track to pursue, but I have no idea how to continue.

TablePC
6th December 2017, 05:05 PM
Just for information.

Well, I finally tried re-installing grub2 and grubby. After I restarted I got exactly the same result. That is the system was still stuck at Linux 4.12.9-300.

My Fedora 27 disks had arrived, so I installed F27 and everything seems to be okay now. There has even been an update to Linux since the F27 installation and it went fine.

Since I never "adjust" or otherwise fiddle with things like grub or grubby, my guess is that something unhappy happened during one of the old routine daily updates.