PDA

View Full Version : [SOLVED] Install Video Editor



evilbastard
17th November 2017, 12:48 AM
I am trying to install a video editor on Fedora 26. I attempted to compile Cinelerra from source, configure worked, but make failed with following

make[3]: *** [../config/rules/c.mak:47: siod.o] Error 1
make[2]: *** [config/rules/targets.mak:57: siod] Error 2



Tried to install kdenlive via

sudo dnf install kdenlive but get the following:

kdenlive
bash: kdenlive: command not found...
Install package 'kdenlive' to provide command 'kdenlive'? [N/y] y


* Waiting in queue... Failed to install packages: Could not depsolve transaction; 1 problem detected:
0. nothing provides dvdauthor needed by kdenlive-17.04.2-3.fc26.x86_64

Can't find what I need to install for "dvdauthor"

Just want to get a decent video editor installed.

ozjd
17th November 2017, 07:10 AM
dvdauthor is in the Fedora repo so you should have any trouble installing it, https://apps.fedoraproject.org/packages/dvdauthor. Do a dnf clean all first and then try again. You could also check that you haven't inadvertently disabled the Fedora repo.

evilbastard
17th November 2017, 10:27 AM
Tried the dnf clean all still get same error. Not sure how to check if I disabled the repos, it looks like they are still there.

sudo dnf install kdenlive
Adobe Systems Incorporated 7.1 kB/s | 1.9 kB 00:00
Copr repo for elementary-stable owned by decath 69 kB/s | 26 kB 00:00
google-chrome 33 kB/s | 3.8 kB 00:00
RPM Fusion for Fedora 26 - Free - Updates 1.3 MB/s | 369 kB 00:00
RPM Fusion for Fedora 26 - Free 1.7 MB/s | 519 kB 00:00
RPM Fusion for Fedora 26 - Nonfree - Updates 249 kB/s | 34 kB 00:00
RPM Fusion for Fedora 26 - Nonfree 952 kB/s | 158 kB 00:00
Last metadata expiration check: 0:00:00 ago on Fri 17 Nov 2017 04:26:27 AM EST.
Error:
Problem: conflicting requests
- nothing provides dvdauthor needed by kdenlive-17.04.2-3.fc26.x86_64

ozjd
17th November 2017, 10:53 AM
To check the repos you have run dnf repolist. You should have Fedora and Fedora updates

evilbastard
17th November 2017, 11:48 AM
This is what I have:

sudo dnf repolist
Last metadata expiration check: 1:20:51 ago on Fri 17 Nov 2017 04:26:27 AM EST.
repo id repo name status
adobe-linux-x86_64 Adobe Systems Incorporated 3
decathorpe-elementary-stable Copr repo for elementary-stable owned by dec 50
google-chrome google-chrome 3
*rpmfusion-free RPM Fusion for Fedora 26 - Free 536
*rpmfusion-free-updates RPM Fusion for Fedora 26 - Free - Updates 185
*rpmfusion-nonfree RPM Fusion for Fedora 26 - Nonfree 202
*rpmfusion-nonfree-updates RPM Fusion for Fedora 26 - Nonfree - Updates 66

ozjd
17th November 2017, 12:44 PM
As there is no Fedora repos shown that is the cause of your problem. Re-enable them and it should work. You need to edit the Fedora repo file in /etc/yum.repo.d/. I'm not on a computer at the moment so can't tell you exactly what to change but there is a line for enabled that needs to be changed from 0 to 1.

evilbastard
17th November 2017, 02:23 PM
I have tried re-enabling the repos using:

su -c 'dnf install http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm'

[Install RPM Fusion FREE & NON-FREE Repo on Fedora 14 to Fedora 21]
$ su -c 'yum install --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm'

They return the following:
Last metadata expiration check: 0:51:30 ago on Fri 17 Nov 2017 07:31:20 AM EST.
rpmfusion-free-release-26.noarch.rpm 43 kB/s | 20 kB 00:00
rpmfusion-nonfree-release-26.noarch.rpm 3.5 kB/s | 20 kB 00:05
Package rpmfusion-free-release-26-1.noarch is already installed, skipping.
Package rpmfusion-nonfree-release-26-1.noarch is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!

But still get errors when trying to install using dnf.

ozjd
17th November 2017, 09:32 PM
You already have the RPMFusion repos, they don't need to be enabled again. I repeat it is the Fedora repos you are missing.

nsnbm
18th November 2017, 01:12 AM
Sounds like the package: fedora-repos, is the one that needs to be installed.

evilbastard
18th November 2017, 12:27 PM
Not sure why the Fedora repository was missing, but added that, then I had to delete kde_desktop and reinstall it, then I was able to install kdenlive. So problem is solve.