View Full Version : [SOLVED] Peculiar behaviour of "Audio Volume" control System settings

16th November 2017, 11:26 PM
I upgraded from Fedora 26 to 27. I use KDE for the desktop and find some oddities in the System Settings - Audio Volume tool. That indicates the interface is Phonon. Applications using Alsa do not seem to have the same trouble. Alsa-info recognizes the audio setup (realtek on the motherboard) the System Settings - Multimedia - Audio Volume reports "No Devices Available." Using Audacious, the system works as expected. It is using the Alsa output plug-in, and "devices" reports it is using the "default pcm device." Since these were all working prior to the upgrade I suspect the issues are set up trouble or perhaps conflicts between Alsa and Phonon. Any suggestions would be welcom.

21st November 2017, 05:24 PM
Hello JohnDee.

First I will say this,conflicts between Alsa and Phonon? The conflicts can be between Alsa and Pulse Audio sound servers.
For my end part of looking into your issue Phonon is just Bridge between those 2 Sound servers.

Now let's try to break the issues one by one.
I will start first in the "software"options to add plug ins to work with the sound servers.

https://preview.ibb.co/kfBgOR/11.png (https://ibb.co/bvUCV6)

Now if that part do not look like that image...start here,as this will be the base to cover the Audio/Video.

Then Let's start to add all that you need from the software manager - dnfdragora.
the first step will be to Open the software manager,and to mark all the Repo's that you have with software Update.
mark them and at the end just click Apply = To Update the repository's.
After you have done that,start to look for all the missing packages:

1 - Gstreamer - will be your first word to look and to add packages to the stream part.
2 - mpg.
3 - lame.
4 - mp3 - then mp4.
5 - theora.
6 - mingw64/mingw32...Dependence of you Architecture.(about all packages).
7 - quicktime.
8 - xmms - that cover allot of help packages.
9 - ffmpeg.
10 - Audio.
11 -Alsa.

Those search options will cover the support to the Multimedia for you.
Hope that Help you to solve the Sound issues.
Good luck.

24th November 2017, 09:09 AM
I have it working now. Installing the PulseAudio system did the trick. DIgging through my notes from the change to 26, I ran into a similar problem and the same solution. It even communicates with the keyboard functions for audio. Not sure why, but satisfied that it did.