View Full Version : Citrix Receiver (ICAClient) in Fedora 27

16th November 2017, 03:59 PM
Hi All,

Just a heads up to anyone upgrading to Fedora 27 who uses Citrix Receiver (ICAClient): trying to upgrade from F26 -> F27 via dnf will list webkitgtk as a missing dependency as this has been removed from F27. If you remove the ICAClient rpm before your F26 -> F27 upgrade and force install the latest ICAClient (v13.7.0.10276927 - Sep 19, 2017) using "--nodeps" afterwards then ICAClient will still work as expected despite the missing dependency (You probably need webkitgtk4* packages installed):

rpm -ivh --nodeps ICAClient-rhel-

19th November 2017, 07:06 PM
This is the exact problem I just ran into. But I could not remove Citrix in a manner that resolved the issue.

First, I tried:
sudo rpm -e `rpm -qa | grep -i icaclient`
But got an error:

/var/tmp/rpm-tmp.5SNpSb: line 4: /opt/Citrix/ICAClient/util/disintegrate.sh: No such file or directory
error: %preun(ICAClient- scriptlet failed, exit status 127
error: ICAClient- erase failed

Then I used the Citrix install/removal script
./setupwfc, which seemed to work.
But on trying to upgrade with
sudo dnf system-upgrade download --refresh --releasever=27, I got the same Citrix error:

Problem: package ICAClient- requires webkitgtk, but none of the providers can be installed
- webkitgtk-2.4.11-5.fc26.x86_64 does not belong to a distupgrade repository
- problem with installed package ICAClient-
What did you do to remove Citrix?

20th November 2017, 05:04 PM
sudo dnf remove ICAClient*

did the trick for me

20th November 2017, 11:32 PM
OP, can you please post how you installed the webkitgtk4* packages?

21st November 2017, 03:13 PM
OP, can you please post how you installed the webkitgtk4* packages?

It's in the standard repos, it's webkitgtk (aka webkitgtk?3?) which was decommed.

20th December 2017, 04:46 PM
SOLVED in 7 commands.

As root on Fedora 27, install gnucash which comes with webkit1.0 and link to the libraries.

WARNING: webkit1.0 appears to be obsolete and is rumored to have security issues.


sudo dnf -y install gnucash

sudo ln -s gnucash/libwebkitgtk-1.0.so.0.22.17 /lib64
sudo ln -s gnucash/libwebkitgtk-1.0.so.0 /lib64
sudo ln -s gnucash/libwebkitgtk-1.0.so /lib64
sudo ln -s gnucash/libjavascriptcoregtk-1.0.so /lib64
sudo ln -s gnucash/libjavascriptcoregtk-1.0.so.0 /lib64
sudo ln -s gnucash/libjavascriptcoregtk-1.0.so.0.16.19 /lib64

What it looks like:
# cat /etc/redhat-release
Fedora release 27 (Twenty Seven)

# /opt/Citrix/ICAClient/selfservice
selfservice is unable to find a compatible webkit library and will now exit.

# sudo dnf -y install gnucash

#sudo ln -s gnucash/libwebkitgtk-1.0.so.0.22.17 /lib64
#sudo ln -s gnucash/libwebkitgtk-1.0.so.0 /lib64
#sudo ln -s gnucash/libwebkitgtk-1.0.so /lib64
#sudo ln -s gnucash/libjavascriptcoregtk-1.0.so /lib64
#sudo ln -s gnucash/libjavascriptcoregtk-1.0.so.0 /lib64
#sudo ln -s gnucash/libjavascriptcoregtk-1.0.so.0.16.19 /lib64

# /opt/Citrix/ICAClient/selfservice
X11 connection rejected because of wrong authentication.

(selfservice:13247): Gtk-WARNING **: cannot open display: A.B.C.D:0.0

9th May 2018, 10:58 AM
Hello HaydnH,

only ICAClient-rhel needs the webkitgtk, the ICAClientWeb-rhel does not need it.

In fact you probably do not need the full ICAClient-rhel but just the ICAClientWeb-rhel which is client that opens the *.ica files downloaded from ICA server and do the connection as the full ICA client does.

So, just remove the ICAClient-rhel, install ICAClientWeb-rhel from https://www.citrix.com/downloads/citrix-receiver/linux/receiver-for-linux-latest.html and then run upgrade again - it just works.


9th May 2018, 11:14 AM
this is unsafe since the webkitgtk is considered FUBAR and removed from Fedora. Please trust fedora engineers and try to use ICAClientWeb-rhel instead (which does not depend on the webkitgtk).