PDA

View Full Version : Pulse Secure installation problem



AGuerra
16th November 2017, 11:49 AM
Hello guys,

I updated my laptop to Fedora 27, but I'm having problems trying to install PulseSecure.

I know that there is not an official version available but I could follow next steps with Fedora 26... and now with Fedora 27 didn't work:
- Download the .deb version here https://secure.nis.vt.edu/resources/downloads/pulse-8.2R5.i386.deb (with wget)
- Create the .rpm version using Alien (-r -c parameters)
- Try to install with sudo yum install XXX.rmp

The console shows me next error:
sudo yum install pulse-8.2-2.noarch.rpm
Last metadata expiration check: 2:20:53 ago on Thu 16 Nov 2017 09:25:58 AM CET.
Dependencies resolved.
================================================== ==============================
Package Arch Version Repository Size
================================================== ==============================
Installing:
pulse noarch 8.2-2 @commandline 6.3 M

Transaction Summary
================================================== ==============================
Install 1 Package

Total size: 6.3 M
Installed size: 6.3 M
Is this ok [y/N]: y
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Error: Transaction check error:
file / from install of pulse-8.2-2.noarch conflicts with file from package filesystem-3.3-3.fc27.x86_64
file /usr from install of pulse-8.2-2.noarch conflicts with file from package filesystem-3.3-3.fc27.x86_64
file /usr/local from install of pulse-8.2-2.noarch conflicts with file from package filesystem-3.3-3.fc27.x86_64

Error Summary
-------------

Someone can help me with this error?

I can imagine that it's trying to access to ~/usr/local ... and the system shows the conflict... but no idea about how to solve it.

Thanks in advance

nonamedotc
16th November 2017, 02:47 PM
Well, this is always the issue when one tries to use alien to convert deb to rpm. The solution to this would be to use rpmrebuild.

After converting to rpm, do


rpmrebuild -ep package.rpm

It will open up the spec file that generates the rpm. If you navigate close to the bottom of the spec, you will see the "files" section. Under that section, delete the lines



/
/usr
/usr/local


After deleting these lines, exit like you would exit vim and answer 'y' to save the modified rpm. if everything goes well, you should be ready to install the modified rpm.

AGuerra
16th November 2017, 04:53 PM
Hello nonamedotc

Thanks for the information. Finally I could install the package with your help.

Unfortunately, once that I try to open the program, I receive next dependency error:
[aguerra@aguerr53 pulse]$ ./pulseUi
./pulseUi: error while loading shared libraries: libwebkitgtk-1.0.so.0: cannot open shared object file: No such file or directory

I have tried to install that library without success... do you have an idea?

Thanks in advance

AGuerra
16th November 2017, 05:46 PM
I think that I've found the problem

The UI has next dependency: webkitgtk.i686

As i'm using Fedora 27 and this package has been deleted for security reasons, I can't install or use it.

Do you have any other option for it?

Thx!

nonamedotc
16th November 2017, 08:27 PM
Not that I am aware of ... unfortunately. But, you can run Fedora 26 on a virtual machine and run pulse.