PDA

View Full Version : F27 Grub / Nvidia / Weird Problems



TheYetiWakes
15th November 2017, 10:13 PM
Fresh install of F27 and I have a bit of an odd problem kind of in two parts

Installed fine, installed Nvidia stable driver through RPMfusions as usual all ok. On reboot had what seems to be a common problem of really laggy mouse and keyboard input. Searching seems to suggested adding nomodeset to grub solves this. Didn't for me, same problem.

Then by accident I did something odd - after adding nomodeset I was looking at other options, and not meaning to hit CTRL-X to boot without realising I had put a space inbetween q and u of quiet following nomodeset. Anyway, computer booted but grub gave an error saying can't find command q (fair enough!) but it booted with no lag problems and nvidia drivers running fine??? Tried various other things like changing nvidia-drm.modeset=1 to 0, deleting the dot out of it, even randomly pressing enter half way though grub line and it boots as should no problems.

1st problem - What is actually happening in this scenario to stop the lag?

2nd problem - How to make it persistent when I do figure it out?

I tried to edit grub with sudo gedit /etc/default/grub but you now seem to have to use the gedit admin///etc/default/grub instead. Is that correct? I simply added nomodeset here in first instance and then ran sudo grub2-mkconfig to update. This updated it and when I check the file it has saved the change but on bootup grub doesn't seem to read this file? I can hit 'e' to check what its running and its the same default stuff without nomodeset in it?

So - how do I stop the lag without just randomly butchering grub command on each start up and when I do work out what to alter how do I make it persistent across a re-boot?

Standard grub file before any alterations is:


GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet"
GRUB_DISABLE_RECOVERY="true"



On bootup and 'e' there are other commands listed before this part but not sure how I can show that here?

leigh123linux
16th November 2017, 12:30 AM
I enabled modesetting for the nvidia driver to enable full Prime support and wayland for eglstream capable DE's.
The issue is in GDM/Shell, it isn't compiled with eglstream support so shouldn't try to use nvidia wayland

See https://bugzilla.rpmfusion.org/show_bug.cgi?id=4709#c1


sudo grubby --update-kernel=ALL --remove-args='nvidia-drm.modeset=1'

Or you could swap to another DM like lightdm.

TheYetiWakes
16th November 2017, 01:31 AM
I enabled modesetting for the nvidia driver to enable full Prime support and wayland for eglstream capable DE's.
The issue is in GDM/Shell, it isn't compiled with eglstream support so shouldn't try to use nvidia wayland

See https://bugzilla.rpmfusion.org/show_bug.cgi?id=4709#c1


sudo grubby --update-kernel=ALL --remove-args='nvidia-drm.modeset=1'

Or you could swap to another DM like lightdm.

Ok I'll try the code you suggest. To be honest I'm getting more confused about things since Wayland was introduced. Never sure what's using what and when nowadays. It previously had F26 on the machine, didn't that use Wayland as well? I never had this problem before.

How do you change the display managers in 27? Think you could select options on login screen in previous versions couldn't you? I'll have to play more.

Any ideas on why I can't alter the grub file?

leigh123linux
16th November 2017, 01:55 AM
Ok I'll try the code you suggest. To be honest I'm getting more confused about things since Wayland was introduced. Never sure what's using what and when nowadays. It previously had F26 on the machine, didn't that use Wayland as well? I never had this problem before.

The F26 rpmfusion nvidia driver didn't have modesetting enabled so gnome-shell defaulted to Xorg for all gnome sessions.



How do you change the display managers in 27? Think you could select options on login screen in previous versions couldn't you? I'll have to play more.

You change it the same way as F26.


Any ideas on why I can't alter the grub file?

Your system is lagging because it's using mesa software rendering fallback for wayland, running gui apps with sudo isn't permitted under wayland (welcome to gnomes-hell :) ).
After running the command and rebooting you should be able to edit the file.

TheYetiWakes
16th November 2017, 08:47 AM
The F26 rpmfusion nvidia driver didn't have modesetting enabled so gnome-shell defaulted to Xorg for all gnome sessions.




You change it the same way as F26.



Your system is lagging because it's using mesa software rendering fallback for wayland, running gui apps with sudo isn't permitted under wayland (welcome to gnomes-hell :) ).
After running the command and rebooting you should be able to edit the file.


Excellent. Thanks for the time and explanation, much appreciated. I shall try later today when I get the time.

I'm presuming I only have the one display manager currently installed on F27 and will have to install another one if I do want to change it?

What I would like to understand if anyone can help is exactly why it runs fine when I butcher the grub menu on startup - what's actually happening differently in that instance to cause the change and load differently?

Thanks again.

bobx001
21st November 2017, 10:31 PM
I would give Xfce or LXDE a shot. Very stable, settings survive many upgrades, fast and reliable. (I always install directy from the Fedora Spins options)

I do think that Gnome shot itself in the foot long ago by piping all (and I mean *all*) through one single proggy "gnome-shell", adding an inherent bottleneck.
And wayland ? trying to reinvent the wheel using new programming methods which are designed to "use the most amount of resources" is not really what I call a "good idea".
just my 0.02.