PDA

View Full Version : Fedora 27 Fonts Look Different Than Fedora 26



woodsdog
15th November 2017, 03:23 PM
I would like to know what changed with fonts between 26 and 27. I upgraded from 26 to 27. Now my console fonts don't looks as good.

I am using DejaVu Sans Mono. In 27, they are smaller and more pushed together. I didn't do anything, that's just what I have.


I have heard there are new freetype and they are rendering things differently. I don't know if that went into 26 or it is new in 27.

woodsdog
15th November 2017, 05:02 PM
In IRC, they recommend I file a bug. I did

https://bugzilla.redhat.com/show_bug.cgi?id=1513579

antikythera
15th November 2017, 05:09 PM
every upgrade, someone is complaining about the same issue. terminal font rendering seemingly gets worse in some way or other with every release, not sure why they can't just leave terminal fonts alone.

jsnjack
16th November 2017, 11:32 AM
every upgrade, someone is complaining about the same issue. terminal font rendering seemingly gets worse in some way or other with every release, not sure why they can't just leave terminal fonts alone.
I agree! Changing font rendering is very dramatic change. I spent few days trying to get the same font rendering as in old fedoras (I think <22) after upgrading to 26. Ended up using different font. :doh:

nonamedotc
16th November 2017, 02:38 PM
I have taken a liking to levien-inconsolata-fonts for monospace applications. This has been reliable in my experience.

jsnjack
18th November 2017, 02:38 PM
I have taken a liking to levien-inconsolata-fonts for monospace applications. This has been reliable in my experience.
Yes, I also use that one. Has just upgraded to f27 and font rendering did not change.

simonsaysthis
18th November 2017, 02:45 PM
These days, I make sure I don't change anything in font rendering. Using F27 and fonts are great out-of-the-box. We come a long way.

iradu2011
20th November 2017, 04:33 PM
I'm using Mate-Compiz spin and I have noticed a change in fonts as well. However I found an workaround to revert to the previous fonts:
System->Preferences->Look and Feel->Appereance->Fonts and play with the options under "Rendering", including "Details...".