PDA

View Full Version : [SOLVED] Bluetooth error after upgrading from F25 to F26



boycottsystemd
15th November 2017, 02:00 PM
29182


g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.GLib.Error : Traceback (most recent call last):
File "/usr/lib64/python3.6/site-packages/dbus/service.py", line 707, in _message_cb
retval = candidate_method(self, *args, **keywords)
File "/usr/lib/python3.6/site-packages/blueman/main/DbusService.py", line 38, in wrapper
return method(*args[1:], **kwargs)
File "/usr/lib/python3.6/site-packages/blueman/plugins/mechanism/Network.py", line 56, in ReloadNetwork
self.confirm_authorization(caller, "org.blueman.network.setup")
File "/usr/libexec/blueman-mechanism", line 166, in confirm_authorization
action_id, {}, 1, "")
File "/usr/lib64/python3.6/site-packages/gi/overrides/Gio.py", line 172, in __call__
None)
GLib.GError: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.AccessDenie d: An SELinux policy prevents this sender from sending this message to this recipient, 0 matched rules; type="method_call", sender=":1.42" (uid=0 pid=2953 comm="python3 /usr/libexec/blueman-mechanism " label="system_u:system_r:blueman_t:s0") interface="org.freedesktop.PolicyKit1.Authority" member="CheckAuthorization" error name="(unset)" requested_reply="0" destination=":1.8" (uid=999 pid=734 comm="/usr/lib/polkit-1/polkitd --no-debug " label="system_u:system_r:policykit_t:s0") (9)
(36)

Any idea how to fix it ?

amitsark
21st January 2018, 04:26 AM
dnf install blueberry && dnf remove blueman

boycottsystemd
22nd January 2018, 02:37 PM
dnf install blueberry && dnf remove blueman

Thank you, it has solved the issue.