PDA

View Full Version : [SOLVED] Fedora 27 Upgrade gnome-web-photo-0.10.5-9.fc24.x86_64 requires libjavascriptcoregtk-



david.paige
15th November 2017, 03:51 AM
I am experiencing problems upgrading to Fedora 27. I ran dnf upgrade --refresh, and already had the dnf-plugin-system-upgrade installed. However, when I ran nf system-upgrade download --refresh --releasever=27, I received the following errors:



[zebra@ornatecandy ~]$ sudo dnf system-upgrade download --refresh --releasever=27
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Failed to synchronize cache for repo 'region51-chrome-gnome-shell', disabling.
Failed to synchronize cache for repo 'google-chrome', disabling.
Failed to synchronize cache for repo 'home_ktgw0316_LightZone', disabling.
Failed to synchronize cache for repo 'virtualbox', disabling.
Last metadata expiration check: 0:00:00 ago on Tue 14 Nov 2017 06:39:28 PM MST.
Error:
Problem: package gnome-web-photo-0.10.5-9.fc24.x86_64 requires libjavascriptcoregtk-3.0.so.0()(64bit), but none of the providers can be installed
- webkitgtk3-2.4.11-5.fc26.x86_64 does not belong to a distupgrade repository
- problem with installed package gnome-web-photo-0.10.5-9.fc24.x86_64
[zebra@ornatecandy ~]$


I'm not sure how to resolve this issue. I'm trying to figure out what package provides the libjavascriptcoregtk, maybe the webkitgtk3?

Any solutions for solving this issue?

Thank you.

Edit: Examining my system, and looking at the post by shoeper (https://forums.fedoraforum.org/showthread.php?316110-Fedora-27-upgrade-nss-pem-1-0-3-3-fc26-x86_64-does-not-belong-to-a-distupgrade-repos), I uninstalled gnome-web-photo and LightZone, after which the upgrade appears to be progressing normally.