PDA

View Full Version : Streaming video in VLC causes authentication problem after upgrade



rrrssssss
14th November 2017, 10:11 PM
Hello Fedora forum,

A few weeks ago I did a complete system upgrade on Fedora 26 but doing so caused my two media players (VLC and Mplayer) to throw a 401 error message (bad authentication) when streaming video with my Foscam IP camera on my LAN. Usually a dialog window pops up in VLC asking for my username and password for the IP camera, but this dialog window does not pop up now so VLC can't stream the video due to improper authentication. It worked fine before the upgrade. I waited a few weeks and upgraded to Fedora 27 thinking that might fix it but the problem still remains. However, I can still stream video using Firefox via the camera's built-in web server with no problem. Only in VLC or Mplayer does the problem exist. Even if I include the username and password on the command line to start VLC I still get the bad authentication message ( vlc http://username:password@cameraIPaddress:portnumber/videostream.cgi ) VLC is at the latest version from RPM fussion.


I rebooted both my Foscam camera and my network router to eliminate the most obvious causes but it did not resolve the issue.

Should I wait for a future upgrade in hopes this issue will be fixed or does anyone on this forum have any ideas? Would the lua package have anything to do with it?

Thanks much in advance,
Roy

UPDATE - I have narrowed down the problem. Any version of VLC after 3.0.0-0.35 has a bug which causes the problem. There has been two VLC upgrades since this version and each version did not address the problem. The version I am presently using (with the bug) is 3.0.0-0.38.