PDA

View Full Version : Fedora 27 upgrade: nss-pem-1.0.3-3.fc26.x86_64 does not belong to a distupgrade repos



shoeper
14th November 2017, 06:55 PM
I'd like to upgrade to Fedora 27 but currently it doesn't download via console due to the following error:
nss-pem-1.0.3-3.fc26.x86_64 does not belong to a distupgrade repository

Specificially I did make sure everything is up to date with dnf upgrade --refresh and then installed the dnf system upgrade plugin.
Then I ran dnf system-upgrade download --releasever=27 and got the following output:
~ dnf system-upgrade download --releasever=27
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Fedora 27 - x86_64 - Updates 1.6 MB/s | 7.4 MB 00:04
Failed to synchronize cache for repo 'region51-chrome-gnome-shell', disabling.
Failed to synchronize cache for repo 'virtualbox', disabling.
Last metadata expiration check: 0:00:00 ago on Di 14 Nov 2017 18:43:21 CET.
Error:
Problem: nss-pem-1.0.3-3.fc26.i686 has inferior architecture
- nss-pem-1.0.3-3.fc26.x86_64 does not belong to a distupgrade repository
- problem with installed package nss-pem-1.0.3-3.fc26.i686

Simply removing the package does not work. See:
~ dnf remove nss-pem.i686
Dependencies resolved.
================================================== =============================================
Package Arch Version Repository Size
================================================== =============================================
Removing:
nss-pem i686 1.0.3-3.fc26 @@commandline 215 k
Removing dependent packages:
libcurl i686 7.53.1-12.fc26 @updates 541 k
libdbusmenu-gtk2 i686 16.04.0-2.fc26 @@commandline 79 k
libdbusmenu-gtk3 i686 16.04.0-2.fc26 @@commandline 79 k
steam i686 1.0.0.54-10.fc26 @@commandline 2.7 M
Removing unused dependencies:
libXScrnSaver i686 1.2.2-11.fc26 @@commandline 35 k
libatomic i686 7.2.1-2.fc26 @updates 21 k
libdbusmenu i686 16.04.0-2.fc26 @@commandline 531 k
libnghttp2 i686 1.21.1-1.fc26 @@commandline 155 k
libpsl i686 0.18.0-1.fc26 @updates 55 k
libssh2 i686 1.8.0-5.fc26 @updates 197 k
libtxc_dxtn i686 1:1.0.1-2.gitef072983.fc26 @@commandline 19 k
libva-intel-driver i686 1.8.3-2.fc26 @rpmfusion-free-updates 4.2 M

Transaction Summary
================================================== =============================================
Remove 13 Packages

Freed space: 8.7 M
Is this ok [y/N]:

It would remove packages I want to keep.

It does download via Gnome, but I don't trust the Gnome upgrade path. When the console reports an issue before download and Gnome does not even after downloading there needs to be an issue with gnome installer.

Cylon1972
15th November 2017, 08:10 PM
Is your system 64bits (x86_64) or 32 bits?

shoeper
15th November 2017, 08:59 PM
It's a 64-bit system.

satanselbow
15th November 2017, 10:45 PM
I have just upgraded and encountered the same problemette - specifically removing the i686 version of nss-pem will remove several 32 bit dependencies but these are largely incidental on a X64 system UNLESS YOU SPECIFICALLY NEED THE i686 VERSION OF THESE PACKAGES


# dnf remove nss-pem.i686

I then re-ran the download (retaining cache as per wiki) and proceeded with upgrade proper - from which I type this post ;)

Block in capitals is my disclaimer!

You may reinstall steam after the upgrade completes ;)

shoeper
15th November 2017, 11:18 PM
Yes, I also came to the conclusion that removing Steam is most likely to fix the problem. Thank you for your reply! I'll try and give feedback later.

I feel confident, that I get it working but my image of the Gnome Fedora updater has been further damaged.

satanselbow
15th November 2017, 11:30 PM
...my image of the Gnome Fedora updater has been further damaged.

Haven't used it - so can't comment ;)

It is not unusual to have to remove and reinstall certain apps during the upgrade procedure ;) There is no reason to remove your game cache - you may find there is already an update to steam above and beyond that pulled from the repo - grrrr....

shoeper
16th November 2017, 01:32 AM
So far it looks like it worked well.

rweed
19th November 2017, 11:24 PM
Just remove the one nss-pem package:

rpm -e --nodeps nss-pem.i686

reinstall it with dnf when upgrade is complete.