PDA

View Full Version : Flickering in Dark Areas



danyo
12th November 2017, 08:45 PM
Hello everybody,

I've been using Arch Linux and its derivatives for a long time now. But since it happened in the past from time to time that an update did not go through cleanly, and I had to fix the system rather cumbersome, I took a look around for alternatives. Since I got so used to Arch Linux and the current package versions and the Rolling Release, the choice here is not very big.
However, I like Fedora's approach of being close to a rolling release and relying on up-to-date software including a near-current kernel, while being a stable system for productive work.

Now I installed Fedora 26 a few weeks ago. The installation worked without problems. The system ran flawlessly.

What I noticed, however, is that in dark areas of the screen, a slight flicker can be seen. I especially noticed this with the program Darktable, a RAW converter for Linux. But even after opening the terminal application, you can recognize this slight flicker. In bright areas, it probably just does not notice.

I have an Intel board, with Intel i7 processor (Ivy Bridge), a NVIDIA GTX 650 graphics card and have otherwise changed nothing else s.System. So I noticed this right after the basic installation.

Yesterday I tried Fedora 27, but there is the same behavior.

If I run Fedora under VirtualBox, everything is fine. So seems some driver problem? to be.

Under Arch Linux, Antergos or Manjaro I have never noticed this, neither with the Nouveau driver nor with the Nvidia driver. Although I wanted to use only the Nouveau driver at Fedora and have not tried there with the Nvidia driver.

Can someone help me here?

Thanks and regards
danyo

mario960
7th January 2018, 12:07 PM
Hi

I am suffering something very similar. Any good news?
I am on 4.14.6-200.fc26.x86_64

enricota
14th January 2018, 10:11 PM
Hi

Same issue here on Fedora 27 and 4.14.13-300.fc27.x86_64 Kernel

The solution for me is remove the driver installation

$ sudo dnf remove akmod-nvidia.

Tried whit last driver, a file.run from Nvidia site.

$ sudo chmod +x NVIDIA-Linux-x86_64-384.111.run
$ sudo ./NVIDIA-Linux-x86_64-384.111.run

This is last driver for my Nvida Geforce 1050ti.
Attention!! my first boot get a black screen, so I have mod my grub to solve it.

Anyway now work fine ....

To check my video card driver:

$ nvidia-smi


[FDmario@localhost ~]$ nvidia-smi
Sun Jan 14 22:09:37 2018
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 384.111 Driver Version: 384.111
|-------------------------------+----------------------+----------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+==========
| 0 GeForce GTX 105... Off | 00000000:01:00.0 On | N/A |
| 0% 33C P8 ERR! / 75W | 282MiB / 4035MiB | 0% Default |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|======================================
| 0 817 G /usr/libexec/Xorg 164MiB |
| 0 1410 G kwin_x11 20MiB |
| 0 1423 G /usr/bin/krunner 1MiB |
| 0 1424 G /usr/bin/plasmashell 69MiB |
| 0 1912 G /usr/bin/akonadi_archivemail_agent 1MiB |
| 0 1917 G /usr/bin/akonadi_imap_resource 1MiB |
| 0 1918 G /usr/bin/akonadi_imap_resource 1MiB |
| 0 1919 G /usr/bin/akonadi_imap_resource 1MiB |
| 0 1920 G /usr/bin/akonadi_imap_resource 1MiB |
| 0 1921 G /usr/bin/akonadi_imap_resource 1MiB |
| 0 1923 G /usr/bin/akonadi_imap_resource 1MiB |
| 0 1946 G /usr/bin/akonadi_mailfilter_agent 1MiB |
| 0 1963 G /usr/bin/akonadi_sendlater_agent 1MiB |
| 0 2627 G /usr/bin/amarok 6MiB |
+-----------------------------------------------------------------------------+
[FDmario@localhost ~]$