PDA

View Full Version : [SOLVED] Library conflicts with rpmfusion, fedora, and negativo17



mlblandf
6th November 2017, 10:42 PM
Hello,

On my computer, I run Mythtv, zoneminder, and Handbrake. These are pulled from rpmfusion, fedora, and negativo17 repositories respectively. These have all lived in harmony for several years.

Starting a few weeks ago though, I am getting conflicts.



dnf upgrade
Last metadata expiration check: 0:30:54 ago on Mon 06 Nov 2017 01:54:26 PM MST.
Dependencies resolved.

Problem 1: cannot install the best update candidate for package gstreamer1-plugins-bad-free-1.12.3-1.fc26.x86_64
- nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by gstreamer1-plugins-bad-1:1.12.3-2.fc26.x86_64
Problem 2: cannot install the best update candidate for package gstreamer1-plugins-bad-free-gtk-1.12.3-1.fc26.x86_64
- nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by gstreamer1-plugins-bad-1:1.12.3-2.fc26.x86_64
Problem 3: cannot install the best update candidate for package gstreamer1-plugins-bad-freeworld-1.12.3-1.fc26.x86_64
- nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by gstreamer1-plugins-bad-1:1.12.3-2.fc26.x86_64
Problem 4: cannot install the best update candidate for package vlc-3.0.0-0.37.git20171009.fc26.x86_64
- nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by vlc-1:3.0.0-23.20171025gita55b0a5.fc26.x86_64
Problem 5: package mythzoneminder-29.0-1.fc26.x86_64 requires libx265.so.116()(64bit), but none of the providers can be installed
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-2.4-1.fc26.x86_64
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-1:2.4-1.fc26.x86_64
- cannot install both x265-libs-2.4-1.fc26.x86_64 and x265-libs-1:2.5-1.fc26.x86_64
- cannot install the best update candidate for package x265-libs-2.4-1.fc26.x86_64
- cannot install the best update candidate for package mythzoneminder-29.0-1.fc26.x86_64
Problem 6: package mythweather-29.0-1.fc26.x86_64 requires libx265.so.116()(64bit), but none of the providers can be installed
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-2.4-1.fc26.x86_64
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-1:2.4-1.fc26.x86_64
- cannot install both x265-libs-2.4-1.fc26.x86_64 and x265-libs-1:2.5-1.fc26.x86_64
- package HandBrake-cli-1.1.0-3.20171020gitc22e7ed.fc26.x86_64 requires libx265.so.130()(64bit), but none of the providers can be installed
- cannot install the best update candidate for package mythweather-29.0-1.fc26.x86_64
- cannot install the best update candidate for package HandBrake-cli-1.1.0-2.20170819git9fd0481.fc26.x86_64
Problem 7: package mythtv-setup-29.0-1.fc26.x86_64 requires libx265.so.116()(64bit), but none of the providers can be installed
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-2.4-1.fc26.x86_64
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-1:2.4-1.fc26.x86_64
- cannot install both x265-libs-2.4-1.fc26.x86_64 and x265-libs-1:2.5-1.fc26.x86_64
- package HandBrake-gui-1.1.0-3.20171020gitc22e7ed.fc26.x86_64 requires libx265.so.130()(64bit), but none of the providers can be installed
- cannot install the best update candidate for package mythtv-setup-29.0-1.fc26.x86_64
- cannot install the best update candidate for package HandBrake-gui-1.1.0-2.20170819git9fd0481.fc26.x86_64
Problem 8: package mythtv-libs-29.0-1.fc26.x86_64 requires libx265.so.116()(64bit), but none of the providers can be installed
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-2.4-1.fc26.x86_64
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-1:2.4-1.fc26.x86_64
- cannot install both x265-libs-2.4-1.fc26.x86_64 and x265-libs-1:2.5-1.fc26.x86_64
- package ffmpeg-libs-1:3.4-1.fc26.x86_64 requires libx265.so.130()(64bit), but none of the providers can be installed
- cannot install the best update candidate for package mythtv-libs-29.0-1.fc26.x86_64
- cannot install the best update candidate for package ffmpeg-libs-3.3.5-1.fc26.x86_64
Problem 9: problem with installed package vlc-3.0.0-0.37.git20171009.fc26.x86_64
- package vlc-3.0.0-0.37.git20171009.fc26.x86_64 requires vlc-core(x86-64) = 3.0.0-0.37.git20171009.fc26, but none of the providers can be installed
- package vlc-1:3.0.0-22.20170822git954ec0a.fc26.x86_64 requires vlc-core(x86-64) = 1:3.0.0-22.20170822git954ec0a.fc26, but none of the providers can be installed
- cannot install both vlc-core-1:3.0.0-23.20171025gita55b0a5.fc26.x86_64 and vlc-core-3.0.0-0.37.git20171009.fc26.x86_64
- cannot install both vlc-core-1:3.0.0-23.20171025gita55b0a5.fc26.x86_64 and vlc-core-1:3.0.0-22.20170822git954ec0a.fc26.x86_64
- cannot install both vlc-core-3.0.0-0.37.git20171009.fc26.x86_64 and vlc-core-1:3.0.0-23.20171025gita55b0a5.fc26.x86_64
- cannot install the best update candidate for package vlc-core-3.0.0-0.37.git20171009.fc26.x86_64
- nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by vlc-1:3.0.0-23.20171025gita55b0a5.fc26.x86_64
Problem 10: package mythtv-frontend-29.0-1.fc26.x86_64 requires libx265.so.116()(64bit), but none of the providers can be installed
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-2.4-1.fc26.x86_64
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-1:2.4-1.fc26.x86_64
- cannot install both x265-libs-2.4-1.fc26.x86_64 and x265-libs-1:2.5-1.fc26.x86_64
- package x265-1:2.5-1.fc26.x86_64 requires libx265.so.130()(64bit), but none of the providers can be installed
- cannot install the best update candidate for package x265-2.4-1.fc26.x86_64
- cannot install the best update candidate for package mythtv-frontend-29.0-1.fc26.x86_64
Problem 11: package mythtv-common-29.0-1.fc26.x86_64 requires libx265.so.116()(64bit), but none of the providers can be installed
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-2.4-1.fc26.x86_64
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-1:2.4-1.fc26.x86_64
- cannot install both x265-libs-2.4-1.fc26.x86_64 and x265-libs-1:2.5-1.fc26.x86_64
- package ffmpeg-libs-1:3.4-1.fc26.x86_64 requires libx265.so.130()(64bit), but none of the providers can be installed
- package ffmpeg-1:3.4-1.fc26.x86_64 requires ffmpeg-libs(x86-64) = 1:3.4-1.fc26, but none of the providers can be installed
- cannot install the best update candidate for package mythtv-common-29.0-1.fc26.x86_64
- cannot install the best update candidate for package ffmpeg-3.3.5-1.fc26.x86_64
================================================== ==============================
Package Arch Version Repository Size
================================================== ==============================
Upgrading:
vlc x86_64 1:3.0.0-22.20170822git954ec0a.fc26 fedora-multimedia 1.5 M
vlc-core x86_64 1:3.0.0-22.20170822git954ec0a.fc26 fedora-multimedia 8.6 M
x265 x86_64 1:2.4-1.fc26 fedora-multimedia 42 k
x265-libs x86_64 1:2.4-1.fc26 fedora-multimedia 1.7 M
Installing dependencies:
live555-libs x86_64 1:2017.09.12-1.fc26 fedora-multimedia 457 k
replacing live555.x86_64 2017.06.04-1.fc26
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
vlc-core x86_64 1:3.0.0-22.20170822git954ec0a.fc26 fedora-multimedia 8.6 M
vlc-core x86_64 1:3.0.0-23.20171025gita55b0a5.fc26 fedora-multimedia 8.5 M
x265-libs x86_64 1:2.4-1.fc26 fedora-multimedia 1.7 M
x265-libs x86_64 1:2.5-1.fc26 fedora-multimedia 1.7 M
Skipping packages with broken dependencies:
HandBrake-cli
x86_64 1.1.0-3.20171020gitc22e7ed.fc26 fedora-multimedia 4.2 M
HandBrake-gui
x86_64 1.1.0-3.20171020gitc22e7ed.fc26 fedora-multimedia 9.3 M
ffmpeg x86_64 1:3.4-1.fc26 fedora-multimedia 1.6 M
ffmpeg-libs x86_64 1:3.4-1.fc26 fedora-multimedia 6.5 M
gstreamer1-plugins-bad
x86_64 1:1.12.3-2.fc26 fedora-multimedia 2.4 M
vlc x86_64 1:3.0.0-22.20170822git954ec0a.fc26 fedora-multimedia 1.5 M
vlc x86_64 1:3.0.0-23.20171025gita55b0a5.fc26 fedora-multimedia 1.5 M
x265 x86_64 1:2.5-1.fc26 fedora-multimedia 38 k

Transaction Summary
================================================== ==============================
Install 1 Package
Upgrade 4 Packages
Skip 12 Packages

Total download size: 12 M
Is this ok [y/N]:



Checking my current package dependencies doesn't show any problems:

rpm -Va --noscripts --nofiles returns no results

Moving the negativo17 fedora-multimedia repo file out of the way and then doing a dnf upgrade is successful so it seems like conflicting libraries for x265 that is impacting other tools.

I am not sure how to go about resolving this. Has anyone else seen this issue?

robertdaleweir
7th November 2017, 01:20 AM
Hello,

On my computer, I run Mythtv, zoneminder, and Handbrake. These are pulled from rpmfusion, fedora, and negativo17 repositories respectively. These have all lived in harmony for several years.

Starting a few weeks ago though, I am getting conflicts.



dnf upgrade
Last metadata expiration check: 0:30:54 ago on Mon 06 Nov 2017 01:54:26 PM MST.
Dependencies resolved.

Problem 1: cannot install the best update candidate for package gstreamer1-plugins-bad-free-1.12.3-1.fc26.x86_64
- nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by gstreamer1-plugins-bad-1:1.12.3-2.fc26.x86_64
Problem 2: cannot install the best update candidate for package gstreamer1-plugins-bad-free-gtk-1.12.3-1.fc26.x86_64
- nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by gstreamer1-plugins-bad-1:1.12.3-2.fc26.x86_64
Problem 3: cannot install the best update candidate for package gstreamer1-plugins-bad-freeworld-1.12.3-1.fc26.x86_64
- nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by gstreamer1-plugins-bad-1:1.12.3-2.fc26.x86_64
Problem 4: cannot install the best update candidate for package vlc-3.0.0-0.37.git20171009.fc26.x86_64
- nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by vlc-1:3.0.0-23.20171025gita55b0a5.fc26.x86_64
Problem 5: package mythzoneminder-29.0-1.fc26.x86_64 requires libx265.so.116()(64bit), but none of the providers can be installed
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-2.4-1.fc26.x86_64
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-1:2.4-1.fc26.x86_64
- cannot install both x265-libs-2.4-1.fc26.x86_64 and x265-libs-1:2.5-1.fc26.x86_64
- cannot install the best update candidate for package x265-libs-2.4-1.fc26.x86_64
- cannot install the best update candidate for package mythzoneminder-29.0-1.fc26.x86_64
Problem 6: package mythweather-29.0-1.fc26.x86_64 requires libx265.so.116()(64bit), but none of the providers can be installed
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-2.4-1.fc26.x86_64
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-1:2.4-1.fc26.x86_64
- cannot install both x265-libs-2.4-1.fc26.x86_64 and x265-libs-1:2.5-1.fc26.x86_64
- package HandBrake-cli-1.1.0-3.20171020gitc22e7ed.fc26.x86_64 requires libx265.so.130()(64bit), but none of the providers can be installed
- cannot install the best update candidate for package mythweather-29.0-1.fc26.x86_64
- cannot install the best update candidate for package HandBrake-cli-1.1.0-2.20170819git9fd0481.fc26.x86_64
Problem 7: package mythtv-setup-29.0-1.fc26.x86_64 requires libx265.so.116()(64bit), but none of the providers can be installed
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-2.4-1.fc26.x86_64
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-1:2.4-1.fc26.x86_64
- cannot install both x265-libs-2.4-1.fc26.x86_64 and x265-libs-1:2.5-1.fc26.x86_64
- package HandBrake-gui-1.1.0-3.20171020gitc22e7ed.fc26.x86_64 requires libx265.so.130()(64bit), but none of the providers can be installed
- cannot install the best update candidate for package mythtv-setup-29.0-1.fc26.x86_64
- cannot install the best update candidate for package HandBrake-gui-1.1.0-2.20170819git9fd0481.fc26.x86_64
Problem 8: package mythtv-libs-29.0-1.fc26.x86_64 requires libx265.so.116()(64bit), but none of the providers can be installed
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-2.4-1.fc26.x86_64
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-1:2.4-1.fc26.x86_64
- cannot install both x265-libs-2.4-1.fc26.x86_64 and x265-libs-1:2.5-1.fc26.x86_64
- package ffmpeg-libs-1:3.4-1.fc26.x86_64 requires libx265.so.130()(64bit), but none of the providers can be installed
- cannot install the best update candidate for package mythtv-libs-29.0-1.fc26.x86_64
- cannot install the best update candidate for package ffmpeg-libs-3.3.5-1.fc26.x86_64
Problem 9: problem with installed package vlc-3.0.0-0.37.git20171009.fc26.x86_64
- package vlc-3.0.0-0.37.git20171009.fc26.x86_64 requires vlc-core(x86-64) = 3.0.0-0.37.git20171009.fc26, but none of the providers can be installed
- package vlc-1:3.0.0-22.20170822git954ec0a.fc26.x86_64 requires vlc-core(x86-64) = 1:3.0.0-22.20170822git954ec0a.fc26, but none of the providers can be installed
- cannot install both vlc-core-1:3.0.0-23.20171025gita55b0a5.fc26.x86_64 and vlc-core-3.0.0-0.37.git20171009.fc26.x86_64
- cannot install both vlc-core-1:3.0.0-23.20171025gita55b0a5.fc26.x86_64 and vlc-core-1:3.0.0-22.20170822git954ec0a.fc26.x86_64
- cannot install both vlc-core-3.0.0-0.37.git20171009.fc26.x86_64 and vlc-core-1:3.0.0-23.20171025gita55b0a5.fc26.x86_64
- cannot install the best update candidate for package vlc-core-3.0.0-0.37.git20171009.fc26.x86_64
- nothing provides libQt5Core.so.5(Qt_5.9)(64bit) needed by vlc-1:3.0.0-23.20171025gita55b0a5.fc26.x86_64
Problem 10: package mythtv-frontend-29.0-1.fc26.x86_64 requires libx265.so.116()(64bit), but none of the providers can be installed
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-2.4-1.fc26.x86_64
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-1:2.4-1.fc26.x86_64
- cannot install both x265-libs-2.4-1.fc26.x86_64 and x265-libs-1:2.5-1.fc26.x86_64
- package x265-1:2.5-1.fc26.x86_64 requires libx265.so.130()(64bit), but none of the providers can be installed
- cannot install the best update candidate for package x265-2.4-1.fc26.x86_64
- cannot install the best update candidate for package mythtv-frontend-29.0-1.fc26.x86_64
Problem 11: package mythtv-common-29.0-1.fc26.x86_64 requires libx265.so.116()(64bit), but none of the providers can be installed
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-2.4-1.fc26.x86_64
- cannot install both x265-libs-1:2.5-1.fc26.x86_64 and x265-libs-1:2.4-1.fc26.x86_64
- cannot install both x265-libs-2.4-1.fc26.x86_64 and x265-libs-1:2.5-1.fc26.x86_64
- package ffmpeg-libs-1:3.4-1.fc26.x86_64 requires libx265.so.130()(64bit), but none of the providers can be installed
- package ffmpeg-1:3.4-1.fc26.x86_64 requires ffmpeg-libs(x86-64) = 1:3.4-1.fc26, but none of the providers can be installed
- cannot install the best update candidate for package mythtv-common-29.0-1.fc26.x86_64
- cannot install the best update candidate for package ffmpeg-3.3.5-1.fc26.x86_64
================================================== ==============================
Package Arch Version Repository Size
================================================== ==============================
Upgrading:
vlc x86_64 1:3.0.0-22.20170822git954ec0a.fc26 fedora-multimedia 1.5 M
vlc-core x86_64 1:3.0.0-22.20170822git954ec0a.fc26 fedora-multimedia 8.6 M
x265 x86_64 1:2.4-1.fc26 fedora-multimedia 42 k
x265-libs x86_64 1:2.4-1.fc26 fedora-multimedia 1.7 M
Installing dependencies:
live555-libs x86_64 1:2017.09.12-1.fc26 fedora-multimedia 457 k
replacing live555.x86_64 2017.06.04-1.fc26
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
vlc-core x86_64 1:3.0.0-22.20170822git954ec0a.fc26 fedora-multimedia 8.6 M
vlc-core x86_64 1:3.0.0-23.20171025gita55b0a5.fc26 fedora-multimedia 8.5 M
x265-libs x86_64 1:2.4-1.fc26 fedora-multimedia 1.7 M
x265-libs x86_64 1:2.5-1.fc26 fedora-multimedia 1.7 M
Skipping packages with broken dependencies:
HandBrake-cli
x86_64 1.1.0-3.20171020gitc22e7ed.fc26 fedora-multimedia 4.2 M
HandBrake-gui
x86_64 1.1.0-3.20171020gitc22e7ed.fc26 fedora-multimedia 9.3 M
ffmpeg x86_64 1:3.4-1.fc26 fedora-multimedia 1.6 M
ffmpeg-libs x86_64 1:3.4-1.fc26 fedora-multimedia 6.5 M
gstreamer1-plugins-bad
x86_64 1:1.12.3-2.fc26 fedora-multimedia 2.4 M
vlc x86_64 1:3.0.0-22.20170822git954ec0a.fc26 fedora-multimedia 1.5 M
vlc x86_64 1:3.0.0-23.20171025gita55b0a5.fc26 fedora-multimedia 1.5 M
x265 x86_64 1:2.5-1.fc26 fedora-multimedia 38 k

Transaction Summary
================================================== ==============================
Install 1 Package
Upgrade 4 Packages
Skip 12 Packages

Total download size: 12 M
Is this ok [y/N]:



Checking my current package dependencies doesn't show any problems:

rpm -Va --noscripts --nofiles returns no results

Moving the negativo17 fedora-multimedia repo file out of the way and then doing a dnf upgrade is successful so it seems like conflicting libraries for x265 that is impacting other tools.

I am not sure how to go about resolving this. Has anyone else seen this issue?

Hi mlblandf
A couple of things you might try is to run the following two items:

dnf clean all this will clean up all of the downloaded (and cached) updates. Next run
dnf --best --allowerasing distro-sync This will show what 'dnf' sees as compatible versions which "should" be installed. You do not have to actually execute this latter item and if you do PLEASE make a backup before doing so. Cheers...

mlblandf
7th November 2017, 04:48 AM
Thanks for the response.

Unfortunately, doing the dnf distro-sync causes dnf to want to remove a lot of packages:



dnf --best --allowerasing distro-sync
Last metadata expiration check: 0:00:58 ago on Mon 06 Nov 2017 08:42:06 PM MST.
Dependencies resolved.
================================================== ==============================
Package Arch Version Repository Size
================================================== ==============================
Upgrading:
HandBrake-gui x86_64 1.1.0-3.20171020gitc22e7ed.fc26
fedora-multimedia 9.3 M
ffmpeg x86_64 1:3.4-1.fc26 fedora-multimedia 1.6 M
ffmpeg-libs x86_64 1:3.4-1.fc26 fedora-multimedia 6.5 M
gpac-libs x86_64 1:0.7.1-1.fc26 fedora-multimedia 2.1 M
gstreamer1-libav x86_64 1:1.12.3-2.fc26 fedora-multimedia 254 k
gstreamer1-plugins-ugly x86_64 1:1.12.3-2.fc26 fedora-multimedia 264 k
replacing gstreamer1-plugins-ugly-free.x86_64 1.12.3-1.fc26
libavdevice x86_64 1:3.4-1.fc26 fedora-multimedia 65 k
librtmp x86_64 1:2.4-8.20151223gitfa8646d.fc26
fedora-multimedia 74 k
mjpegtools x86_64 2.1.0-7.fc26 fedora-multimedia 611 k
mjpegtools-lav x86_64 2.1.0-7.fc26 fedora-multimedia 72 k
mjpegtools-libs x86_64 2.1.0-7.fc26 fedora-multimedia 154 k
vlc-core x86_64 1:3.0.0-23.20171025gita55b0a5.fc26
fedora-multimedia 8.5 M
vo-amrwbenc x86_64 0.1.3-3.fc26 fedora-multimedia 74 k
x264 x86_64 1:0.148-12.20170521gitaaa9aa8.fc26
fedora-multimedia 62 k
x264-libs x86_64 1:0.148-12.20170521gitaaa9aa8.fc26
fedora-multimedia 583 k
x265 x86_64 1:2.5-1.fc26 fedora-multimedia 38 k
x265-libs x86_64 1:2.5-1.fc26 fedora-multimedia 1.7 M
Installing dependencies:
live555-libs x86_64 1:2017.09.12-1.fc26
fedora-multimedia 457 k
replacing live555.x86_64 2017.06.04-1.fc26
Removing:
gstreamer1-plugins-bad-free
x86_64 1.12.3-1.fc26 @updates 5.6 M
gstreamer1-plugins-bad-free-gtk
x86_64 1.12.3-1.fc26 @updates 48 k
gstreamer1-plugins-bad-freeworld
x86_64 1.12.3-1.fc26 @rpmfusion-free-updates 532 k
vlc x86_64 3.0.0-0.37.git20171009.fc26
@rpmfusion-free-updates 5.3 M
Removing dependent packages:
HandBrake x86_64 1.0.7-3.fc26 @rpmfusion-free 1.2 M
anaconda x86_64 26.21.12-1.fc26 @updates 0
anaconda-gui x86_64 26.21.12-1.fc26 @updates 1.8 M
bijiben x86_64 3.24.2-1.fc26 @updates 1.6 M
cheese x86_64 2:3.24.0-1.fc26 @@commandline 409 k
control-center x86_64 1:3.24.3-1.fc26 @updates 18 M
deja-dup x86_64 36.3-1.fc26 @updates 4.0 M
deja-dup-nautilus x86_64 36.3-1.fc26 @updates 19 k
empathy x86_64 3.12.13-2.fc26 @@commandline 15 M
...... lots of packages removed from the list to fit the post size limit
libzapojit x86_64 0.0.3-10.fc26 @@commandline 107 k
mkvtoolnix-gui x86_64 16.0.0-1.fc26 @updates 7.7 M
mytharchive x86_64 29.0-1.fc26 @rpmfusion-free-updates 18 M
mythbrowser x86_64 29.0-1.fc26 @rpmfusion-free-updates 289 k
mythffmpeg x86_64 29.0-1.fc26 @rpmfusion-free-updates 18 M
mythgallery x86_64 29.0-1.fc26 @rpmfusion-free-updates 758 k
mythgame x86_64 29.0-1.fc26 @rpmfusion-free-updates 682 k
mythmusic x86_64 29.0-1.fc26 @rpmfusion-free-updates 2.3 M
mythnetvision x86_64 29.0-1.fc26 @rpmfusion-free-updates 16 M
mythnews x86_64 29.0-1.fc26 @rpmfusion-free-updates 355 k
mythplugins x86_64 29.0-1.fc26 @rpmfusion-free-updates 18 k
mythtv x86_64 29.0-1.fc26 @rpmfusion-free-updates 13 k
mythtv-backend x86_64 29.0-1.fc26 @rpmfusion-free-updates 6.5 M
mythtv-common x86_64 29.0-1.fc26 @rpmfusion-free-updates 10 M
mythtv-frontend x86_64 29.0-1.fc26 @rpmfusion-free-updates 36 M
mythtv-libs x86_64 29.0-1.fc26 @rpmfusion-free-updates 22 M
mythtv-setup x86_64 29.0-1.fc26 @rpmfusion-free-updates 306 k
mythweather x86_64 29.0-1.fc26 @rpmfusion-free-updates 2.7 M
mythweb noarch 29.0-1.fc26 @rpmfusion-free-updates 3.8 M
mythzoneminder x86_64 29.0-1.fc26 @rpmfusion-free-updates 432 k
openshot noarch 2.4.0-3.fc26 @rpmfusion-free-updates 81 M
openshot-lang noarch 2.4.0-3.fc26 @rpmfusion-free-updates 3.1 M
pidgin x86_64 2.12.0-2.fc26 @@commandline 3.3 M
pidgin-indicator x86_64 1.0-2.fc26 @@commandline 60 k
plasma-desktop x86_64 5.10.5-1.fc26 @updates 27 M
plasma-integration x86_64 5.10.5-1.fc26 @updates 451 k
plasma-lookandfeel-fedora
noarch 5.10.5-3.fc26 @updates 6.1 M
plasma-workspace x86_64 5.10.5-3.fc26 @updates 20 M
plasma-workspace-drkonqi x86_64 5.10.5-3.fc26 @updates 4.8 M
pulseaudio-gdm-hooks x86_64 11.1-2.fc26 @updates 354
python3-libopenshot x86_64 0.1.8-1.fc26 @rpmfusion-free-updates 2.8 M
python3-qt5 x86_64 5.8.1-4.fc26 @updates 6.3 M
python3-qt5-webkit x86_64 5.8.1-4.fc26 @updates 538 k
qt5-qtmultimedia x86_64 5.7.1-5.fc26 @@commandline 3.0 M
shotwell x86_64 0.26.3-1.fc26 @updates 13 M
sushi x86_64 3.24.0-1.fc26 @@commandline 311 k
telepathy-farstream x86_64 0.6.1-8.fc26 @@commandline 195 k
telepathy-haze x86_64 0.8.0-3.fc22 @fedora 231 k
totem x86_64 1:3.24.0-1.fc26 @@commandline 6.5 M
totem-nautilus x86_64 1:3.24.0-1.fc26 @@commandline 31 k
webkitgtk4 x86_64 2.18.0-1.fc26 @updates 45 M
webkitgtk4-plugin-process-gtk2
x86_64 2.18.0-1.fc26 @updates 41 M
yelp x86_64 2:3.22.0-2.fc26 @@commandline 2.2 M
yelp-libs x86_64 2:3.22.0-2.fc26 @@commandline 302 k

Transaction Summary
================================================== ==============================
Install 1 Package
Upgrade 17 Packages
Remove 109 Packages

Total download size: 32 M
Is this ok [y/N]: n
Operation aborted.


If I remove the negativo repository, all is well, but I get reverted to an older version of Handbrake and loose my presets. Having it enabled, wants to remove packages I do use a lot.

Any other thoughts?

robertdaleweir
7th November 2017, 05:21 AM
Hi mlblandf
I had a similar issue with respect to Handbrake and 'gstreamer'. I found that Handbrake came from 'unitedrpms' (and if I remember correctly negitivo17, or whatever as well). After some effort I learned that only certain Repos are smooth with Fedora. The 'koji' repo, I think is OK. The 'unitedrpms' was not, at least at a certain date and time, compatible. If one wants to keep things 'synced' it pays to stick to the basic Repos. Fedora, Fedora Updates, etc. Run
dnf repolist and see which ones you have installed. I have gone off the beaten path and installed certain programs which are not in the mainstream. As such I always do a complete 'backup' and restore if I mess up. You might try 'postinstallerf.noarch' which is avaiIable to assist in installing additional programs and it seems to work OK (just search the forum for specifics) . I have spent many hours playing with various programs and unless you are a 'risk taker' it pays to stick with the main ones Fedora, Fedora Updates, and possibly Koji. Hope this helps...

mlblandf
7th November 2017, 05:55 AM
Here is my current list



dnf repolist
Last metadata expiration check: 1:10:17 ago on Mon 06 Nov 2017 08:42:06 PM MST.
repo id repo name status
adobe-linux-i386 Adobe Systems Incorporated 3
adobe-linux-x86_64 Adobe Systems Incorporated 3
*fedora Fedora 26 - x86_64 53,912
fedora-multimedia negativo17 - Multimedia 413
fedora-steam Steam for Fedora 15
folkswithhats Folks With Hats Repository 30
google-chrome google-chrome 3
google-talkplugin google-talkplugin 1
*rpmfusion-free RPM Fusion for Fedora 26 - Free 536
*rpmfusion-free-updates RPM Fusion for Fedora 26 - Free - Updates 183
*rpmfusion-nonfree RPM Fusion for Fedora 26 - Nonfree 202
*rpmfusion-nonfree-updates RPM Fusion for Fedora 26 - Nonfree - Updates 65
skype-stable skype (stable) 2
*updates Fedora 26 - x86_64 - Updates 10,284
virtualbox Oracle Linux / RHEL / CentOS-26 / x86_64 - Vir 3



These have all worked together for many years. It does all seem related to the netativo17 repository.

It seems like an issue with conflicting x265 libraries. I can see how different projects - mythtv, zoneminder, HandBrake, all use common libraries and one could be updated and break the others.

Cylon1972
7th November 2017, 10:17 AM
Here is my current list



dnf repolist
Last metadata expiration check: 1:10:17 ago on Mon 06 Nov 2017 08:42:06 PM MST.
repo id repo name status
adobe-linux-i386 Adobe Systems Incorporated 3
adobe-linux-x86_64 Adobe Systems Incorporated 3
*fedora Fedora 26 - x86_64 53,912
fedora-multimedia negativo17 - Multimedia 413
fedora-steam Steam for Fedora 15
folkswithhats Folks With Hats Repository 30
google-chrome google-chrome 3
google-talkplugin google-talkplugin 1
*rpmfusion-free RPM Fusion for Fedora 26 - Free 536
*rpmfusion-free-updates RPM Fusion for Fedora 26 - Free - Updates 183
*rpmfusion-nonfree RPM Fusion for Fedora 26 - Nonfree 202
*rpmfusion-nonfree-updates RPM Fusion for Fedora 26 - Nonfree - Updates 65
skype-stable skype (stable) 2
*updates Fedora 26 - x86_64 - Updates 10,284
virtualbox Oracle Linux / RHEL / CentOS-26 / x86_64 - Vir 3



These have all worked together for many years. It does all seem related to the netativo17 repository.

It seems like an issue with conflicting x265 libraries. I can see how different projects - mythtv, zoneminder, HandBrake, all use common libraries and one could be updated and break the others.

What happens when you do dnf update with the negativo-repo disabled?

mlblandf
7th November 2017, 03:47 PM
Hi All,

thanks for the responses.

I did hear back from the negativo17 repository. He has stated the the libraries in the fedora-multimedia repo are NOT compatible with rpmfusion because they upgrade some key packages. He has added a note to the repo page so others will hopefully not run into this same issue.

For now, I will move those packages into a VM.

Thanks for helping me debug this issue.

robertdaleweir
7th November 2017, 05:32 PM
Hi All,

thanks for the responses.

I did hear back from the negativo17 repository. He has stated the the libraries in the fedora-multimedia repo are NOT compatible with rpmfusion because they upgrade some key packages. He has added a note to the repo page so others will hopefully not run into this same issue.

For now, I will move those packages into a VM.

Thanks for helping me debug this issue.

Hi mlblandf
Great. You can mark this thread (solved) from the Thread Tools if you are satisfied with your replies. I guess this is why it is recommended to stick with the recommended Repos. Have a great day:)