PDA

View Full Version : [SOLVED] Permission for Mounting Linux Mint Hard Disk in Fedora 26.



Sethanath
5th November 2017, 06:50 PM
Hi,

I am Linux Mint user, but I want to learn how to use Fedora 26. I am going to install Fedora 26 on my notebook. However, I have EXT4 external hard drive, that need to be mounted to my fresh installation of Fedora 26 notebook.

I do understand that Fedora and Linux Mint use different security permission, but I forgot those numbering.

I hope you can give me steps how to.

Thank you so much.

rockdoctor
6th November 2017, 12:02 AM
I believe the only significant difference you'll find is that Fedora will automount the external hard drive at
/run/media/<user-name> whereas Mint will automount an external hard drive at
media/<user-name>.

Sethanath
6th November 2017, 01:23 AM
Hi there,

I have done something like this long time ago. It used to be the combination of UID and GroupID, or else I won't be able to use any files on my EXT4 external hard disk.

It has been quite some time, and I really forget. I hope you can help.

sidebrnz
6th November 2017, 02:17 AM
If you're going to have the partition always mounted at boot, or want to make sure that it's always in the same place, create a mount point and add an entry for it to /etc/fstab. If it's not always going to be there, simply use noauto as one of your mount options. And, it's probably a good idea to include umask=0000 in the options as well, to make sure it doesn't get mounted read only. (Yes, you can include r/w, but this seems to work far more reliably.)

Sethanath
6th November 2017, 04:48 PM
About eight years ago, I learned that Ubuntu, Linux Mint, and Debian would use a range of UID and GroupID. However, Fedora would use the difference range of UID and such. If I want to use those files (Read, write, or executable), which are stored on external hard disk, formated through Linux Mint OS, I would need to change UID and GroupID on those files, first.

Maybe, things have been change since then :)

Right now, my fresh installation of Fedora 26 is unusable, so I will need to wait until Fedora 27 released. I can't install Fedora 25 or 26 on my Compaq Presario F763NR. However, this same laptop was used with Linux Mint for eight years now.

I hope it would work for Fedora 27.

Thank you so much.

Sethanath
7th November 2017, 06:43 PM
Hi Everyone,

I have just installed Fedora 25 on my Compaq Presario F763NR, as I could not get fedora 26 to work at all. I tried both net installation and live media, but neither would work. Net installation seems to work better than live media, but still I could not get it to work.

Now, all of you are right. I am able to mount Linux Mint hard disk.

Thank you so much for your time.