View Full Version : Odd problem with GParted

5th November 2017, 12:35 AM
Back when I first set this computer up with Linux, it was dual boot, Win98 and Linux. I haven't needed to boot into Win98 in over a decade, but the partition's still there to give me access to various old files, a few of which I still use. However, I left myself way too much room, and now I want to recover most of it, moving it to the next partition out, which is mounted as /home. My plan was to use GParted to shrink the old partition just before I rebooted for a new kernel, and later make a LiveUSB key to enlarge /home, being sure to make a backup just before rebooting.

Alas, the first step doesn't work. If I unmount that partition before starting GParted, the program hangs, goes dark to show that it's working its little tail off, then vanishes without leaving a crash report. If the partition's mounted, all goes well until I select it and unmount it, at which time it goes through the same process as above. Every, single time, both before and after the needed reboot for a new kernel. I now have a Live system I could boot into, but I'd like to look into this first, to see if there's anything wrong with that partition, or if I need to do anything first.

I should add that I've tried unmount a different (ext4) partition from GParted and remounting it, without trouble. Also, the option to Resize/Move is grayed out on the FAT32 partition, but not on the other one I experimented with.

5th November 2017, 04:14 AM
Update: on a hunch, I unmounted the FAT32 partition and ran fsck. There were enough errors that I killed it and am currently running fsck -a on it. From what I can tell, there are a large number of errors in the short filenames in /windows/system32, and that might be what's wrong. Once it's done, I'll see if GParted works, and report back.

6th November 2017, 04:38 AM
Specifically, the complete directory \windows\system\mui is completely munged, and every single cluster is getting renamed as a separate file, making for thousands and thousands of them. Also, every time I try to delete a file in that directory, the partition gets remounted as Read Only, and I have to remount it. I have lots and lots of unpartitioned free space, so I think I'm going to create a new partition, format it as FAT32 and copy over everything I can salvage. (If some of the lost files are essential to boot, I don't care, as I haven't booted Win98 in about a decade.) Then, I'll unmount the old partition and reformat it from a CLI because I doubt that GParted can manage it right now. This will keep the UUID and label intact, so that once I copy things back, I won't have to edit /etc/fstab.

I'm not marking this as SOLVED, because I never managed to find out what happened, but I have worked out a way to recover as much as I can, and I'll report back later on how it went in case anybody else is ever interested.

6th November 2017, 04:52 AM
(If some of the lost files are essential to boot, I don't care, as I haven't booted Win98 in about a decade.)

Two things here.
[1] I would call this thread as "Odd problem with Win98 partition";
[2] Text in red really asked for troubles... Lot of troubles! :D


6th November 2017, 05:07 AM
Well, when I first posted, I thought it was a GParted issue. And, I've been running Fedora as my only OS on this box since Fedora 9 came out, and have no reason to expect that I'm ever going to boot Windows on it again. The partition is mostly there to keep files that I may want some day, such as lots and lots of archives full of potentially interesting stuph.

6th November 2017, 08:53 AM
The fact the HDD is still working is surprising if the W98 partition is that badly corrupted, especially given the age of the drive if you use the PC regularly. It may be prudent to invest in a new drive from the black friday sales just in case it dies on you completely and a SATA to PATA adaptor? I'm not a huge fan of SMART diags. but if you run them I'd hazard a guess they will give pre-fail warnings.

6th November 2017, 09:06 AM
"Age of the drive?" This entire installation was moved to a new, 465 GB drive about a year ago or so. At the time, the old partition must have still been fine because there wasn't the slightest difficulty moving it across, and I'm not sure if the old drive was the original one either. Conceptually, it's still the same computer, even though I don't think there's still any of the original parts left. And, this box is on 24/7 unless there's either a power outage or a hardware issue that can't be dealt with any other way.

6th November 2017, 12:24 PM
the way your posts were worded I thought you were still on the original HDD. the drive should be okay but it is still worth looking into. the transfer program may have just copied sector by sector and brought with it any existing file system errors from the older drive.